aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-mac
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-09 10:01:59 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-09 10:01:59 +0000
commitcd19a89bf8047d4da6e820b683355fd91d736141 (patch)
tree02f13792b6d5fe08b400f338dd972e01726af348 /audio/xmms-mac
parent9811e3fbb9f2ad3939e249efba08ad4cac57758c (diff)
downloadports-cd19a89bf8047d4da6e820b683355fd91d736141.tar.gz
ports-cd19a89bf8047d4da6e820b683355fd91d736141.zip
Add xmms-mac 0.2.1, monkey's Audio Codec non-win32 port.
PR: ports/78303
Notes
Notes: svn path=/head/; revision=130699
Diffstat (limited to 'audio/xmms-mac')
-rw-r--r--audio/xmms-mac/Makefile36
-rw-r--r--audio/xmms-mac/distinfo2
-rw-r--r--audio/xmms-mac/files/patch-aa11
-rw-r--r--audio/xmms-mac/pkg-descr13
-rw-r--r--audio/xmms-mac/pkg-plist1
5 files changed, 63 insertions, 0 deletions
diff --git a/audio/xmms-mac/Makefile b/audio/xmms-mac/Makefile
new file mode 100644
index 000000000000..32ef367c6b6f
--- /dev/null
+++ b/audio/xmms-mac/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: xmms-mac
+# Date Created: 23 February 2005
+# Whom: <arundel@h3c.de>
+#
+# $FreeBSD$
+
+PORTNAME= mac
+PORTVERSION= 0.2.1
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= mac-port
+PKGNAMEPREFIX= xmms-
+DISTNAME= xmms-${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= arundel@h3c.de
+COMMENT= Monkey's Audio Codec non-win32 port
+
+BUILD_DEPENDS= mac:${PORTSDIR}/audio/mac
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms
+
+USE_X_PREFIX= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_AUTOCONF_VER= 259
+
+WRKSRC= ${WRKDIR}/libxmms-mac
+
+TARGET_DIR= ${PREFIX}/lib/xmms/Input
+
+PROG_FILES= ${WRKSRC}/src/.libs/libxmms-mac.so.1
+
+do-install:
+ ${INSTALL} -d ${TARGET_DIR}
+ ${INSTALL_PROGRAM} ${PROG_FILES} ${TARGET_DIR}/libxmms-mac.so
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-mac/distinfo b/audio/xmms-mac/distinfo
new file mode 100644
index 000000000000..0426446436ae
--- /dev/null
+++ b/audio/xmms-mac/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-mac-0.2.1.tar.gz) = 67737a3d0fdf15db894497eb64673dea
+SIZE (xmms-mac-0.2.1.tar.gz) = 273451
diff --git a/audio/xmms-mac/files/patch-aa b/audio/xmms-mac/files/patch-aa
new file mode 100644
index 000000000000..f7d24828f2a2
--- /dev/null
+++ b/audio/xmms-mac/files/patch-aa
@@ -0,0 +1,11 @@
+--- configure.in.orig Mon Feb 28 14:51:53 2005
++++ configure.in Mon Feb 28 14:51:37 2005
+@@ -44,7 +44,7 @@
+
+ AC_CHECK_LIB(mac, DecompressFile, [])
+
+-MAC_LIBS="-lmac"
++MAC_LIBS="-lmac -lpthread"
+ MAC_INCLUDES="-I/usr/include/mac"
+ MAC_CXXFLAGS="-s -O3 -Wall -pedantic -DBUILD_CROSS_PLATFORM"
+
diff --git a/audio/xmms-mac/pkg-descr b/audio/xmms-mac/pkg-descr
new file mode 100644
index 000000000000..3d42692d0778
--- /dev/null
+++ b/audio/xmms-mac/pkg-descr
@@ -0,0 +1,13 @@
+Monkey's Audio is a fast and easy way to compress digital music.
+Unlike traditional methods such as mp3, ogg, or lqt that permanently
+discard quality to save space, Monkey's Audio only makes perfect,
+bit-for-bit copies of your music. That means it always sounds perfect
+- exactly the same as the original. Even though the sound is perfect,
+it still saves a lot of space. (think of it as a beefed-up Winzip^(TM)
+for your music) The other great thing is that you can always decompress
+your Monkey's Audio files back to the exact, original files. That way,
+you'll never have to recopy your CD collection to switch formats, and
+you'll always be able to recreate the original music CD if something
+ever happens to yours.
+
+WWW: http://www.monkeysaudio.com/
diff --git a/audio/xmms-mac/pkg-plist b/audio/xmms-mac/pkg-plist
new file mode 100644
index 000000000000..ec8a66667934
--- /dev/null
+++ b/audio/xmms-mac/pkg-plist
@@ -0,0 +1 @@
+lib/xmms/Input/libxmms-mac.so