aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-sapplug
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-21 11:18:33 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2011-06-21 11:18:33 +0000
commit62ecbd72055eaef64811ed496a0172acc7d9c98d (patch)
tree39cb0fabf26456ce2b4b784048859008cebdce91 /audio/xmms-sapplug
parent4e92d29b149c79c4dbb3ddcf454dde2215b2bac3 (diff)
downloadports-62ecbd72055eaef64811ed496a0172acc7d9c98d.tar.gz
ports-62ecbd72055eaef64811ed496a0172acc7d9c98d.zip
Fix build with clang and fix some new portlint warnings.
Notes
Notes: svn path=/head/; revision=275983
Diffstat (limited to 'audio/xmms-sapplug')
-rw-r--r--audio/xmms-sapplug/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/xmms-sapplug/Makefile b/audio/xmms-sapplug/Makefile
index 09bd440798c6..c9f793883e41 100644
--- a/audio/xmms-sapplug/Makefile
+++ b/audio/xmms-sapplug/Makefile
@@ -16,14 +16,13 @@ MAINTAINER= ehaupt@FreeBSD.org
COMMENT= XMMS input plugin for playing 8bit Atari(TM) .sap audio files
BUILD_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= xmms:${PORTSDIR}/multimedia/xmms
USE_GMAKE= yes
USE_GNOME= glib12
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
-CXXFLAGS+= --no-exceptions
WRKSRC= ${WRKDIR}/sapplug-${DISTVERSION}
LICENSE= GPLv2
@@ -34,6 +33,10 @@ OPTIONS= OPTIMIZED_CXXFLAGS "use optimized C++ flags" on \
.include <bsd.port.pre.mk>
+.if ${CXX:T} != "clang++"
+CXXFLAGS+= --no-exceptions
+.endif
+
.if defined(WITH_OPTIMIZED_CXXFLAGS)
CXXFLAGS+= -fPIC -fpic -funroll-all-loops -fno-strength-reduce \
-finline-functions -fomit-frame-pointer