aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-scrobbler
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-12-06 22:19:28 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-12-06 22:19:28 +0000
commitf5744334fa7daac4f27c460016c4b47521e63264 (patch)
treedd5604729760fa54f3a47e433f3b431a5d18955a /audio/xmms-scrobbler
parent0d1f1da4addebd64e8b06c5abe9c1603854d6ba4 (diff)
downloadports-f5744334fa7daac4f27c460016c4b47521e63264.tar.gz
ports-f5744334fa7daac4f27c460016c4b47521e63264.zip
Add xmms-scrobbler, a XMMS/BPM Plugin for audioscrobbler.com
Notes
Notes: svn path=/head/; revision=123343
Diffstat (limited to 'audio/xmms-scrobbler')
-rw-r--r--audio/xmms-scrobbler/Makefile27
-rw-r--r--audio/xmms-scrobbler/distinfo2
-rw-r--r--audio/xmms-scrobbler/pkg-descr5
-rw-r--r--audio/xmms-scrobbler/pkg-plist4
4 files changed, 38 insertions, 0 deletions
diff --git a/audio/xmms-scrobbler/Makefile b/audio/xmms-scrobbler/Makefile
new file mode 100644
index 000000000000..4af3f79c40ed
--- /dev/null
+++ b/audio/xmms-scrobbler/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: xmms-scrobbler
+# Date created: 2004-12-06
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= xmms-scrobbler
+PORTVERSION= 0.3.5.1
+CATEGORIES= audio
+MASTER_SITES= http://www.pipian.com/stuffforchat/
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= XMMS and bmp plugin for Audioscrobbler.com
+
+LIB_DEPENDS= xmms.4:${PORTSDIR}/multimedia/xmms \
+ beep.2:${PORTSDIR}/multimedia/beep-media-player \
+ musicbrainz.4:${PORTSDIR}/audio/libmusicbrainz \
+ curl.3:${PORTSDIR}/ftp/curl
+
+GNU_CONFIGURE= yes
+USE_GNOME= gtk12 gtk20
+USE_BZIP2= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/audio/xmms-scrobbler/distinfo b/audio/xmms-scrobbler/distinfo
new file mode 100644
index 000000000000..ee82b3060011
--- /dev/null
+++ b/audio/xmms-scrobbler/distinfo
@@ -0,0 +1,2 @@
+MD5 (xmms-scrobbler-0.3.5.1.tar.bz2) = 1355a91ddb3e9d756a40bf230bdd834f
+SIZE (xmms-scrobbler-0.3.5.1.tar.bz2) = 251445
diff --git a/audio/xmms-scrobbler/pkg-descr b/audio/xmms-scrobbler/pkg-descr
new file mode 100644
index 000000000000..0fc7b09dbcb2
--- /dev/null
+++ b/audio/xmms-scrobbler/pkg-descr
@@ -0,0 +1,5 @@
+This is an XMMS and BMP Plugin which sends the Playlist data to
+audioscrobbler.com
+
+WWW: http://www.audioscrobbler.com
+Author: pipian@pipian.com
diff --git a/audio/xmms-scrobbler/pkg-plist b/audio/xmms-scrobbler/pkg-plist
new file mode 100644
index 000000000000..b8178b5743db
--- /dev/null
+++ b/audio/xmms-scrobbler/pkg-plist
@@ -0,0 +1,4 @@
+lib/bmp/General/libbmp_scrobbler.la
+lib/bmp/General/libbmp_scrobbler.so
+lib/xmms/General/libxmms_scrobbler.so
+lib/xmms/General/libxmms_scrobbler.la