aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms-uade/files
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2003-02-19 23:43:38 +0000
committerMartin Blapp <mbr@FreeBSD.org>2003-02-19 23:43:38 +0000
commitc6e2c6d3c6787c76c1400f590eae9f3324a6f22b (patch)
treebc792284550e099029b40ba544cbf462a0488fdc /audio/xmms-uade/files
parent99f6f324e248edf72bd3fa5e998a3f111de05b99 (diff)
downloadports-c6e2c6d3c6787c76c1400f590eae9f3324a6f22b.tar.gz
ports-c6e2c6d3c6787c76c1400f590eae9f3324a6f22b.zip
Update to 0.80 pre3. More stability, more module support, and
something against the war. All core developers told me not to use the old version, so here it is: the recent uade.
Notes
Notes: svn path=/head/; revision=75915
Diffstat (limited to 'audio/xmms-uade/files')
-rw-r--r--audio/xmms-uade/files/patch-Makefile.in23
-rw-r--r--audio/xmms-uade/files/patch-configure160
-rw-r--r--audio/xmms-uade/files/patch-osdep+strltest.c12
-rw-r--r--audio/xmms-uade/files/patch-plugindir+Makefile.in11
-rw-r--r--audio/xmms-uade/files/patch-src+Makefile.in11
-rw-r--r--audio/xmms-uade/files/patch-src+memory.c10
6 files changed, 65 insertions, 162 deletions
diff --git a/audio/xmms-uade/files/patch-Makefile.in b/audio/xmms-uade/files/patch-Makefile.in
new file mode 100644
index 000000000000..161ff3dab791
--- /dev/null
+++ b/audio/xmms-uade/files/patch-Makefile.in
@@ -0,0 +1,23 @@
+--- Makefile.in.orig Sat Feb 15 18:28:42 2003
++++ Makefile.in Sun Feb 16 01:18:56 2003
+@@ -1,6 +1,7 @@
+ # Top-level Makefile for UADE
+
+ MAKE = {MAKE}
++CFLAGS = {SYSCFLAGS}
+
+ FINALBINDIR = {BINDIR}
+ FINALDATADIR = {DATADIR}
+@@ -16,10 +17,10 @@
+ @test "{USEXMMS}" = "no" || $(MAKE) plugin
+
+ uade-bin:
+- @ cd src && $(MAKE)
++ @ cd src && CFLAGS='$(CFLAGS)' $(MAKE)
+
+ plugin:
+- @ cd plugindir && $(MAKE)
++ @ cd plugindir && CFLAGS='$(CFLAGS)' $(MAKE)
+
+ config.h:
+ @echo ""
diff --git a/audio/xmms-uade/files/patch-configure b/audio/xmms-uade/files/patch-configure
index 54d0e3b6b50c..38fa9970d138 100644
--- a/audio/xmms-uade/files/patch-configure
+++ b/audio/xmms-uade/files/patch-configure
@@ -1,142 +1,6 @@
---- configure.orig Mon Jan 6 02:56:29 2003
-+++ configure Fri Jan 24 00:44:31 2003
-@@ -8,38 +8,72 @@
- usexmms=yes
- xmmsinputplugindir=automatic
-
--for arg
--do
--
--if expr "$arg" : "--prefix=.*" > /dev/null;then
-- prefix=`echo $arg | sed -n 's/--prefix=\(.*\)/\1/p'`
-- echo $prefix
--fi
--
--if expr "$arg" : "--package-prefix=.*" > /dev/null;then
-- packageprefix=`echo $arg | sed -n 's/--package-prefix=\(.*\)/\1/p'`
-- if test "$prefix" = "$HOME/.xmms"; then
-- echo
-- echo "with --package-prefix you must give a global installation prefix first..."
-- echo "example: --prefix=/usr/local --package-prefix=/tmp/foobar"
-- echo
-- exit
-- fi
--fi
--
--if expr "$arg" : "--mymods=.*" > /dev/null;then
-- mymods=`echo $arg | sed -n 's/--mymods=\(.*\)/\1/p'`
-- mod=1
--fi
--
--if expr "$arg" : "--input-plugin-dir=.*" > /dev/null;then
-- xmmsinputplugindir=`echo $arg | sed -n 's/--input-plugin-dir=\(.*\)/\1/p'`
--fi
--
--if expr "$arg" : "--no-plugin" > /dev/null;then
-- usexmms=no
--fi
--
-+for _switch ; do
-+ case $_switch in
-+ --prefix=*)
-+ prefix=`echo $1 | sed -n 's/--prefix=\(.*\)/\1/p'`
-+ shift;
-+ ;;
-+ --binprefix=*)
-+ binprefix=`echo $1 | sed -n 's/--binprefix=\(.*\)/\1/p'`
-+ shift;
-+ ;;
-+ --docprefix=*)
-+ docprefix=`echo $1 | sed -n 's/--docprefix=\(.*\)/\1/p'`
-+ shift;
-+ ;;
-+ --package-prefix=*)
-+ packageprefix=`echo $1 | sed -n 's/--package-prefix=\(.*\)/\1/p'`
-+ if test "$prefix" = "$HOME/.xmms"; then
-+ echo
-+ echo "with --package-prefix you must give a global installation prefix first..."
-+ echo "example: --prefix=/usr/local --package-prefix=/tmp/foobar"
-+ echo
-+ exit
-+ else
-+ shift;
-+ fi
-+ ;;
-+ --input-plugin-dir=*)
-+ xmmsinputplugindir=`echo $1 | sed -n 's/--input-plugin-dir=\(.*\)/\1/p'`
-+ shift;
-+ ;;
-+ --mymods=*)
-+ mymods=`echo $1 | sed -n 's/--mymods=\(.*\)/\1/p'`
-+ mod=1
-+ shift;
-+ ;;
-+ --no-plugin)
-+ usexmms=no
-+ shift;
-+ ;;
-+ --with-sdl)
-+ SDL=yes
-+ shift;
-+ ;;
-+ --help)
-+ echo
-+ echo "Usage: --prefix=path if you don't want this installed in /usr/local."
-+ echo " --no-plugin if you don't want to have an xmms plugin"
-+ echo " --input-plugin-dir=path where path is the xmms input plugin"
-+ echo " directory"
-+ echo " --mymods=path where path is the default mod directory for "
-+ echo " pwraps tk interface. Default path is homedir."
-+ echo " --with-sdl use SDL rather than native audio for sound output."
-+ echo
-+ exit
-+ ;;
-+ --x-libraries=*)
-+ shift;
-+ ;;
-+ --x-includes=*)
-+ shift;
-+ ;;
-+ *)
-+ ;;
-+ esac
-+done
-+
- if test "$usexmms" = "yes"; then
- if test -x "`which xmms-config`"; then
- echo > /dev/null
-@@ -47,30 +81,8 @@
- usexmms=no
- echo "Couldn't find xmms-plugin => not compiling xmms-plugin!"
- fi
--
- fi
-
--if test "$arg" = "--with-sdl";then
--SDL=yes
--fi
--
--if test "$arg" = "--help";then
--echo
--echo "Usage: --prefix=path if you don't want this installed in /usr/local."
--echo " --no-plugin if you don't want to have an xmms plugin"
--echo " --input-plugin-dir=path where path is the xmms input plugin"
--echo " directory"
--echo " --mymods=path where path is the default mod directory for "
--echo " pwraps tk interface. Default path is homedir."
--echo " --with-sdl use SDL rather than native audio for sound output."
--echo
--exit 1
--break
--fi
--
--
--done
--
- if [ -f src/sd-sound.c ];then
- rm src/sd-sound.c
- fi
-@@ -171,18 +183,34 @@
+--- configure.orig Sat Feb 15 18:28:42 2003
++++ configure Sun Feb 16 01:13:28 2003
+@@ -189,18 +189,34 @@
if test "$prefix" = "$HOME/.xmms"; then
uadedatadir="$prefix/uade"
@@ -175,7 +39,15 @@
fi
if test "$xmmsinputplugindir" != "automatic"; then
-@@ -242,10 +270,10 @@
+@@ -247,6 +263,7 @@
+
+ sed -e "s|{DATADIR}|$uadedatadir|" \
+ -e "s|{MAKE}|$MAKE|" \
++ -e "s|{SYSCFLAGS}|$SYSCFLAGS|" \
+ -e "s|{BINDIR}|$bindir|" \
+ -e "s|{DOCDIR}|$docdir|" \
+ -e "s|{USEXMMS}|$usexmms|" \
+@@ -261,10 +278,10 @@
-e "s|{UADEVERSION}|$VERSION|" \
osdep/uadeconfig-unix.h.in > osdep/uadeconfig.h
@@ -190,3 +62,11 @@
XMMSFLAGS=`xmms-config --cflags`
XMMSLIBS=`xmms-config --libs`
INCLUDEFLAG="-I$includedir"
+@@ -275,6 +292,7 @@
+ -e "s|{GTKFLAGS}|$GTKFLAGS|" -e "s|{GTKLIBS}|$GTKLIBS|" \
+ -e "s|{XMMSFLAGS}|$XMMSFLAGS|" -e "s|{XMMSLIBS}|$XMMSLIBS|" \
+ -e "s|{INCLUDEFLAG}|$INCLUDEFLAG|" -e "s|{LIBFLAG}|$LIBFLAG|" \
++ -e "s|{SYSCFLAGS}|$SYSCFLAGS|" \
+ -e "s|{PLUGINDIR}|$plugin|" \
+ -e "s|{PACKAGEPREFIX}|$packageprefix|" \
+ -e "s|{VERSION}|$VERSION|" \
diff --git a/audio/xmms-uade/files/patch-osdep+strltest.c b/audio/xmms-uade/files/patch-osdep+strltest.c
deleted file mode 100644
index 2078a6030744..000000000000
--- a/audio/xmms-uade/files/patch-osdep+strltest.c
+++ /dev/null
@@ -1,12 +0,0 @@
---- osdep/strltest.c.orig Fri Jan 24 00:04:54 2003
-+++ osdep/strltest.c Fri Jan 24 00:07:05 2003
-@@ -5,7 +5,7 @@
- int
- main(void)
- {
-- char a[2];
-- strlcpy(a, "666", sizeof(a));
-+ char a[10];
-+ strlncat(a, "666", 3);
- return 0;
- }
diff --git a/audio/xmms-uade/files/patch-plugindir+Makefile.in b/audio/xmms-uade/files/patch-plugindir+Makefile.in
new file mode 100644
index 000000000000..31aa2a84c86b
--- /dev/null
+++ b/audio/xmms-uade/files/patch-plugindir+Makefile.in
@@ -0,0 +1,11 @@
+--- plugindir/Makefile.in.orig Sun Feb 16 01:24:20 2003
++++ plugindir/Makefile.in Sun Feb 16 01:24:28 2003
+@@ -26,7 +26,7 @@
+
+ UADEDEPS = uade.h defaults.h gui.h ../decrunch/decrunch.h
+ INCLUDEFLAGS = -I. -I../osdep -I../src/include $(GLIBFLAGS) $(GTKFLAGS) $(XMMSFLAGS) $(INCLUDEFLAG)
+-CFLAGS = -O2 -DHAVE_CONFIG_H -D_REENTRANT -DVERSION=\"$(VERSION)\" -W -Wall
++CFLAGS += -O2 -DHAVE_CONFIG_H -D_REENTRANT -DVERSION=\"$(VERSION)\" -W -Wall
+ LDFLAGS = $(LIBFLAG) $(GLIBLIBS) $(XMMSLIBS)
+
+ LIBTOOL = libtool
diff --git a/audio/xmms-uade/files/patch-src+Makefile.in b/audio/xmms-uade/files/patch-src+Makefile.in
new file mode 100644
index 000000000000..c6015023a206
--- /dev/null
+++ b/audio/xmms-uade/files/patch-src+Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun Feb 16 01:15:38 2003
++++ src/Makefile.in Sun Feb 16 01:15:48 2003
+@@ -3,7 +3,7 @@
+ ARCHFLAGS =
+
+ CTFLAGS = -fomit-frame-pointer -Wall -Wno-unused -Wno-format -W -Wmissing-prototypes -Wstrict-prototypes -DGCCCONSTFUNC="__attribute__((const))" -D_REENTRANT -fno-exceptions -fno-strength-reduce -DREGPARAM= -D__inline__=inline $(ARCHFLAGS)
+-CFLAGS = -O2 $(CTFLAGS)
++CFLAGS += -O2 $(CTFLAGS)
+
+ SDLLIBS=
+ SDLFLAGS=
diff --git a/audio/xmms-uade/files/patch-src+memory.c b/audio/xmms-uade/files/patch-src+memory.c
deleted file mode 100644
index d22a97140cc3..000000000000
--- a/audio/xmms-uade/files/patch-src+memory.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/memory.c.orig Fri Jan 24 00:01:36 2003
-+++ src/memory.c Fri Jan 24 00:01:51 2003
-@@ -492,7 +492,6 @@
-
- uae_u8 REGPARAM2 *default_xlate (uaecptr a)
- {
-- write_log ("Your Amiga program just did something terribly stupid\n");
- uae_reset();
- return kickmem_xlate (get_long (0xF80000)); /* So we don't crash. */
- }