aboutsummaryrefslogtreecommitdiff
path: root/audio/xmms2
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-01-17 16:53:10 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-01-17 16:53:10 +0000
commit9553558ae76cf1df897f56fd664fc8771995b918 (patch)
tree0422ab4c8e5d8bbfb51e747b8624f2f96915f0af /audio/xmms2
parent8c0906e8fe65991adfd50e15df8f23be04b803a4 (diff)
downloadports-9553558ae76cf1df897f56fd664fc8771995b918.tar.gz
ports-9553558ae76cf1df897f56fd664fc8771995b918.zip
- Use LIB_DEPENDS instead some BUILD_DEPENDS
PR: ports/91848 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=153750
Diffstat (limited to 'audio/xmms2')
-rw-r--r--audio/xmms2/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/audio/xmms2/Makefile b/audio/xmms2/Makefile
index 361a9074c7fc..ee988b952ba2 100644
--- a/audio/xmms2/Makefile
+++ b/audio/xmms2/Makefile
@@ -42,8 +42,8 @@ PLIST_SUB+= CURL="@comment "
.endif
.if defined(WITH_SID)
-LIB_DEPENDS+= resid.0:${PORTSDIR}/audio/resid \
- sidplay.2:${PORTSDIR}/audio/libsidplay2
+LIB_DEPENDS+= resid.[0-9]:${PORTSDIR}/audio/resid \
+ sidplay2.[0-9]:${PORTSDIR}/audio/libsidplay2
PLIST_SUB+= SID=""
.else
EXCLUDE+= sid
@@ -67,7 +67,7 @@ PLIST_SUB+= RUBY="@comment "
.endif
.if defined(WITH_ECORE)
-BUILD_DEPENDS+= ecore.1:${PORTSDIR}/x11/ecore
+LIB_DEPENDS+= lecore.1:${PORTSDIR}/x11/ecore
PLIST_SUB+= ECORE=""
.else
EXCLUDE+= xmmsclient-ecore
@@ -75,7 +75,7 @@ PLIST_SUB+= ECORE="@comment "
.endif
.if defined(WITH_FLAC)
-BUILD_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
PLIST_SUB+= FLAC=""
.else
EXCLUDE+= flac
@@ -83,7 +83,7 @@ PLIST_SUB+= FLAC="@comment "
.endif
.if defined(WITH_FAAD)
-BUILD_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
+LIB_DEPENDS+= faad.0:${PORTSDIR}/audio/faad
PLIST_SUB+= FAAD=""
#EXTRA_PATCHES+= ${FILESDIR}/extraPatch-src::clients::faad::Plugin
.else
@@ -101,7 +101,7 @@ PLIST_SUB+= SDL="@comment "
.endif
.if defined(WITH_MUSEPACK)
-BUILD_DEPENDS+= mpcdec.3:${PORTSDIR}/audio/libmpcdec
+LIB_DEPENDS+= mpcdec.3:${PORTSDIR}/audio/libmpcdec
PLIST_SUB+= MUSEPACK=""
.else
EXCLUDE+= musepack