aboutsummaryrefslogtreecommitdiff
path: root/audio/xsidplay
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2000-10-10 05:07:19 +0000
committerKevin Lo <kevlo@FreeBSD.org>2000-10-10 05:07:19 +0000
commitbfb25bb50bbb27781337387ccf8843ae5b3bd920 (patch)
treeeb7d1d59684f3856ad268cf93a47cff295d37078 /audio/xsidplay
parentba794879bcfd80b8c66dd90237f54d386a2f9c51 (diff)
downloadports-bfb25bb50bbb27781337387ccf8843ae5b3bd920.tar.gz
ports-bfb25bb50bbb27781337387ccf8843ae5b3bd920.zip
Update to version 1.4.2
PR: 21848 Submitted by: MAINTAINER
Notes
Notes: svn path=/head/; revision=33655
Diffstat (limited to 'audio/xsidplay')
-rw-r--r--audio/xsidplay/Makefile22
-rw-r--r--audio/xsidplay/distinfo2
-rw-r--r--audio/xsidplay/files/patch-aa47
-rw-r--r--audio/xsidplay/files/patch-ab47
-rw-r--r--audio/xsidplay/files/patch-ac81
5 files changed, 49 insertions, 150 deletions
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
index 2be8171cf1fd..ba9eccfbc636 100644
--- a/audio/xsidplay/Makefile
+++ b/audio/xsidplay/Makefile
@@ -6,21 +6,29 @@
#
PORTNAME= xsidplay
-PORTVERSION= 1.3.9
+PORTVERSION= 1.4.2
CATEGORIES= audio emulators
MASTER_SITES= http://www.geocities.com/SiliconValley/Lakes/5147/sidplay/packages/ \
http://www.freenix.no/~anders/
-DISTFILES= ${PORTNAME}-${PORTVERSION:S/./_/g}.tgz
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/./_/g}
+EXTRACT_SUFX= .tgz
MAINTAINER= anders@fix.no
LIB_DEPENDS= sidplay.1:${PORTSDIR}/audio/libsidplay
-GNU_CONFIGURE= YES
-USE_QT= YES
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
- -I${X11BASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+USE_QT2= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+CONFIGURE_ENV= MOC="${X11BASE}/bin/moc2"
+CONFIGURE_ARGS= --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-qt-libraries=${X11BASE}/lib \
+ --with-sidplay-includes=${LOCALBASE}/include \
+ --with-sidplay-library=${LOCALBASE}/lib \
+ --with-x-includes=${X11BASE}/include \
+ --with-x-libraries=${X11BASE}/lib
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/xsidplay ${PREFIX}/bin
diff --git a/audio/xsidplay/distinfo b/audio/xsidplay/distinfo
index 3772c7fc9f02..746fd5828b19 100644
--- a/audio/xsidplay/distinfo
+++ b/audio/xsidplay/distinfo
@@ -1 +1 @@
-MD5 (xsidplay-1_3_9.tgz) = 0899624e144c6b686d69d7396689e8c5
+MD5 (xsidplay-1_4_2.tgz) = e23471956ac48d6d6894d439462971eb
diff --git a/audio/xsidplay/files/patch-aa b/audio/xsidplay/files/patch-aa
index c3173417acf8..6e6fcc29a2b2 100644
--- a/audio/xsidplay/files/patch-aa
+++ b/audio/xsidplay/files/patch-aa
@@ -1,36 +1,11 @@
---- src/HVSCDialogData.cpp.orig Fri Oct 9 09:08:24 1998
-+++ src/HVSCDialogData.cpp Tue Sep 12 04:02:45 2000
-@@ -109,9 +109,30 @@
- browseBtn = new QPushButton( this, "BrowseButton" );
- browseBtn->setGeometry( 320, 32, 70, 30 );
- {
-- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11862015) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
-- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(8505544) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-+ QColorGroup normal(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)11862015 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
-+ QColorGroup disabled(
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ) );
-+ QColorGroup active(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)8505544 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
- QPalette palette( normal, disabled, active );
- browseBtn->setPalette( palette );
- }
+--- configure.orig Mon Sep 18 19:55:14 2000
++++ configure Tue Sep 19 00:48:06 2000
+@@ -1480,7 +1480,7 @@
+ # Check whether --with-qt-dir or --without-qt-dir was given.
+ if test "${with_qt_dir+set}" = set; then
+ withval="$with_qt_dir"
+- ac_qt_includes="$withval"/include
++ ac_qt_includes="$withval"/include/qt2
+ ac_qt_libraries="$withval"/lib
+
+ fi
diff --git a/audio/xsidplay/files/patch-ab b/audio/xsidplay/files/patch-ab
index cea199754565..529fa6413668 100644
--- a/audio/xsidplay/files/patch-ab
+++ b/audio/xsidplay/files/patch-ab
@@ -1,36 +1,11 @@
---- src/MainDialog.cpp.orig Sat Jul 3 12:57:28 1999
-+++ src/MainDialog.cpp Tue Sep 12 03:47:31 2000
-@@ -152,9 +152,30 @@
- timeLCD->setMode( QLCDNumber::DEC );
- timeLCD->setSegmentStyle( QLCDNumber::Filled );
- {
-- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
-- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-+ QColorGroup normal(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)11513755 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
-+ QColorGroup disabled(
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ) );
-+ QColorGroup active(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
- QPalette palette( normal, disabled, active );
- timeLCD->setPalette( palette );
- }
+--- src/MainDialogData.cpp.orig Fri Sep 15 22:51:57 2000
++++ src/MainDialogData.cpp Tue Sep 19 00:12:43 2000
+@@ -169,7 +169,7 @@
+ subSongSlider->setPageStep( 1 );
+ subSongSlider->setValue( 1 );
+ subSongSlider->setFocusPolicy( QSlider::TabFocus );
+- subSongSlider->setSizePolicy( QSizePolicy( (QSizePolicy::SizeType)7, (QSizePolicy::SizeType)0 ) );
++ // subSongSlider->setSizePolicy( QSizePolicy( (QSizePolicy::SizeType)7, (QSizePolicy::SizeType)0 ) );
+ subSongSlider->setCursor( QCursor( 13 ) );
+ QToolTip::add( subSongSlider, tr( "Quick song selection" ) );
+
diff --git a/audio/xsidplay/files/patch-ac b/audio/xsidplay/files/patch-ac
index 9f92e5f59f1d..ee4de92dc96d 100644
--- a/audio/xsidplay/files/patch-ac
+++ b/audio/xsidplay/files/patch-ac
@@ -1,70 +1,11 @@
---- src/MainDialogData.cpp.orig Mon Dec 14 06:50:51 1998
-+++ src/MainDialogData.cpp Tue Sep 12 03:57:49 2000
-@@ -43,9 +43,30 @@
- songLCD = new QLCDNumber( this, "LCDNumber_2" );
- songLCD->setGeometry( 90, 35, 40, 30 );
- {
-- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
-- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-+ QColorGroup normal(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)11513755 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
-+ QColorGroup disabled(
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ) );
-+ QColorGroup active(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
- QPalette palette( normal, disabled, active );
- songLCD->setPalette( palette );
- }
-@@ -58,9 +79,30 @@
- timeLCD = new TimeLCD( this, "TimeLCD_1" );
- timeLCD->setGeometry( 10, 35, 75, 30 );
- {
-- QColorGroup normal( QColor( QRgb(0) ), QColor( QRgb(11513755) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-- QColorGroup disabled( QColor( QRgb(8421504) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(8421504) ), QColor( QRgb(12632256) ) );
-- QColorGroup active( QColor( QRgb(0) ), QColor( QRgb(12632256) ), QColor( QRgb(16777215) ), QColor( QRgb(6316128) ), QColor( QRgb(10789024) ), QColor( QRgb(0) ), QColor( QRgb(16777215) ) );
-+ QColorGroup normal(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)11513755 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
-+ QColorGroup disabled(
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)8421504 ),
-+ QColor( (unsigned int)12632256 ) );
-+ QColorGroup active(
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)12632256 ),
-+ QColor( (unsigned int)16777215 ),
-+ QColor( (unsigned int)6316128 ),
-+ QColor( (unsigned int)10789024 ),
-+ QColor( (unsigned int)0 ),
-+ QColor( (unsigned int)16777215 ) );
- QPalette palette( normal, disabled, active );
- timeLCD->setPalette( palette );
- }
+--- src/Makefile.in.old Mon Oct 9 01:32:37 2000
++++ src/Makefile.in Mon Oct 9 01:33:41 2000
+@@ -104,7 +104,7 @@
+
+ bin_PROGRAMS = xsidplay
+
+-xsidplay_LDADD = audio/libaudio.a stilview/libstilview.a songlendb/libsonglendb.a widgets/libwidgets.a @SIDPLAY_LDFLAGS@ -lsidplay @QT_LDFLAGS@ -lqt
++xsidplay_LDADD = audio/libaudio.a stilview/libstilview.a songlendb/libsonglendb.a widgets/libwidgets.a @SIDPLAY_LDFLAGS@ -lsidplay @QT_LDFLAGS@ -L$(X11BASE)/lib -lqt2
+
+
+ xsidplay_SOURCES = $(BUILT_SOURCES) AudioDialog.cpp AudioDialog.h AudioDialogData.cpp AudioDialogData.h ConfigFile.cpp ConfigFile.h EmuDialog.cpp EmuDialog.h EmuDialogData.cpp EmuDialogData.h FilterDialog.cpp FilterDialog.h FilterDialogData.cpp FilterDialogData.h GlobalIcon.h HVSCDialog.cpp HVSCDialog.h HVSCDialogData.cpp HVSCDialogData.h HVSCconfig.h HistoryDialog.cpp HistoryDialog.h HistoryDialogData.cpp HistoryDialogData.h HistoryFile.cpp HistoryFile.h HistoryItem.h MainDialog.cpp MainDialog.h MainDialogData.cpp MainDialogData.h MixerConfig.h MixerDialog.cpp MixerDialog.h MixerDialogData.cpp MixerDialogData.h Playlist.cpp Playlist.h PlaylistDialog.cpp PlaylistDialog.h PlaylistDialogData.cpp PlaylistDialogData.h PlaylistItem.h PlaylistOptDialog.cpp PlaylistOptDialog.h StilDialog.cpp StilDialog.h TextFile.cpp TextFile.h WaveViewDialog.cpp WaveViewDialog.h WaveViewDialogData.cpp WaveViewDialogData.h myTimer.h xsidplay.cpp