aboutsummaryrefslogtreecommitdiff
path: root/audio/zinf
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-14 05:58:51 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-14 05:58:51 +0000
commite0e8980b78adbcae1ce5b8361be7cdbf0ad3d7f7 (patch)
treee8b99ed1f20329af265093881307e7988dc77cfc /audio/zinf
parent2c0bfa99736e3b0157a2778a16ca6bf696e03748 (diff)
downloadports-e0e8980b78adbcae1ce5b8361be7cdbf0ad3d7f7.tar.gz
ports-e0e8980b78adbcae1ce5b8361be7cdbf0ad3d7f7.zip
Depend on freetype2 libs and fix ORBit detection
PR: 35881, 35845 Submitted by: maintainer, Steve Wills <steve@stevenwills.com>
Notes
Notes: svn path=/head/; revision=56055
Diffstat (limited to 'audio/zinf')
-rw-r--r--audio/zinf/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 931a0443a6b7..963b3eb118bd 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freeamp
PORTVERSION= 2.1.1
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://www.freeamp.org/download/src/
@@ -16,7 +17,7 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
ORBit.2:${PORTSDIR}/devel/ORBit \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
- ttf.4:${PORTSDIR}/print/freetype
+ freetype.9:${PORTSDIR}/print/freetype2
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_BZIP2= yes
@@ -24,7 +25,9 @@ USE_GTK= yes
WANT_ESOUND= yes
USE_GMAKE= yes
USE_AUTOCONF_VER=213
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ORBIT_CFLAGS!= orbit-config --cflags server
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
+ ${ORBIT_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>