aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-06-07 17:16:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-06-07 17:16:43 +0000
commit2cf8468ce0348dba2a4c8134703f4dff845babc5 (patch)
treee20acaeffcea58db4dbfeae30de1f701cae445e7 /audio
parenteb1034af0311fc529e98668f41435cb34454361f (diff)
downloadports-2cf8468ce0348dba2a4c8134703f4dff845babc5.tar.gz
ports-2cf8468ce0348dba2a4c8134703f4dff845babc5.zip
- Update to 0.2.36
- Add new knob, WITH_ARTS, this enables arts backend (weird...)
Notes
Notes: svn path=/head/; revision=137003
Diffstat (limited to 'audio')
-rw-r--r--audio/esound/Makefile31
-rw-r--r--audio/esound/distinfo6
2 files changed, 32 insertions, 5 deletions
diff --git a/audio/esound/Makefile b/audio/esound/Makefile
index 36f660dd667a..4c1e6395dac4 100644
--- a/audio/esound/Makefile
+++ b/audio/esound/Makefile
@@ -6,18 +6,25 @@
#
PORTNAME= esound
-PORTVERSION= 0.2.35
-PORTREVISION= 2
+PORTVERSION= 0.2.36
CATEGORIES= audio
-MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ http://cvs.gnome.org/viewcvs/esound/:arts
MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.2
+DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
+.if defined(WITH_ARTS)
+DISTFILES+= ${ARTS_FILE}:arts
+.endif
DIST_SUBDIR= gnome
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX}
MAINTAINER= gnome@FreeBSD.org
COMMENT= A sound library for enlightenment package
LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile
+ARTS_FILE= audio_arts.c?rev=1.1
+
USE_BZIP2= yes
USE_GNOME= gnometarget gnomehack
USE_REINPLACE= yes
@@ -30,7 +37,25 @@ CONFLICTS= py*-ro-[0-9]*
MAN1= esd-config.1 esd.1 esdcat.1 esdctl.1 esddsp.1 esdfilt.1 esdloop.1 \
esdmon.1 esdplay.1 esdrec.1 esdsample.1
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsc.0:${PORTSDIR}/audio/arts
+
+CONFIGURE_ARGS+=--enable-arts
+.else
+CONFIGURE_ARGS+=--disable-arts
+.endif
+
+pre-everything::
+.if !defined(WITH_ARTS)
+ @${ECHO_MSG} "You can enable audio/arts backend by defining"
+ @${ECHO_MSG} "WITH_ARTS"
+ @${ECHO_MSG} ""
+.endif
+
post-patch:
+.if defined(WITH_ARTS)
+ @${CP} ${_DISTDIR}/${ARTS_FILE} ${WRKSRC}/audio_arts.c
+.endif
@${REINPLACE_CMD} -e 's|esdconf_DATA = esd.conf|esdconf_DATA = |g' \
${WRKSRC}/Makefile.in
diff --git a/audio/esound/distinfo b/audio/esound/distinfo
index e3f394317928..8a75d79bd479 100644
--- a/audio/esound/distinfo
+++ b/audio/esound/distinfo
@@ -1,2 +1,4 @@
-MD5 (gnome/esound-0.2.35.tar.bz2) = 1566344f80a8909b5e6e4d6b6520c2c1
-SIZE (gnome/esound-0.2.35.tar.bz2) = 384641
+MD5 (gnome/esound-0.2.36.tar.bz2) = 3facb5aa0115cc1c31771b9ad454ae76
+SIZE (gnome/esound-0.2.36.tar.bz2) = 369952
+MD5 (gnome/audio_arts.c?rev=1.1) = c4f0e0214b59bfc282ce67450d4d8669
+SIZE (gnome/audio_arts.c?rev=1.1) = 4089