aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorBeech Rintoul <beech@FreeBSD.org>2009-02-02 06:28:46 +0000
committerBeech Rintoul <beech@FreeBSD.org>2009-02-02 06:28:46 +0000
commit7eb318e4de4b89e90a65bfc90fe07b6aac3c3b10 (patch)
tree05cdd46bd80dc778fa5b475ec2a9e64f69df0d72 /audio
parent10f3b0a99e1ca28a7fae541e5636ef21f728f1a4 (diff)
downloadports-7eb318e4de4b89e90a65bfc90fe07b6aac3c3b10.tar.gz
ports-7eb318e4de4b89e90a65bfc90fe07b6aac3c3b10.zip
- Update to 1.3.7
- Fix plist PR: ports/131239 Submitted by: Jack <xxjack12xx@gmail.com> (maintainer)
Notes
Notes: svn path=/head/; revision=227429
Diffstat (limited to 'audio')
-rw-r--r--audio/audacity-devel/Makefile73
-rw-r--r--audio/audacity-devel/distinfo6
-rw-r--r--audio/audacity-devel/files/patch-libresample-Makefile.in11
-rw-r--r--audio/audacity-devel/files/patch-locale_Makefile.in11
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.c29
-rw-r--r--audio/audacity-devel/files/patch-portaudio-pa_unix.h11
-rw-r--r--audio/audacity-devel/pkg-plist44
7 files changed, 79 insertions, 106 deletions
diff --git a/audio/audacity-devel/Makefile b/audio/audacity-devel/Makefile
index cdab24190fa9..67d086209c30 100644
--- a/audio/audacity-devel/Makefile
+++ b/audio/audacity-devel/Makefile
@@ -5,11 +5,11 @@
# $FreeBSD$
PORTNAME= audacity
-PORTVERSION= 1.3.5
+PORTVERSION= 1.3.7
CATEGORIES= audio
MASTER_SITES= SF
PKGNAMESUFFIX= -devel
-DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+DISTNAME= ${PORTNAME}-fullsrc-${PORTVERSION}
MAINTAINER= xxjack12xx@gmail.com
COMMENT= Audacity is a GUI editor for digital audio waveforms
@@ -19,22 +19,29 @@ LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
CONFLICTS= audacity-[0-9]*
-WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}-beta
+WRKSRC= ${WRKDIR}/${PORTNAME}-src-${PORTVERSION}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GETTEXT= yes
USE_GCC= 4.2+
+USE_GETTEXT= yes
USE_BZIP2= yes
-USE_WX= 2.6
+USE_WX= 2.8
WX_COMPS= wx
+PORTDOCS= README.txt LICENSE.txt
MAN1= audacity.1
MANCOMPRESSED= yes
-OPTIONS= ID3TAG "ID3 tag support" off \
- MAD "Mad MP3 audio decoder support" on \
- VORBIS "OGG/Vorbis audio support" on
+OPTIONS= VORBIS "Use libvorbis for Ogg Vorbis support" on \
+ MAD "Use libmad for mp2/3 decoding support" on \
+ FLAC "Use libFLAC for FLAC support" on \
+ ID3TAG "Use libid3tag for mp3 id3 tag support" on \
+ SBSMS "Use libsbsms for pitch and tempo changing" on \
+ SOUNDTOUCH "Use libsbsms for pitch and tempo changing" on\
+ TWOLAME "Use libtwolame for MP2 export support" on \
+ FFMPEG "Use ffmpeg for import and export support" on \
+ MIDI "Use portSMF for Midi support" on
.include <bsd.port.pre.mk>
@@ -44,34 +51,50 @@ SSE_CFLAGS= -mno-sse -mno-sse2
CONFIGURE_ARG+= --destdir=/
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
- CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
- CFLAGS="${CFLAGS} -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS} -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
+ CFLAGS="${CFLAGS} -I${WRKSRC}/lib-src/portaudio-v19/include -I${LOCALBASE}/include ${SSE_CFLAGS} ${PTHREAD_CFLAGS}" \
WX_CONFIG=${WX_CONFIG}
.if !defined(NOPORTDOCS)
MAKE_ENV= DOC=yes
.endif
-CONFIGURE_ARGS+= --with-portaudio=v18
-.if !defined(WITHOUT_MAD)
-CONFIGURE_ARGS+= --with-libmad=system
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
-.else
-CONFIGURE_ARGS+= --without-libmad
+CONFIGURE_ARGS+= --enable-unicode=no
+
+.if defined(WITH_VORBIS)
+CONFIGURE_ARGS+= --with-libvorbis
+.endif
+
+.if defined(WITH_MAD)
+CONFIGURE_ARGS+= --with-libmad
.endif
-.if !defined(WITHOUT_VORBIS)
-CONFIGURE_ARGS+= --with-vorbis=system
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
-.else
-CONFIGURE_ARGS+= --without-vorbis
+.if defined(WITH_FLAC)
+CONFIGURE_ARGS+= --with-libflac
.endif
.if defined(WITH_ID3TAG)
-CONFIGURE_ARGS+= --with-id3tag=system
-LIB_DEPENDS+= id3tag.0:${PORTSDIR}/audio/libid3tag
-.else
-CONFIGURE_ARGS+= --without-id3tag
+CONFIGURE_ARGS+= --with-libid3tag
+.endif
+
+.if defined(WITH_SBSMS)
+CONFIGURE_ARGS+= --with-sbsms
+.endif
+
+.if defined(WITH_SOUNDTOUCH)
+CONFIGURE_ARGS+= --with-soundtouch
+.endif
+
+.if defined(WITH_TWOLAME)
+CONFIGURE_ARGS+= --with-libtwolame
+.endif
+
+.if defined(WITH_FFMPEG)
+CONFIGURE_ARGS+= --with-ffmpeg
+.endif
+
+.if defined(WITH_MIDI)
+CONFIGURE_ARGS+= --with-midi
.endif
.include <bsd.port.post.mk>
diff --git a/audio/audacity-devel/distinfo b/audio/audacity-devel/distinfo
index f297da90011d..3b6d7ca2a55a 100644
--- a/audio/audacity-devel/distinfo
+++ b/audio/audacity-devel/distinfo
@@ -1,3 +1,3 @@
-MD5 (audacity-src-1.3.5.tar.bz2) = b15503c331e7145942fa0e4b27760d61
-SHA256 (audacity-src-1.3.5.tar.bz2) = 58beaf20d5d4bdec61c93cc9bda08faea9b1c9b51c962b4176e9390a6a65904c
-SIZE (audacity-src-1.3.5.tar.bz2) = 4542637
+MD5 (audacity-fullsrc-1.3.7.tar.bz2) = 29b5c2ad50f58dac01406ccc1f31d40e
+SHA256 (audacity-fullsrc-1.3.7.tar.bz2) = be4a7ae1906e321e94aee35d0a60c332f4920ecd0cdb54a279a519c60c835acd
+SIZE (audacity-fullsrc-1.3.7.tar.bz2) = 13671285
diff --git a/audio/audacity-devel/files/patch-libresample-Makefile.in b/audio/audacity-devel/files/patch-libresample-Makefile.in
index bcb4513bcd20..e69de29bb2d1 100644
--- a/audio/audacity-devel/files/patch-libresample-Makefile.in
+++ b/audio/audacity-devel/files/patch-libresample-Makefile.in
@@ -1,11 +0,0 @@
---- lib-src/libresample/Makefile.in.orig Tue Dec 2 19:46:02 2003
-+++ lib-src/libresample/Makefile.in Tue Dec 2 19:46:25 2003
-@@ -6,7 +6,7 @@
- CC = @CC@
- CFLAGS = @CFLAGS@ -Wall
-
--LIBS = @LIBS@ -lm
-+LIBS = @LDFLAGS@ @LIBS@ -lm
-
- AR = @AR@
- RANLIB = @RANLIB@
diff --git a/audio/audacity-devel/files/patch-locale_Makefile.in b/audio/audacity-devel/files/patch-locale_Makefile.in
index 979310458e10..e69de29bb2d1 100644
--- a/audio/audacity-devel/files/patch-locale_Makefile.in
+++ b/audio/audacity-devel/files/patch-locale_Makefile.in
@@ -1,11 +0,0 @@
---- locale/Makefile.in 2008-07-04 23:33:51.000000000 +0000
-+++ locale/Makefile.in.orig 2008-07-04 23:33:28.000000000 +0000
-@@ -14,7 +14,7 @@
- DATADIR=@datadir@
- # This is an intermediate directory that all files destined for installation
- # get put into on the way (make DESTDIR=/foo install).
--DESTDIR=@destdir@
-+DESTDIR=
- # this is where locale-dependant stuff (i.e. .mo files) goes
- LOCALEDIR=@localedir@
- INSTALL=@INSTALL@
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.c b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
index ff3c8ca818fd..e69de29bb2d1 100644
--- a/audio/audacity-devel/files/patch-portaudio-pa_unix.c
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.c
@@ -1,29 +0,0 @@
---- lib-src/portaudio/pa_unix_oss/pa_unix.c.orig Tue Nov 30 21:18:35 2004
-+++ lib-src/portaudio/pa_unix_oss/pa_unix.c Tue Nov 30 21:33:58 2004
-@@ -422,7 +422,7 @@
- maxPri = sched_get_priority_max(SCHEDULER_POLICY);
- if( schp.sched_priority > maxPri ) schp.sched_priority = maxPri;
-
-- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
-+ if (pthread_setschedparam(pahsc->pahsc_WatchDogThread, SCHEDULER_POLICY, &schp) != 0)
- {
- ERR_RPT(("PaHost_WatchDogProc: cannot set watch dog priority!\n"));
- goto killAudio;
-@@ -465,7 +465,7 @@
- lowerAudio:
- {
- struct sched_param schat = { 0 };
-- if( sched_setscheduler(pahsc->pahsc_AudioThreadPID, SCHED_OTHER, &schat) != 0)
-+ if( pthread_setschedparam(pahsc->pahsc_AudioThread, SCHED_OTHER, &schat) != 0)
- {
- ERR_RPT(("PaHost_WatchDogProc: failed to lower audio priority. errno = %d\n", errno ));
- /* Fall through into killing audio thread. */
-@@ -585,7 +585,7 @@
- sched_get_priority_min(SCHEDULER_POLICY)) / 2;
- schp.sched_priority = pahsc->pahsc_AudioPriority;
-
-- if (sched_setscheduler(0, SCHEDULER_POLICY, &schp) != 0)
-+ if (pthread_setschedparam(pahsc->pahsc_AudioThread, SCHEDULER_POLICY, &schp) != 0)
- {
- DBUG(("PortAudio: only superuser can use real-time priority.\n"));
- }
diff --git a/audio/audacity-devel/files/patch-portaudio-pa_unix.h b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
index e4a44ff9a1bf..e69de29bb2d1 100644
--- a/audio/audacity-devel/files/patch-portaudio-pa_unix.h
+++ b/audio/audacity-devel/files/patch-portaudio-pa_unix.h
@@ -1,11 +0,0 @@
---- lib-src/portaudio/pa_unix_oss/pa_unix.h.orig Tue Dec 2 19:56:56 2003
-+++ lib-src/portaudio/pa_unix_oss/pa_unix.h Tue Dec 2 19:58:33 2003
-@@ -82,7 +82,7 @@
- #define MAX_TIMEOUT_MSEC (1000)
-
- /************************************************* Definitions ********/
--#ifdef __linux__
-+#if defined(__linux__) || defined(__FreeBSD__)
- #define DEVICE_NAME_BASE "/dev/dsp"
- #else
- #define DEVICE_NAME_BASE "/dev/audio"
diff --git a/audio/audacity-devel/pkg-plist b/audio/audacity-devel/pkg-plist
index 424684edafd9..87f156155dc4 100644
--- a/audio/audacity-devel/pkg-plist
+++ b/audio/audacity-devel/pkg-plist
@@ -1,4 +1,6 @@
bin/audacity
+share/applications/audacity.desktop
+%%DATADIR%%/audacity.xpm
%%DATADIR%%/nyquist/bug.lsp
%%DATADIR%%/nyquist/dspprims.lsp
%%DATADIR%%/nyquist/evalenv.lsp
@@ -18,25 +20,28 @@ bin/audacity
%%DATADIR%%/nyquist/test.lsp
%%DATADIR%%/nyquist/xlinit.lsp
%%DATADIR%%/plug-ins/SilenceMarker.ny
+%%DATADIR%%/plug-ins/analyze.ny
+%%DATADIR%%/plug-ins/beat.ny
%%DATADIR%%/plug-ins/clicktrack.ny
+%%DATADIR%%/plug-ins/clipfix.ny
%%DATADIR%%/plug-ins/crossfadein.ny
%%DATADIR%%/plug-ins/crossfadeout.ny
%%DATADIR%%/plug-ins/delay.ny
+%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/highpass.ny
%%DATADIR%%/plug-ins/lowpass.ny
%%DATADIR%%/plug-ins/pluck.ny
-%%DATADIR%%/plug-ins/tremolo.ny
-%%DATADIR%%/plug-ins/beat.ny
-%%DATADIR%%/plug-ins/equalabel.ny
%%DATADIR%%/plug-ins/rissetdrum.ny
+%%DATADIR%%/plug-ins/tremolo.ny
%%DATADIR%%/plug-ins/vocalremover.ny
%%DATADIR%%/plug-ins/vocoder.ny
-%%DATADIR%%/audacity.xpm
share/locale/af/LC_MESSAGES/audacity.mo
share/locale/ar/LC_MESSAGES/audacity.mo
share/locale/bg/LC_MESSAGES/audacity.mo
share/locale/bn/LC_MESSAGES/audacity.mo
+share/locale/bs/LC_MESSAGES/audacity.mo
share/locale/ca/LC_MESSAGES/audacity.mo
+share/locale/ca@valencia/LC_MESSAGES/audacity.mo
share/locale/cs/LC_MESSAGES/audacity.mo
share/locale/cy/LC_MESSAGES/audacity.mo
share/locale/da/LC_MESSAGES/audacity.mo
@@ -44,16 +49,20 @@ share/locale/de/LC_MESSAGES/audacity.mo
share/locale/el/LC_MESSAGES/audacity.mo
share/locale/es/LC_MESSAGES/audacity.mo
share/locale/eu/LC_MESSAGES/audacity.mo
+share/locale/fa/LC_MESSAGES/audacity.mo
share/locale/fi/LC_MESSAGES/audacity.mo
share/locale/fr/LC_MESSAGES/audacity.mo
share/locale/ga/LC_MESSAGES/audacity.mo
share/locale/gl/LC_MESSAGES/audacity.mo
share/locale/he/LC_MESSAGES/audacity.mo
share/locale/hu/LC_MESSAGES/audacity.mo
+share/locale/id/LC_MESSAGES/audacity.mo
share/locale/it/LC_MESSAGES/audacity.mo
share/locale/ja/LC_MESSAGES/audacity.mo
-share/locale/lt/LC_MESSAGES/audacity.mo
+share/locale/ka/LC_MESSAGES/audacity.mo
+share/locale/km/LC_MESSAGES/audacity.mo
share/locale/ko/LC_MESSAGES/audacity.mo
+share/locale/lt/LC_MESSAGES/audacity.mo
share/locale/mk/LC_MESSAGES/audacity.mo
share/locale/nb/LC_MESSAGES/audacity.mo
share/locale/nl/LC_MESSAGES/audacity.mo
@@ -62,22 +71,25 @@ share/locale/pl/LC_MESSAGES/audacity.mo
share/locale/pt_BR/LC_MESSAGES/audacity.mo
share/locale/ro/LC_MESSAGES/audacity.mo
share/locale/ru/LC_MESSAGES/audacity.mo
-share/locale/sl/LC_MESSAGES/audacity.mo
share/locale/sk/LC_MESSAGES/audacity.mo
+share/locale/sl/LC_MESSAGES/audacity.mo
share/locale/sv/LC_MESSAGES/audacity.mo
+share/locale/tg/LC_MESSAGES/audacity.mo
share/locale/tr/LC_MESSAGES/audacity.mo
share/locale/uk/LC_MESSAGES/audacity.mo
share/locale/vi/LC_MESSAGES/audacity.mo
share/locale/zh/LC_MESSAGES/audacity.mo
share/locale/zh_TW/LC_MESSAGES/audacity.mo
-@dirrmtry share/locale/oc/LC_MESSAGES
-@dirrmtry share/locale/oc
-@dirrm %%DATADIR%%/plug-ins
-@dirrm %%DATADIR%%/nyquist
-@dirrm %%DATADIR%%
-%%PORTDOCS%%%%DOCSDIR%%/README.txt
-%%PORTDOCS%%%%DOCSDIR%%/LICENSE.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
share/mime/packages/audacity.xml
-share/applications/audacity.desktop
-@dirrmtry share/applications
+@dirrm share/mime/packages
+@dirrm share/mime
+@dirrm share/locale/oc/LC_MESSAGES
+@dirrm share/locale/oc
+@dirrm share/locale/km/LC_MESSAGES
+@dirrm share/locale/km
+@dirrm share/locale/ca@valencia/LC_MESSAGES
+@dirrm share/locale/ca@valencia
+@dirrm share/audacity/plug-ins
+@dirrm share/audacity/nyquist
+@dirrm share/audacity
+@dirrm share/applications