aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-04-05 17:43:03 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-04-05 17:43:03 +0000
commitb229f6cd0cdecf0a4c09931c7b9620556df3dd7a (patch)
tree4cd7dbc9c201eaddebbd8a1102a84895823d7993 /audio
parent70b3386448e4b5e9157613112cd0bb1885843ac8 (diff)
downloadports-b229f6cd0cdecf0a4c09931c7b9620556df3dd7a.tar.gz
ports-b229f6cd0cdecf0a4c09931c7b9620556df3dd7a.zip
Continue playing music after a new mail arrived.
Submitted by: joerg
Notes
Notes: svn path=/head/; revision=78311
Diffstat (limited to 'audio')
-rw-r--r--audio/xmms-mailnotify/Makefile2
-rw-r--r--audio/xmms-mailnotify/files/patch-ac26
2 files changed, 27 insertions, 1 deletions
diff --git a/audio/xmms-mailnotify/Makefile b/audio/xmms-mailnotify/Makefile
index 8dd1fb90298c..9b5345aaec9b 100644
--- a/audio/xmms-mailnotify/Makefile
+++ b/audio/xmms-mailnotify/Makefile
@@ -6,7 +6,7 @@
PORTNAME= xmms-mailnotify
PORTVERSION= 0.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= arved
diff --git a/audio/xmms-mailnotify/files/patch-ac b/audio/xmms-mailnotify/files/patch-ac
new file mode 100644
index 000000000000..a9c55359fe45
--- /dev/null
+++ b/audio/xmms-mailnotify/files/patch-ac
@@ -0,0 +1,26 @@
+--- mailnotify.c.orig Mon Mar 31 16:55:38 2003
++++ mailnotify.c Mon Mar 31 16:55:52 2003
+@@ -675,16 +675,18 @@
+ dummy = xmms_remote_get_playlist_file(mailnotify.xmms_session, saved_position);
+ printf(" which is %s\n", dummy);
+ #endif
+- if(!wasplaying)
+- xmms_remote_stop(mailnotify.xmms_session);
+-
++ xmms_remote_stop(mailnotify.xmms_session);
+ xmms_remote_set_playlist_pos(mailnotify.xmms_session, saved_position);
+ xmms_remote_playlist_delete(mailnotify.xmms_session, afpos);
+
+-#ifdef CONTINUE_WHERE_INTERRUPTED
+ if(wasplaying)
++ {
++ xmms_remote_play(mailnotify.xmms_session);
++#ifdef CONTINUE_WHERE_INTERRUPTED
+ xmms_remote_jump_to_time(mailnotify.xmms_session, saved_offset);
+ #endif
++ }
++
+ }
+ else
+ {
+