aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-09-26 13:53:01 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-09-26 13:53:01 +0000
commit519f4e67779863399411e061efabaef354e042bc (patch)
tree27969723a2136a2643421f17465cc839dd81361c /audio
parentad482eae95cf85dfada4ed8081958a08bc384d0d (diff)
downloadports-519f4e67779863399411e061efabaef354e042bc.tar.gz
ports-519f4e67779863399411e061efabaef354e042bc.zip
Add mpck 0.10, a command-line utility for checking mp3 files for errors.
PR: ports/86553 Submitted by: Emanuel Haupt <ehaupt@critical.ch>
Notes
Notes: svn path=/head/; revision=143585
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/checkmate/Makefile29
-rw-r--r--audio/checkmate/distinfo2
-rw-r--r--audio/checkmate/pkg-descr6
-rw-r--r--audio/mpck/Makefile29
-rw-r--r--audio/mpck/distinfo2
-rw-r--r--audio/mpck/pkg-descr6
7 files changed, 75 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 79e929e1b1a3..450948446414 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -309,6 +309,7 @@
SUBDIR += mp3stat
SUBDIR += mp3wrap
SUBDIR += mpc
+ SUBDIR += mpck
SUBDIR += mpegaudio
SUBDIR += mpeglib_artsplug
SUBDIR += mpg123
diff --git a/audio/checkmate/Makefile b/audio/checkmate/Makefile
new file mode 100644
index 000000000000..a484be8b99a1
--- /dev/null
+++ b/audio/checkmate/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpck
+# Date created: 25 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpck
+PORTVERSION= 0.10
+CATEGORIES= audio
+MASTER_SITES= http://mpck.linuxonly.nl/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line utility for checking mp3 files for errors
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= mpck.1
+PLIST_FILES= bin/mpck
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/src/checkframe.c \
+ ${WRKSRC}/src/bufio.c
+
+.include <bsd.port.mk>
diff --git a/audio/checkmate/distinfo b/audio/checkmate/distinfo
new file mode 100644
index 000000000000..06f8187a8929
--- /dev/null
+++ b/audio/checkmate/distinfo
@@ -0,0 +1,2 @@
+MD5 (mpck-0.10.tar.gz) = d49d9af7605a1be1c0f9a2d7889de437
+SIZE (mpck-0.10.tar.gz) = 178362
diff --git a/audio/checkmate/pkg-descr b/audio/checkmate/pkg-descr
new file mode 100644
index 000000000000..9de273b24a75
--- /dev/null
+++ b/audio/checkmate/pkg-descr
@@ -0,0 +1,6 @@
+Mpck reads mp3 files and tries to determine if they are valid.
+
+It displays statistics such as the bitrate. It is fast and supports
+recursive directory checking.
+
+WWW: http://mpck.linuxonly.nl/
diff --git a/audio/mpck/Makefile b/audio/mpck/Makefile
new file mode 100644
index 000000000000..a484be8b99a1
--- /dev/null
+++ b/audio/mpck/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: mpck
+# Date created: 25 Sep 2005
+# Whom: Emanuel Haupt <ehaupt@critical.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mpck
+PORTVERSION= 0.10
+CATEGORIES= audio
+MASTER_SITES= http://mpck.linuxonly.nl/
+
+MAINTAINER= ehaupt@critical.ch
+COMMENT= A command-line utility for checking mp3 files for errors
+
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+MAN1= mpck.1
+PLIST_FILES= bin/mpck
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/src/checkframe.c \
+ ${WRKSRC}/src/bufio.c
+
+.include <bsd.port.mk>
diff --git a/audio/mpck/distinfo b/audio/mpck/distinfo
new file mode 100644
index 000000000000..06f8187a8929
--- /dev/null
+++ b/audio/mpck/distinfo
@@ -0,0 +1,2 @@
+MD5 (mpck-0.10.tar.gz) = d49d9af7605a1be1c0f9a2d7889de437
+SIZE (mpck-0.10.tar.gz) = 178362
diff --git a/audio/mpck/pkg-descr b/audio/mpck/pkg-descr
new file mode 100644
index 000000000000..9de273b24a75
--- /dev/null
+++ b/audio/mpck/pkg-descr
@@ -0,0 +1,6 @@
+Mpck reads mp3 files and tries to determine if they are valid.
+
+It displays statistics such as the bitrate. It is fast and supports
+recursive directory checking.
+
+WWW: http://mpck.linuxonly.nl/