aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-11-08 19:43:04 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-11-08 19:43:04 +0000
commit5c4d0dd322a9f83e01ed79fda63e5676e18c9594 (patch)
tree43304d5fa2b9f3b39734ea4080855e7c239a513b /audio
parent3acbf500877fe1744df7404f6c97d43caf346b2f (diff)
downloadports-5c4d0dd322a9f83e01ed79fda63e5676e18c9594.tar.gz
ports-5c4d0dd322a9f83e01ed79fda63e5676e18c9594.zip
Initial import of py-gmusicapi
Notes
Notes: svn path=/head/; revision=372328
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/py-gmusicapi/Makefile34
-rw-r--r--audio/py-gmusicapi/distinfo2
-rw-r--r--audio/py-gmusicapi/pkg-descr13
4 files changed, 50 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 2fadfc9934ea..3fd81fbd8aba 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -599,6 +599,7 @@
SUBDIR += py-eyed3
SUBDIR += py-eyed3-06
SUBDIR += py-fastaudio
+ SUBDIR += py-gmusicapi
SUBDIR += py-id3
SUBDIR += py-karaoke
SUBDIR += py-mad
diff --git a/audio/py-gmusicapi/Makefile b/audio/py-gmusicapi/Makefile
new file mode 100644
index 000000000000..97cb36acd2e2
--- /dev/null
+++ b/audio/py-gmusicapi/Makefile
@@ -0,0 +1,34 @@
+# Created by: Thomas Zander <riggs@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= gmusicapi
+PORTVERSION= 4.0.0.20141107
+CATEGORIES= audio python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= riggs@FreeBSD.org
+COMMENT= Unofficial Python API for Google Play Music
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=1.3.0:${PORTSDIR}/devel/py-appdirs \
+ ${PYTHON_PKGNAMEPREFIX}dateutil>=2.2:${PORTSDIR}/devel/py-dateutil \
+ ${PYTHON_PKGNAMEPREFIX}decorator>=3.4.0:${PORTSDIR}/devel/py-decorator \
+ ${PYTHON_PKGNAMEPREFIX}mock>=1.0.1:${PORTSDIR}/devel/py-mock \
+ ${PYTHON_PKGNAMEPREFIX}mutagen>=1.18:${PORTSDIR}/audio/py-mutagen \
+ ${PYTHON_PKGNAMEPREFIX}oauth2client>=1.2:${PORTSDIR}/security/py-oauth2client \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:${PORTSDIR}/devel/py-protobuf \
+ ${PYTHON_PKGNAMEPREFIX}requests>=2.3.0:${PORTSDIR}/www/py-requests \
+ ${PYTHON_PKGNAMEPREFIX}validictory>=0.9.3:${PORTSDIR}/devel/py-validictory
+
+USE_GITHUB= yes
+GH_ACCOUNT= simon-weber
+GH_PROJECT= Unofficial-Google-Music-API
+GH_COMMIT= e4d15e0
+GH_TAGNAME= ${GH_COMMIT}
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/audio/py-gmusicapi/distinfo b/audio/py-gmusicapi/distinfo
new file mode 100644
index 000000000000..eb9cae1db4c5
--- /dev/null
+++ b/audio/py-gmusicapi/distinfo
@@ -0,0 +1,2 @@
+SHA256 (gmusicapi-4.0.0.20141107.tar.gz) = f660f79fa5b22d1e4cfc9f7ef03d4f5040561a11cac05c96283267875a421fd2
+SIZE (gmusicapi-4.0.0.20141107.tar.gz) = 147864
diff --git a/audio/py-gmusicapi/pkg-descr b/audio/py-gmusicapi/pkg-descr
new file mode 100644
index 000000000000..04d08eb0441f
--- /dev/null
+++ b/audio/py-gmusicapi/pkg-descr
@@ -0,0 +1,13 @@
+gmusicapi is an unofficial API for Google Play Music, written in python.
+
+All major functionality is supported:
+* Library management: list, create, delete, and modify songs and playlists
+* Streaming and single-song downloading
+* Music Manager uploading/scan-and-match and library downloading
+* Most All Access features
+
+This project is not supported nor endorsed by Google. The author kindly
+asks the users of this API to use common sense (protocol compliance,
+reasonable load, etc) when accessing Google Play Music through this API.
+
+WWW: http://github.com/simon-weber/Unofficial-Google-Music-API