aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-07 22:08:48 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-07 22:08:48 +0000
commitfc85ed241187932eff27e68d4372474495b5c6fe (patch)
tree74aa9abe904f4a847194445c7bc627153550ffa5 /audio
parent04ce823507de54563ca960e3bd14bc59b57649a8 (diff)
downloadports-fc85ed241187932eff27e68d4372474495b5c6fe.tar.gz
ports-fc85ed241187932eff27e68d4372474495b5c6fe.zip
- Fix build with gcc 4.2
PR: 118274 Submitted by: Pietro Cerutti" <gahr@gahr.ch> Approved by: maintainer timeout
Notes
Notes: svn path=/head/; revision=206868
Diffstat (limited to 'audio')
-rw-r--r--audio/hydrogen/Makefile8
-rw-r--r--audio/hydrogen/files/patch-src-lib-xml_tinyxml.h11
2 files changed, 12 insertions, 7 deletions
diff --git a/audio/hydrogen/Makefile b/audio/hydrogen/Makefile
index 599f1cd18cc4..c19bc1707623 100644
--- a/audio/hydrogen/Makefile
+++ b/audio/hydrogen/Makefile
@@ -44,12 +44,6 @@ OPTIONS= JACK "JACK support" off \
LRDF "LRDF support" off \
FLAC "FLAC support" on
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.if defined(WITH_JACK)
LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
CPPFLAGS+= ${PTHREAD_CFLAGS}
@@ -118,4 +112,4 @@ do-install:
${MKDIR} ${MAN1PREFIX}/man/ru.KOI8-R/man1
${INSTALL_MAN} ${WRKSRC}/man/ru/hydrogen.1 ${MAN1PREFIX}/man/ru.KOI8-R/man1
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/hydrogen/files/patch-src-lib-xml_tinyxml.h b/audio/hydrogen/files/patch-src-lib-xml_tinyxml.h
new file mode 100644
index 000000000000..fd7d14a8bde1
--- /dev/null
+++ b/audio/hydrogen/files/patch-src-lib-xml_tinyxml.h
@@ -0,0 +1,11 @@
+--- src/lib/xml/tinyxml.h.orig 2007-11-27 00:59:06.000000000 +0100
++++ src/lib/xml/tinyxml.h 2007-11-27 01:05:34.000000000 +0100
+@@ -823,7 +823,7 @@
+ #endif
+
+ /// Construct.
+- TiXmlDeclaration::TiXmlDeclaration( const char * _version,
++ TiXmlDeclaration( const char * _version,
+ const char * _encoding,
+ const char * _standalone );
+