aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorEdward Tomasz Napierala <trasz@FreeBSD.org>2009-02-19 22:14:53 +0000
committerEdward Tomasz Napierala <trasz@FreeBSD.org>2009-02-19 22:14:53 +0000
commit36f12de294567fd479a43875c16e1df17f45150e (patch)
tree9e77bfbe70273ef37c7fd442b9382a6bd21d4f9b /audio
parentb73f95f9088ee3ed89aa06f86d36751ee6008e50 (diff)
downloadports-36f12de294567fd479a43875c16e1df17f45150e.tar.gz
ports-36f12de294567fd479a43875c16e1df17f45150e.zip
Update to 20081213.
Notes
Notes: svn path=/head/; revision=228688
Diffstat (limited to 'audio')
-rw-r--r--audio/ghostess/Makefile6
-rw-r--r--audio/ghostess/distinfo6
-rw-r--r--audio/ghostess/files/patch-configure15
-rw-r--r--audio/ghostess/files/patch-src-ghostess.c18
-rw-r--r--audio/ghostess/files/patch-src-universal_gui.c14
5 files changed, 28 insertions, 31 deletions
diff --git a/audio/ghostess/Makefile b/audio/ghostess/Makefile
index 464c7dc892c3..5dc953683cc9 100644
--- a/audio/ghostess/Makefile
+++ b/audio/ghostess/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= ghostess
-PORTVERSION= 20061127
-PORTREVISION= 3
+PORTVERSION= 20081213
CATEGORIES= audio
-MASTER_SITES= http://home.jps.net/~musound/
+MASTER_SITES= http://www.smbolton.com/linux/
MAINTAINER= trasz@FreeBSD.org
COMMENT= Graphical DSSI host with JACK MIDI support
@@ -28,6 +27,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-jackmidi
USE_GMAKE= yes
USE_GNOME= gtk20
+USE_BZIP2= yes
PLIST_FILES= bin/ghostess bin/ghostess_universal_gui
diff --git a/audio/ghostess/distinfo b/audio/ghostess/distinfo
index f0fc9e2a418a..e8becf67c8b0 100644
--- a/audio/ghostess/distinfo
+++ b/audio/ghostess/distinfo
@@ -1,3 +1,3 @@
-MD5 (ghostess-20061127.tar.gz) = 74c6ee39a0ed1ac9ec0015fe7b45ffe6
-SHA256 (ghostess-20061127.tar.gz) = a557ecfecc85654cb2f86110485e8c5dcea602143d1a0666dd486aeacb2475fb
-SIZE (ghostess-20061127.tar.gz) = 375161
+MD5 (ghostess-20081213.tar.bz2) = 1b90048c07e152768a42be136f49f2be
+SHA256 (ghostess-20081213.tar.bz2) = a9ab39710e00a1ff691b3d4fd070fa231081a1b449685e899d81ac4105593956
+SIZE (ghostess-20081213.tar.bz2) = 264977
diff --git a/audio/ghostess/files/patch-configure b/audio/ghostess/files/patch-configure
index 7d0d56e769e5..c817f0f836fa 100644
--- a/audio/ghostess/files/patch-configure
+++ b/audio/ghostess/files/patch-configure
@@ -1,7 +1,7 @@
---- configure.orig Tue Nov 28 17:09:13 2006
-+++ configure Sat Jan 13 20:08:31 2007
-@@ -21405,14 +21405,9 @@
- echo "GTK support: $with_gtk"
+--- configure.orig 2008-12-14 01:50:58.000000000 +0100
++++ configure 2009-01-11 15:27:38.000000000 +0100
+@@ -11766,15 +11766,9 @@
+
case "${host_os}" in
-darwin*)
@@ -13,6 +13,7 @@
-_ACEOF
-
-
- succeeded=no
-
- if test -z "$PKG_CONFIG"; then
+-
+ if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
+ if test -n "$ac_tool_prefix"; then
+ # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
diff --git a/audio/ghostess/files/patch-src-ghostess.c b/audio/ghostess/files/patch-src-ghostess.c
index 910215fe1730..d83cda53e2b4 100644
--- a/audio/ghostess/files/patch-src-ghostess.c
+++ b/audio/ghostess/files/patch-src-ghostess.c
@@ -8,21 +8,3 @@
#include <gtk/gtk.h>
-@@ -232,7 +233,7 @@
- void* midi_port_buf = jack_port_get_buffer(midi_input_port, nframes);
- jack_midi_event_t jack_midi_event;
- jack_nframes_t jack_midi_event_index = 0;
-- jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf, nframes);
-+ jack_nframes_t jack_midi_event_count = jack_midi_get_event_count(midi_port_buf);
- static snd_seq_event_t jack_seq_event_holder[3];
- snd_seq_event_t *jack_seq_event = NULL, *osc_seq_event = NULL;
- int had_midi_overflow = 0;
-@@ -258,7 +259,7 @@
-
- int count;
-
-- jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index, nframes);
-+ jack_midi_event_get(&jack_midi_event, midi_port_buf, jack_midi_event_index);
- jack_midi_event_index++;
-
- jack_seq_event = jack_seq_event_holder;
diff --git a/audio/ghostess/files/patch-src-universal_gui.c b/audio/ghostess/files/patch-src-universal_gui.c
new file mode 100644
index 000000000000..73e12c46f212
--- /dev/null
+++ b/audio/ghostess/files/patch-src-universal_gui.c
@@ -0,0 +1,14 @@
+--- src/universal_gui.c.orig 2009-01-11 15:40:04.000000000 +0100
++++ src/universal_gui.c 2009-01-11 15:42:28.000000000 +0100
+@@ -610,8 +610,9 @@
+ (gpointer)port);
+
+ /* update bounds */
+- gtk_adjustment_set_lower(GTK_ADJUSTMENT(port_data[port].adjustment), plb);
+- gtk_adjustment_set_upper(GTK_ADJUSTMENT(port_data[port].adjustment), pub);
++ GTK_ADJUSTMENT(port_data[port].adjustment)->lower = plb;
++ GTK_ADJUSTMENT(port_data[port].adjustment)->upper = pub;
++ gtk_adjustment_changed(GTK_ADJUSTMENT(port_data[port].adjustment));
+
+ /* update labels */
+ if (port_data[port].bounded) {