aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2007-12-15 19:00:59 +0000
committerPav Lucistnik <pav@FreeBSD.org>2007-12-15 19:00:59 +0000
commitd4dcb234435487c9a9110433b823b24a1b9108ea (patch)
treeb4d551ca6e79a4ca9f115052985e72b977aa7685 /audio
parent0650f5cb0fa8d24d1ea76fbea875cde8a0856ad4 (diff)
downloadports-d4dcb234435487c9a9110433b823b24a1b9108ea.tar.gz
ports-d4dcb234435487c9a9110433b823b24a1b9108ea.zip
Tags groups of audio files using CDDB.
TagLookup is a utility for tagging MP3s and other taggable audio file formats. It inspects a set of audio files and uses their lengths to look up an appropriate disc from a CDDB-compatible service. TagLookup can be used in two modes: * ID -- Given a CDDB ID and a number of files, look up the details of the CDDB disc from a CDDB service. Tag files using the CDDB disc. Match each file with each CDDB track using the closest track length. * Sequence -- Given a number of files, generate a CDDB ID and query a CDDB service. CDDB IDs are generated based on the sequence of tracks. Choose the closest matching CDDB disc to tag the files. As well as this, taglookup can: * Rename -- Rename files based on their tags. WWW: http://www.kamaz.org.uk/taglookup PR: ports/117644 Submitted by: Alex Allan <alex@kamaz.org.uk>
Notes
Notes: svn path=/head/; revision=203772
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/taglookup/Makefile23
-rw-r--r--audio/taglookup/distinfo3
-rw-r--r--audio/taglookup/pkg-descr18
4 files changed, 45 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index db851f98bdaf..1328f3c5e843 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -616,6 +616,7 @@
SUBDIR += swhplugins
SUBDIR += tagger
SUBDIR += taglib
+ SUBDIR += taglookup
SUBDIR += tagtool
SUBDIR += tap-plugins
SUBDIR += tclmidi
diff --git a/audio/taglookup/Makefile b/audio/taglookup/Makefile
new file mode 100644
index 000000000000..d4d12f23ca7a
--- /dev/null
+++ b/audio/taglookup/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: taglookup
+# Date created: 21 Oct 2007
+# Whom: Alex Allan <alex@kamaz.org.uk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= taglookup
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= http://www.kamaz.org.uk/taglookup/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= alex@kamaz.org.uk
+COMMENT= Utility for tagging groups of audio files using CDDB
+
+LIB_DEPENDS= cddb.4:${PORTSDIR}/audio/libcddb \
+ tag.5:${PORTSDIR}/audio/taglib
+
+MAN1= taglookup.1
+PLIST_FILES= bin/taglookup
+
+.include <bsd.port.mk>
diff --git a/audio/taglookup/distinfo b/audio/taglookup/distinfo
new file mode 100644
index 000000000000..0a43763e839b
--- /dev/null
+++ b/audio/taglookup/distinfo
@@ -0,0 +1,3 @@
+MD5 (taglookup-0.2.tgz) = a77d0ea7714c338be53485db94269640
+SHA256 (taglookup-0.2.tgz) = 78463a754a85c438ffdffda4326ac83723616ba5f941a44dcd2d6b2dcfbfb0be
+SIZE (taglookup-0.2.tgz) = 16869
diff --git a/audio/taglookup/pkg-descr b/audio/taglookup/pkg-descr
new file mode 100644
index 000000000000..cef9e350856e
--- /dev/null
+++ b/audio/taglookup/pkg-descr
@@ -0,0 +1,18 @@
+Tags groups of audio files using CDDB.
+
+TagLookup is a utility for tagging MP3s and other taggable audio file formats.
+It inspects a set of audio files and uses their lengths to look up an
+appropriate disc from a CDDB-compatible service. TagLookup can be used in two
+modes:
+
+* ID -- Given a CDDB ID and a number of files, look up the details of the CDDB
+ disc from a CDDB service. Tag files using the CDDB disc. Match each file with
+ each CDDB track using the closest track length.
+* Sequence -- Given a number of files, generate a CDDB ID and query a CDDB
+ service. CDDB IDs are generated based on the sequence of tracks. Choose the
+ closest matching CDDB disc to tag the files.
+
+As well as this, taglookup can:
+* Rename -- Rename files based on their tags.
+
+WWW: http://www.kamaz.org.uk/taglookup