aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorAndrey A. Chernov <ache@FreeBSD.org>1995-02-27 20:23:12 +0000
committerAndrey A. Chernov <ache@FreeBSD.org>1995-02-27 20:23:12 +0000
commitf51f0d2884b666d52a3080aaf7b503e30e250936 (patch)
treee43c389cafe2365ae3c6f1e9bd55861dbc29bcd7 /audio
parentd2150c8f9c9c2ad9cc008fff2fddb0c804372cf4 (diff)
downloadports-f51f0d2884b666d52a3080aaf7b503e30e250936.tar.gz
ports-f51f0d2884b666d52a3080aaf7b503e30e250936.zip
Play MIDI files
Notes
Notes: svn path=/head/; revision=1052
Diffstat (limited to 'audio')
-rw-r--r--audio/playmidi/Makefile13
-rw-r--r--audio/playmidi/distinfo1
-rw-r--r--audio/playmidi/files/patch-ab98
-rw-r--r--audio/playmidi/pkg-comment1
-rw-r--r--audio/playmidi/pkg-descr9
-rw-r--r--audio/playmidi/pkg-plist9
6 files changed, 131 insertions, 0 deletions
diff --git a/audio/playmidi/Makefile b/audio/playmidi/Makefile
new file mode 100644
index 000000000000..ba0b4919f935
--- /dev/null
+++ b/audio/playmidi/Makefile
@@ -0,0 +1,13 @@
+# New ports collection makefile for: tracker
+# Version required: 4.19
+# Date created: 27 Feb 1995
+# Whom: ache
+#
+# $Id: Makefile,v 1.9 1995/02/25 17:54:38 ats Exp $
+#
+
+DISTNAME= playmidi
+DISTFILES= playmidi-1.1.tar.gz
+MASTER_SITES= ftp://sunsite.unc.edu/pub/Linux/apps/sound/players/
+
+.include <bsd.port.mk>
diff --git a/audio/playmidi/distinfo b/audio/playmidi/distinfo
new file mode 100644
index 000000000000..07a5877d3e79
--- /dev/null
+++ b/audio/playmidi/distinfo
@@ -0,0 +1 @@
+MD5 (playmidi-1.1.tar.gz) = 0bd288bfc26caedb6f85dc930390f58c
diff --git a/audio/playmidi/files/patch-ab b/audio/playmidi/files/patch-ab
new file mode 100644
index 000000000000..7af8a8dd7bf7
--- /dev/null
+++ b/audio/playmidi/files/patch-ab
@@ -0,0 +1,98 @@
+*** Makefile.orig Fri Nov 25 22:24:59 1994
+--- Makefile Mon Feb 27 23:08:42 1995
+***************
+*** 9,59 ****
+ # to prevent segmentation faults 'cause of a bug, otherwise use 2.5.8
+ #CFLAGS = -g
+ #LDFLAGS = -g
+! CFLAGS = -O2 -m486 -Wall
+! LDFLAGS = -s
+! INSTALLDIR = /usr/local/bin
+ OBJECTS = playmidi.o midifile.o playevents.o patchload.o emumidi.o
+
+ all: playmidi resetmidi
+
+! playmidi: .depend $(OBJECTS)
+ $(CC) $(LDFLAGS) -o playmidi $(OBJECTS)
+
+! resetmidi: .depend resetmidi.o
+! $(CC) -N $(LDFLAGS) -o resetmidi resetmidi.o
+!
+! scope: .depend scope.o
+! $(CC) -N $(LDFLAGS) -o scope scope.o -lvga
+
+ $(INSTALLDIR)/playmidi: playmidi
+! cp playmidi $(INSTALLDIR)
+
+ $(INSTALLDIR)/resetmidi: resetmidi
+! cp resetmidi $(INSTALLDIR)
+!
+! $(INSTALLDIR)/scope: scope
+! cp scope $(INSTALLDIR)
+
+! install: $(INSTALLDIR)/playmidi $(INSTALLDIR)/resetmidi #$(INSTALLDIR)/scope
+
+ clean:
+! rm -f *.o *~ *.bak playmidi resetmidi scope a.out
+
+- ifeq (.depend, $(wildcard .depend))
+- .depend depend dep:
+- for i in *.c; do $(CPP) -M $$i; done >.depend
+-
+- include .depend
+- else
+- depend dep:
+- for i in *.c; do $(CPP) -M $$i; done >.depend
+-
+- .depend:
+- @echo
+- @echo "Bad or missing .depend running 'make depend'"
+- @echo
+- $(MAKE) depend
+- @echo
+- @echo "Successful. Now make again (ignore following error)"
+- @exit 1
+- endif
+--- 9,50 ----
+ # to prevent segmentation faults 'cause of a bug, otherwise use 2.5.8
+ #CFLAGS = -g
+ #LDFLAGS = -g
+! PREFIX = /usr/local
+! CFLAGS += -Wall -DPREFIX=\"$(PREFIX)\"
+! #LDFLAGS = -s
+! INSTALLDIR = $(PREFIX)/bin
+ OBJECTS = playmidi.o midifile.o playevents.o patchload.o emumidi.o
++ #INSTALL_BIN = cp
++ #INSTALL_DAT = cp
++ INSTALL_BIN = $(INSTALL) -s $(COPY) -o $(BINOWN) -g $(BINGRP) -m 755
++ INSTALL_DAT = $(INSTALL) -c -o $(BINOWN) -g $(BINGRP) -m 644
+
+ all: playmidi resetmidi
+
+! playmidi: $(OBJECTS)
+ $(CC) $(LDFLAGS) -o playmidi $(OBJECTS)
+
+! resetmidi: resetmidi.o
+! $(CC) $(LDFLAGS) -o resetmidi resetmidi.o
+
+ $(INSTALLDIR)/playmidi: playmidi
+! $(INSTALL_BIN) playmidi $(INSTALLDIR)
+
+ $(INSTALLDIR)/resetmidi: resetmidi
+! $(INSTALL_BIN) resetmidi $(INSTALLDIR)
+
+! dirs:
+! -@mkdir -p $(INSTALLDIR)
+! -@mkdir -p $(PREFIX)/lib/midi
+! -@mkdir -p $(PREFIX)/lib/gus
+! -@mkdir -p $(PREFIX)/man/man1
+! -@mkdir -p $(PREFIX)/man/man3
+!
+! install: dirs $(INSTALLDIR)/playmidi $(INSTALLDIR)/resetmidi
+! $(INSTALL_DAT) std.o3 drums.o3 std.sb drums.sb $(PREFIX)/lib/midi
+! $(INSTALL_DAT) playmidi.1 $(PREFIX)/man/man1
+! $(INSTALL_DAT) midifile.3 $(PREFIX)/man/man3
+
+ clean:
+! rm -f *.o *~ *.bak playmidi resetmidi a.out
+
diff --git a/audio/playmidi/pkg-comment b/audio/playmidi/pkg-comment
new file mode 100644
index 000000000000..967dd33e5c6e
--- /dev/null
+++ b/audio/playmidi/pkg-comment
@@ -0,0 +1 @@
+Playmidi 1.1 - MIDI player
diff --git a/audio/playmidi/pkg-descr b/audio/playmidi/pkg-descr
new file mode 100644
index 000000000000..29ebda2c8d90
--- /dev/null
+++ b/audio/playmidi/pkg-descr
@@ -0,0 +1,9 @@
+ playmidi is a small quick midi file player using the level two sequencer
+ of the voxware 3.0 package to play on general midi devices or FM or
+ Gravis Ultrasound. If no files are specified, playmidi will give a short
+ summary of usage options. If more than one file is specified, you may
+ skip to the next file while the current one is playing by pressing your
+ interrupt (usually control-c) key. If you invoke playmidi while it is al-
+ ready running, it will allow you to control the currently running invoca-
+ tion until its death, after which time all waiting invocations fight to
+ go first.
diff --git a/audio/playmidi/pkg-plist b/audio/playmidi/pkg-plist
new file mode 100644
index 000000000000..10238841d74d
--- /dev/null
+++ b/audio/playmidi/pkg-plist
@@ -0,0 +1,9 @@
+@cwd /usr/local
+bin/playmidi
+bin/resetmidi
+lib/midi/std.o3
+lib/midi/std.sb
+lib/midi/drums.o3
+lib/midi/drums.sb
+man/man1/playmidi.1
+man/man3/midifile.3