aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2004-04-13 12:57:26 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2004-04-13 12:57:26 +0000
commit1350b37fee73a170460aa86c8fd79e0124632977 (patch)
tree6d441d807ecb868a0d67a552a3eb1503347befde /audio
parentbebc268cabde4924174e76793cabf611659ec241 (diff)
downloadports-1350b37fee73a170460aa86c8fd79e0124632977.tar.gz
ports-1350b37fee73a170460aa86c8fd79e0124632977.zip
Make it work on 64bit platforms.
PR: 64964 Submitted by: tjr Obtained from: faad CVS
Notes
Notes: svn path=/head/; revision=106909
Diffstat (limited to 'audio')
-rw-r--r--audio/faad/Makefile6
-rw-r--r--audio/faad/files/patch-structs.h92
2 files changed, 92 insertions, 6 deletions
diff --git a/audio/faad/Makefile b/audio/faad/Makefile
index 85b855c66740..2ed21fc85f48 100644
--- a/audio/faad/Makefile
+++ b/audio/faad/Makefile
@@ -55,12 +55,6 @@ post-configure:
.include <bsd.port.pre.mk>
-# No matter what file you try to play, it gives the error message:
-# Error: Pulse coding not allowed in short blocks.
-.if ${ARCH} == "amd64"
-IGNORE= Does not work
-.endif
-
CONFIGURE_ARGS+= --build=${CONFIGURE_TARGET}
.include <bsd.port.post.mk>
diff --git a/audio/faad/files/patch-structs.h b/audio/faad/files/patch-structs.h
new file mode 100644
index 000000000000..3bfb42d3001e
--- /dev/null
+++ b/audio/faad/files/patch-structs.h
@@ -0,0 +1,92 @@
+--- libfaad/structs.h.orig Thu Nov 13 07:47:59 2003
++++ libfaad/structs.h Sun Apr 11 22:01:09 2004
+@@ -297,57 +297,57 @@
+ typedef struct mp4AudioSpecificConfig
+ {
+ /* Audio Specific Info */
+- uint8_t objectTypeIndex;
+- uint8_t samplingFrequencyIndex;
+- uint32_t samplingFrequency;
+- uint8_t channelsConfiguration;
++ unsigned char objectTypeIndex;
++ unsigned char samplingFrequencyIndex;
++ unsigned long samplingFrequency;
++ unsigned char channelsConfiguration;
+
+ /* GA Specific Info */
+- uint8_t frameLengthFlag;
+- uint8_t dependsOnCoreCoder;
+- uint16_t coreCoderDelay;
+- uint8_t extensionFlag;
+- uint8_t aacSectionDataResilienceFlag;
+- uint8_t aacScalefactorDataResilienceFlag;
+- uint8_t aacSpectralDataResilienceFlag;
+- uint8_t epConfig;
++ unsigned char frameLengthFlag;
++ unsigned char dependsOnCoreCoder;
++ unsigned short coreCoderDelay;
++ unsigned char extensionFlag;
++ unsigned char aacSectionDataResilienceFlag;
++ unsigned char aacScalefactorDataResilienceFlag;
++ unsigned char aacSpectralDataResilienceFlag;
++ unsigned char epConfig;
+
+- int8_t sbr_present_flag;
+- int8_t forceUpSampling;
++ char sbr_present_flag;
++ char forceUpSampling;
+ } mp4AudioSpecificConfig;
+
+ typedef struct faacDecConfiguration
+ {
+- uint8_t defObjectType;
+- uint32_t defSampleRate;
+- uint8_t outputFormat;
+- uint8_t downMatrix;
+- uint8_t useOldADTSFormat;
++ unsigned char defObjectType;
++ unsigned long defSampleRate;
++ unsigned char outputFormat;
++ unsigned char downMatrix;
++ unsigned char useOldADTSFormat;
+ } faacDecConfiguration, *faacDecConfigurationPtr;
+
+ typedef struct faacDecFrameInfo
+ {
+- uint32_t bytesconsumed;
+- uint32_t samples;
+- uint8_t channels;
+- uint8_t error;
+- uint32_t samplerate;
++ unsigned long bytesconsumed;
++ unsigned long samples;
++ unsigned char channels;
++ unsigned char error;
++ unsigned long samplerate;
+
+ /* SBR: 0: off, 1: on; normal, 2: on; downsampled */
+- uint8_t sbr;
++ unsigned char sbr;
+
+ /* MPEG-4 ObjectType */
+- uint8_t object_type;
++ unsigned char object_type;
+
+ /* AAC header type; MP4 will be signalled as RAW also */
+- uint8_t header_type;
++ unsigned char header_type;
+
+ /* multichannel configuration */
+- uint8_t num_front_channels;
+- uint8_t num_side_channels;
+- uint8_t num_back_channels;
+- uint8_t num_lfe_channels;
+- uint8_t channel_position[MAX_CHANNELS];
++ unsigned char num_front_channels;
++ unsigned char num_side_channels;
++ unsigned char num_back_channels;
++ unsigned char num_lfe_channels;
++ unsigned char channel_position[MAX_CHANNELS];
+ } faacDecFrameInfo;
+
+ typedef struct