aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2001-08-29 18:58:19 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2001-08-29 18:58:19 +0000
commit9ab6a37c4ca9efe48a5c4e6535f00ec293b3b8e8 (patch)
tree22ce492e6ef56fbcd1b0219ed43ed81c17f8baaa /audio
parent4c1a76f69e0e9b3c188445a8ccbdffea42bb52af (diff)
downloadports-9ab6a37c4ca9efe48a5c4e6535f00ec293b3b8e8.tar.gz
ports-9ab6a37c4ca9efe48a5c4e6535f00ec293b3b8e8.zip
Use PTHREAD_CFLAGS and PTHREAD_LIBS to "follow the ways of bentoism".
Submitted by: Patrick Li <pat@databits.net> PR: 29596
Notes
Notes: svn path=/head/; revision=47108
Diffstat (limited to 'audio')
-rw-r--r--audio/snd/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/audio/snd/Makefile b/audio/snd/Makefile
index b76e0f3956ef..d831dbaf065a 100644
--- a/audio/snd/Makefile
+++ b/audio/snd/Makefile
@@ -48,7 +48,9 @@ CONFIGURE_ARGS+= --with-gtk-extra
CONFIGURE_ARGS+= --without-gui
.endif
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
+ CFLAGS="${CFLAGS} ${PTHREAD_CFLAGS}"
+
GNU_CONFIGURE= yes
MAKEFILE= makefile
PLIST= ${WRKDIR}/pkg-plist