aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-05-06 20:55:05 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-05-06 20:55:05 +0000
commit2de884520a57f3eda9a525170cb7bcd5af480b8a (patch)
tree76fbe3c47d753f33f03da41fac73282b10d865ee /audio
parente87b59efc3196e3a8f49bafb6c90585792d6741c (diff)
downloadports-2de884520a57f3eda9a525170cb7bcd5af480b8a.tar.gz
ports-2de884520a57f3eda9a525170cb7bcd5af480b8a.zip
Resurrect the musicbox port, which was prematurely sent to the grave by
Will.
Notes
Notes: svn path=/head/; revision=58624
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/musicbox/Makefile46
-rw-r--r--audio/musicbox/distinfo1
-rw-r--r--audio/musicbox/files/patch-ListView.cpp26
-rw-r--r--audio/musicbox/files/patch-Makefile109
-rw-r--r--audio/musicbox/files/patch-MultiListBox.h10
-rw-r--r--audio/musicbox/files/patch-player.cpp60
-rw-r--r--audio/musicbox/files/patch-qktstreelist.cpp20
-rw-r--r--audio/musicbox/pkg-comment1
-rw-r--r--audio/musicbox/pkg-descr4
10 files changed, 278 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index dcca7bec56f3..f5a21c729d5c 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -145,6 +145,7 @@
SUBDIR += mpmf20
SUBDIR += mpt
SUBDIR += mq3
+ SUBDIR += musicbox
SUBDIR += musicbrainz
SUBDIR += mutemix
SUBDIR += mxv
diff --git a/audio/musicbox/Makefile b/audio/musicbox/Makefile
new file mode 100644
index 000000000000..3e3982bda178
--- /dev/null
+++ b/audio/musicbox/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: musicbox
+# Date created: 2000-12-31
+# Whom: trevor
+# based on the NetBSD pkgsrc by tron@NetBSD.org
+#
+# $NetBSD: Makefile,v 1.7 2000/07/14 16:04:19 agc Exp $
+# $FreeBSD$
+#
+
+PORTNAME= musicbox
+PORTVERSION= 1.01p2
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_NETBSD} # ftp://freebsd.csie.nctu.edu.tw/Upload/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trevor@FreeBSD.org
+
+RUN_DEPENDS= mpg123:${PORTSDIR}/audio/mpg123
+
+USE_QT_VER= 1
+DOCS= ChangeLog README
+EVAL_PREFIX+= QT1DIR=qt1
+PATH= ${QT1DIR}/qt/bin:$$PATH
+PLIST= ${WRKDIR}/pkg-plist
+USE_X_PREFIX= yes
+WRKSRC= ${WRKDIR}/musicbox-1.01
+
+pre-install:
+ ${ECHO_CMD} bin/musicbox > ${PLIST}
+.if !defined(NOPORTDOCS)
+.for i in ${DOCS}
+ ${ECHO_CMD} share/doc/musicbox/${i} >> ${PLIST}
+.endfor
+ ${ECHO_CMD} @dirrm share/doc/musicbox >> ${PLIST}
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/musicbox ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/musicbox
+.for i in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${PREFIX}/share/doc/musicbox
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/musicbox/distinfo b/audio/musicbox/distinfo
new file mode 100644
index 000000000000..a33c847c4b32
--- /dev/null
+++ b/audio/musicbox/distinfo
@@ -0,0 +1 @@
+MD5 (musicbox-1.01p2.tgz) = cdaad5a34c33c78af568bc6e589aa257
diff --git a/audio/musicbox/files/patch-ListView.cpp b/audio/musicbox/files/patch-ListView.cpp
new file mode 100644
index 000000000000..729063cf2bb2
--- /dev/null
+++ b/audio/musicbox/files/patch-ListView.cpp
@@ -0,0 +1,26 @@
+--- ListView.cpp.orig Wed Feb 17 09:17:11 1999
++++ ListView.cpp Wed Feb 17 09:21:00 1999
+@@ -383,11 +383,11 @@
+ if (item != NULL)
+ temp = item;
+
+- lbl = new QLabel("歌星:",this);
++ lbl = new QLabel("Artist:",this);
+ topLayout->addWidget(lbl,0,0);
+- lbl = new QLabel("專輯名稱:",this);
++ lbl = new QLabel("Album:",this);
+ topLayout->addWidget(lbl,1,0);
+- lbl = new QLabel("發行公司:",this);
++ lbl = new QLabel("Company:",this);
+ topLayout->addWidget(lbl,2,0);
+
+ Title = new QLabel(this);
+@@ -412,7 +412,7 @@
+ connect(btn,SIGNAL(clicked()),this,SLOT(RemoveSong()));
+ topLayout->addWidget(btn,4,1);
+
+- lbl = new QLabel("歌曲名稱:",this);
++ lbl = new QLabel("Title:",this);
+ topLayout->addWidget(lbl,4,2);
+
+ edtSinger = new QLineEdit(this);
diff --git a/audio/musicbox/files/patch-Makefile b/audio/musicbox/files/patch-Makefile
new file mode 100644
index 000000000000..8690d61572d8
--- /dev/null
+++ b/audio/musicbox/files/patch-Makefile
@@ -0,0 +1,109 @@
+--- Makefile.orig Wed Nov 12 11:01:58 1997
++++ Makefile Sun May 5 14:57:01 2002
+@@ -1,7 +1,8 @@
+ # change following for your environment
+-INC = /usr/X11R6/include/X11/qt
+-LIB = /usr/X11R6/lib
+-MOC = moc
++#INC = /usr/X11R6/include/X11/qt1
++INC = -I${X11BASE}/include -I${X11BASE}/include/X11/qt1
++LIB = -L${X11BASE}/lib -Wl,-R${X11BASE}/lib -L${X11BASE}/lib -Wl,-R${X11BASE}/lib
++MOC = moc1
+
+ # if you use freebsd
+ CFLAGS = -DFreeBSD
+@@ -9,7 +10,7 @@
+ #if you use linux
+ #CFLAGS = -DLinux
+
+-GCC = gcc
++GCC ?= cc
+
+ ALL = mplayer.o player.o ListView.o clock.o mclock.o mListView.o \
+ filebrowse.o mfilebrowse.o qktstreelist.o mqktstreelist.o \
+@@ -18,69 +19,69 @@
+ PKG = musicbox
+
+ all: ${ALL}
+- ${GCC} ${ALL} -o ${PKG} -L${LIB} -I${INC} -lqt
++ ${GCC} ${ALL} -o ${PKG} ${LIB} -lqt1 -lX11 -lXext
+
+-player.o:
+- ${GCC} -c player.cpp -o player.o ${CFLAGS} -L${LIB} -I${INC}
++player.o: player.cpp
++ ${GCC} -c player.cpp -o player.o ${CFLAGS} ${INC}
+
+ mplayer.o: mplayer.cpp
+- ${GCC} -c mplayer.cpp -o mplayer.o ${CFLAGS} -L${LIB} -I${INC}
++ ${GCC} -c mplayer.cpp -o mplayer.o ${CFLAGS} ${INC}
+
+ mplayer.cpp:
+ ${MOC} player.h -o mplayer.cpp
+
+ ListView.o:
+- ${GCC} -c ListView.cpp -o ListView.o ${CFLAGS} -L${LIB} -I${INC}
++ ${GCC} -c ListView.cpp -o ListView.o ${CFLAGS} ${INC}
+
+ mListView.o: mListView.cpp
+- ${GCC} -c mListView.cpp -o mListView.o ${CFLAGS} -L${LIB} -I${INC}
++ ${GCC} -c mListView.cpp -o mListView.o ${CFLAGS} ${INC}
+
+ mListView.cpp:
+ ${MOC} ListView.h -o mListView.cpp
+ clock.o:
+- ${GCC} -c clock.cpp -o clock.o -L${LIB} -I${INC}
++ ${GCC} -c clock.cpp -o clock.o ${INC}
+
+ mclock.cpp:
+ ${MOC} clock.h -o mclock.cpp
+
+ mclock.o: mclock.cpp
+- ${GCC} -c mclock.cpp -o mclock.o -L${LIB} -I${INC}
++ ${GCC} -c mclock.cpp -o mclock.o ${INC}
+
+ mfilebrowse.cpp:
+ ${MOC} filebrowse.h -o mfilebrowse.cpp
+
+ filebrowse.o :
+- ${GCC} -c filebrowse.cpp -o filebrowse.o -L${LIB} -I${INC}
++ ${GCC} -c filebrowse.cpp -o filebrowse.o ${INC}
+
+ mfilebrowse.o: mfilebrowse.cpp
+- ${GCC} -c mfilebrowse.cpp -o mfilebrowse.o -L${LIB} -I${INC}
++ ${GCC} -c mfilebrowse.cpp -o mfilebrowse.o ${INC}
+
+ diskbrowse.o:
+- ${GCC} -c diskbrowse.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c diskbrowse.cpp -o $@ ${INC}
+
+ mdiskbrowse.o: mdiskbrowse.cpp
+- ${GCC} -c mdiskbrowse.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c mdiskbrowse.cpp -o $@ ${INC}
+
+ mdiskbrowse.cpp:
+ ${MOC} diskbrowse.h -o $@
+
+ qktstreelist.o:
+- ${GCC} -c qktstreelist.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c qktstreelist.cpp -o $@ ${INC}
+
+ mqktstreelist.o: mqktstreelist.cpp
+- ${GCC} -c mqktstreelist.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c mqktstreelist.cpp -o $@ ${INC}
+
+ mqktstreelist.cpp:
+ ${MOC} qktstreelist.h -o $@
+
+ MultiListBox.o:
+- ${GCC} -c MultiListBox.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c MultiListBox.cpp -o $@ ${INC}
+
+ mMultiListBox.cpp:
+ ${MOC} MultiListBox.h -o $@
+
+ mMultiListBox.o: mMultiListBox.cpp
+- ${GCC} -c mMultiListBox.cpp -o $@ -L${LIB} -I${INC}
++ ${GCC} -c mMultiListBox.cpp -o $@ ${INC}
+
+ clean:
+ rm -f player mplayer.cpp *.o mclock.cpp mListView.cpp mfilebrowse.cpp \
diff --git a/audio/musicbox/files/patch-MultiListBox.h b/audio/musicbox/files/patch-MultiListBox.h
new file mode 100644
index 000000000000..0f1a18e79446
--- /dev/null
+++ b/audio/musicbox/files/patch-MultiListBox.h
@@ -0,0 +1,10 @@
+--- MultiListBox.h.orig Wed Nov 12 10:57:00 1997
++++ MultiListBox.h Sun Dec 31 06:24:22 2000
+@@ -16,7 +16,6 @@
+ Pic = i->Pic;
+ Text = i->Text;
+ }
+- setPixmap(QPixmap& p) {Pic = p;}
+ int Width(MultiListBox *box);
+ int Height(MultiListBox *box,int max_w);
+ void Paint(QPainter *p,int w,int h,int flag=0);
diff --git a/audio/musicbox/files/patch-player.cpp b/audio/musicbox/files/patch-player.cpp
new file mode 100644
index 000000000000..5afe8b464f71
--- /dev/null
+++ b/audio/musicbox/files/patch-player.cpp
@@ -0,0 +1,60 @@
+--- player.cpp.orig Thu Oct 1 10:00:23 1998
++++ player.cpp Wed Jun 9 00:56:30 1999
+@@ -72,7 +72,7 @@
+ options = new QPopupMenu;
+ AutoPlayID = options->insertItem( "&Auto Play", this, SLOT(AutoPlay()) );
+ options->setItemChecked( AutoPlayID, isAutoPlay );
+- RepeatID = options->insertItem( "Re&peat", this, SLOT(RepeatPlay()) );
++ RepeatID = options->insertItem( "&Repeat", this, SLOT(RepeatPlay()) );
+ options->setCheckable(TRUE);
+ menubar->insertItem( "&Options",options );
+ menubar->insertSeparator();
+@@ -150,7 +150,7 @@
+
+ QLabel *label;
+ label = new QLabel( this );
+- label->setText("歌星:");
++ label->setText("Artist:");
+ label->setGeometry(5,133,125,30);
+
+ edtName = new QLabel( this );
+@@ -158,7 +158,7 @@
+ edtName->setGeometry(83,136,100,25);
+
+ label = new QLabel( this );
+- label->setText("專輯名稱:");
++ label->setText("Album:");
+ label->setGeometry(5,173,125,30);
+
+ edtAlbum = new QLabel( this );
+@@ -166,7 +166,7 @@
+ edtAlbum->setGeometry(83,176,100,25);
+
+ label = new QLabel( this );
+- label->setText("發行公司:");
++ label->setText("Company:");
+ label->setGeometry(5,213,125,30);
+
+ edtPub = new QLabel( this );
+@@ -242,15 +242,13 @@
+ song->setText(SongBox->text(SongBox->currentItem()));
+ dclock->Start(SongBox->currentItem());
+ if ((mp3_pid = fork()) == 0 ){
+- char **argv;
+- int i;
+- argv[0]=MP3_PLAYER;
+- argv[1]="-q";
+- argv[2]=(char *)LocBox->text(SongBox->currentItem());
+- argv[3]=NULL;
+- execvp(MP3_PLAYER,argv);
++ execlp(MP3_PLAYER,
++ MP3_PLAYER,
++ "-q",
++ (char *)LocBox->text(SongBox->currentItem()),
++ NULL);
+ QMessageBox::warning(this,"error","can't exec mpg123\n");
+- exit(1);
++ _exit(1);
+ }
+ }
+ }
diff --git a/audio/musicbox/files/patch-qktstreelist.cpp b/audio/musicbox/files/patch-qktstreelist.cpp
new file mode 100644
index 000000000000..51bd04655ad6
--- /dev/null
+++ b/audio/musicbox/files/patch-qktstreelist.cpp
@@ -0,0 +1,20 @@
+--- qktstreelist.cpp.orig Mon Nov 10 18:10:02 1997
++++ qktstreelist.cpp Wed Jun 9 00:15:13 1999
+@@ -834,7 +834,7 @@
+ QktsItemSearchInfo searchInfo;
+ searchInfo.index = index;
+ searchInfo.count = -1;
+- forEveryVisibleItem(QktsTreeList::findItemAt, &searchInfo);
++ forEveryVisibleItem(&QktsTreeList::findItemAt, &searchInfo);
+ return searchInfo.foundItem;
+ }
+
+@@ -1340,7 +1340,7 @@
+ QktsTreeListItem *item = treeRoot->getChild();
+ do {
+ while(item) {
+- if((func)(item, user)) return;
++ if((this->*func)(item, user)) return;
+ if(item->hasChild() && item->isExpanded()) {
+ stack.push(item);
+ item = item->getChild();
diff --git a/audio/musicbox/pkg-comment b/audio/musicbox/pkg-comment
new file mode 100644
index 000000000000..6ca3841a9b62
--- /dev/null
+++ b/audio/musicbox/pkg-comment
@@ -0,0 +1 @@
+X11 front end for mpg123
diff --git a/audio/musicbox/pkg-descr b/audio/musicbox/pkg-descr
new file mode 100644
index 000000000000..4d55f0bbc85b
--- /dev/null
+++ b/audio/musicbox/pkg-descr
@@ -0,0 +1,4 @@
+Music Box is a Qt-based front end to mpg123.
+
+Trevor Johnson
+trevor@FreeBSD.org