aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorPatrick Li <pat@FreeBSD.org>2002-03-15 05:24:22 +0000
committerPatrick Li <pat@FreeBSD.org>2002-03-15 05:24:22 +0000
commit14449954e0e68f6fb0bd8c57637ed037b206d67b (patch)
treefee29d9051160240b945f668e230280f823bd0bf /audio
parentb62c7782ac3910b626ca5b1f7ddc4448a1b30e3a (diff)
downloadports-14449954e0e68f6fb0bd8c57637ed037b206d67b.tar.gz
ports-14449954e0e68f6fb0bd8c57637ed037b206d67b.zip
Remove unnecessary ORBit dependency that installs an experimental UI plugin
and unbreaks build if ORBit is not installed. Bump PORTREVISION. PR: 35915 Submitted by: maintainer Noticed by: kris
Notes
Notes: svn path=/head/; revision=56124
Diffstat (limited to 'audio')
-rw-r--r--audio/freeamp/Makefile7
-rw-r--r--audio/freeamp/files/patch-aa43
-rw-r--r--audio/freeamp/pkg-plist1
-rw-r--r--audio/zinf/Makefile7
-rw-r--r--audio/zinf/files/patch-aa43
-rw-r--r--audio/zinf/pkg-plist1
6 files changed, 58 insertions, 44 deletions
diff --git a/audio/freeamp/Makefile b/audio/freeamp/Makefile
index 7aae10fc6da5..1b39c431a0f0 100644
--- a/audio/freeamp/Makefile
+++ b/audio/freeamp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freeamp
PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.freeamp.org/download/src/
@@ -15,7 +15,6 @@ MAINTAINER= ports@geeksrus.net
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
- ORBit.2:${PORTSDIR}/devel/ORBit \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
ttf.4:${PORTSDIR}/print/freetype
@@ -25,9 +24,7 @@ USE_GTK= yes
WANT_ESOUND= yes
USE_GMAKE= yes
USE_AUTOCONF_VER=213
-ORBIT_CFLAGS!= orbit-config --cflags server
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- ${ORBIT_CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
diff --git a/audio/freeamp/files/patch-aa b/audio/freeamp/files/patch-aa
index 61220aea2e96..a28137bd431c 100644
--- a/audio/freeamp/files/patch-aa
+++ b/audio/freeamp/files/patch-aa
@@ -1,5 +1,5 @@
---- configure.in.orig Tue Dec 11 06:42:31 2001
-+++ configure.in Sun Dec 16 23:03:03 2001
+--- configure.in.orig Mon Dec 10 16:42:31 2001
++++ configure.in Thu Mar 14 23:34:42 2002
@@ -179,8 +179,8 @@
;;
freebsd*)
@@ -71,7 +71,7 @@
AC_DEFINE(HAVE_GTK)
elif test "$host_os" = "beos"; then
OSDEPPLUGINS="$OSDEPPLUGINS plugins/musicbrowser.ui"
-@@ -541,7 +541,7 @@
+@@ -541,17 +541,10 @@
AC_SUBST(GTK_LIBS)
AC_SUBST(EXTRALIBS)
@@ -79,8 +79,19 @@
+AC_SUBST(CPPFLAGS)
dnl orbit crap
- save_CPPFLAGS="$CPPFLAGS"
-@@ -661,7 +661,7 @@
+-save_CPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
+-AC_LANG_SAVE
+-AC_LANG_C
+-AC_CHECK_HEADERS(orb/orbit.h, have_orbit="true", have_orbit="false")
+-CPPFLAGS="$save_CPPFLAGS"
+-AC_LANG_RESTORE
+-
++have_orbit="false"
+ ORBIT_LIBS=""
+ ORBIT_IDL=""
+
+@@ -661,7 +654,7 @@
alsa_min_major_version=0
alsa_min_minor_version=5
alsa_min_micro_version=0
@@ -89,7 +100,7 @@
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lasound"
-@@ -706,7 +706,7 @@
+@@ -706,7 +699,7 @@
], , have_alsa=false, have_alsa=false
)
AC_LANG_RESTORE
@@ -98,7 +109,7 @@
LIBS="$ac_save_LIBS"
if test "$have_alsa" = "false"; then
AC_MSG_RESULT(no)
-@@ -726,6 +726,10 @@
+@@ -726,6 +719,10 @@
AC_MSG_RESULT([compiling alsa pmo plugin])
fi
@@ -109,7 +120,7 @@
AC_CHECK_LIB(ogg, ogg_sync_init, have_ogg="yes",)
AC_CHECK_LIB(vorbisfile, ov_info, have_vorbis="yes",, -lvorbis -logg)
-@@ -736,6 +740,7 @@
+@@ -736,6 +733,7 @@
OSDEPPLUGINS="$OSDEPPLUGINS plugins/vorbis.mdf";
AC_MSG_RESULT([compiling vorbis codec plugin])
fi
@@ -117,7 +128,7 @@
fi
ID3_LIBS=""
-@@ -749,6 +754,9 @@
+@@ -749,6 +747,9 @@
dnl Partly taken from SDL's configure.in
dnl -------------------------------------------------------------
@@ -127,7 +138,7 @@
AC_PATH_PROG(ARTSCCONFIG, artsc-config)
if test x$ARTSCCONFIG = x -o x$ARTSCCONFIG = x'"$ARTSCCONFIG"'; then
: # arts isn't installed
-@@ -765,6 +773,7 @@
+@@ -765,6 +766,7 @@
AC_MSG_RESULT([compiling arts pmo plugin])
])
fi
@@ -135,7 +146,7 @@
AC_SUBST(ARTS_LIBS)
AC_SUBST(EXTRALIBS)
-@@ -819,9 +828,9 @@
+@@ -819,9 +821,9 @@
gdk_pixbuf_micro_version=`$GDK_PIXBUF_CONFIG $gdk_pixbuf_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
if test "x$enable_gdk_pixbuftest" = "xyes" ; then
@@ -147,7 +158,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
dnl
dnl Now check if the installed GDK_PIXBUF is sufficiently new. (Also sanity
-@@ -883,7 +892,7 @@
+@@ -883,7 +885,7 @@
}
],, no_gdk_pixbuf=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
@@ -156,7 +167,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -902,7 +911,7 @@
+@@ -902,7 +904,7 @@
:
else
echo "*** Could not run GDK_PIXBUF test program, checking why..."
@@ -165,7 +176,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-@@ -921,7 +930,7 @@
+@@ -921,7 +923,7 @@
echo "*** exact error that occured. This usually means GDK_PIXBUF was incorrectly installed"
echo "*** or that you have moved GDK_PIXBUF since it was installed. In the latter case, you"
echo "*** may want to edit the gdk-pixbuf-config script: $GDK_PIXBUF_CONFIG" ])
@@ -174,7 +185,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -933,8 +942,8 @@
+@@ -933,8 +935,8 @@
AC_SUBST(GDK_PIXBUF_LIBS)
rm -f conf.gdk_pixbuftest
@@ -185,7 +196,7 @@
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-@@ -944,7 +953,7 @@
+@@ -944,7 +946,7 @@
echo "*** Download the library from "
echo "*** http://www.musicbrainz.org/download.html"
echo "***"
diff --git a/audio/freeamp/pkg-plist b/audio/freeamp/pkg-plist
index 8ea3ae02bf62..4fa3140c6248 100644
--- a/audio/freeamp/pkg-plist
+++ b/audio/freeamp/pkg-plist
@@ -3,7 +3,6 @@ etc/sdr/plugins/sdr2.plugin.S100.audio.rtp.mpa.freeamp
%%LIBARTS%%lib/freeamp/plugins/arts.pmo
lib/freeamp/plugins/cd.lmc
lib/freeamp/plugins/cd.pmo
-lib/freeamp/plugins/corba.ui
lib/freeamp/plugins/download.ui
%%ESOUND%%lib/freeamp/plugins/esound.pmo
lib/freeamp/plugins/freeamp.ui
diff --git a/audio/zinf/Makefile b/audio/zinf/Makefile
index 7aae10fc6da5..1b39c431a0f0 100644
--- a/audio/zinf/Makefile
+++ b/audio/zinf/Makefile
@@ -7,7 +7,7 @@
PORTNAME= freeamp
PORTVERSION= 2.1.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio
MASTER_SITES= http://www.freeamp.org/download/src/
@@ -15,7 +15,6 @@ MAINTAINER= ports@geeksrus.net
BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= musicbrainz.1:${PORTSDIR}/audio/musicbrainz \
- ORBit.2:${PORTSDIR}/devel/ORBit \
gdk_pixbuf.2:${PORTSDIR}/graphics/gdk-pixbuf \
ttf.4:${PORTSDIR}/print/freetype
@@ -25,9 +24,7 @@ USE_GTK= yes
WANT_ESOUND= yes
USE_GMAKE= yes
USE_AUTOCONF_VER=213
-ORBIT_CFLAGS!= orbit-config --cflags server
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS} \
- ${ORBIT_CFLAGS}" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
.include <bsd.port.pre.mk>
diff --git a/audio/zinf/files/patch-aa b/audio/zinf/files/patch-aa
index 61220aea2e96..a28137bd431c 100644
--- a/audio/zinf/files/patch-aa
+++ b/audio/zinf/files/patch-aa
@@ -1,5 +1,5 @@
---- configure.in.orig Tue Dec 11 06:42:31 2001
-+++ configure.in Sun Dec 16 23:03:03 2001
+--- configure.in.orig Mon Dec 10 16:42:31 2001
++++ configure.in Thu Mar 14 23:34:42 2002
@@ -179,8 +179,8 @@
;;
freebsd*)
@@ -71,7 +71,7 @@
AC_DEFINE(HAVE_GTK)
elif test "$host_os" = "beos"; then
OSDEPPLUGINS="$OSDEPPLUGINS plugins/musicbrowser.ui"
-@@ -541,7 +541,7 @@
+@@ -541,17 +541,10 @@
AC_SUBST(GTK_LIBS)
AC_SUBST(EXTRALIBS)
@@ -79,8 +79,19 @@
+AC_SUBST(CPPFLAGS)
dnl orbit crap
- save_CPPFLAGS="$CPPFLAGS"
-@@ -661,7 +661,7 @@
+-save_CPPFLAGS="$CPPFLAGS"
+-CPPFLAGS="$CPPFLAGS $GTK_CFLAGS"
+-AC_LANG_SAVE
+-AC_LANG_C
+-AC_CHECK_HEADERS(orb/orbit.h, have_orbit="true", have_orbit="false")
+-CPPFLAGS="$save_CPPFLAGS"
+-AC_LANG_RESTORE
+-
++have_orbit="false"
+ ORBIT_LIBS=""
+ ORBIT_IDL=""
+
+@@ -661,7 +654,7 @@
alsa_min_major_version=0
alsa_min_minor_version=5
alsa_min_micro_version=0
@@ -89,7 +100,7 @@
ac_save_LIBS="$LIBS"
LIBS="$LIBS -lasound"
-@@ -706,7 +706,7 @@
+@@ -706,7 +699,7 @@
], , have_alsa=false, have_alsa=false
)
AC_LANG_RESTORE
@@ -98,7 +109,7 @@
LIBS="$ac_save_LIBS"
if test "$have_alsa" = "false"; then
AC_MSG_RESULT(no)
-@@ -726,6 +726,10 @@
+@@ -726,6 +719,10 @@
AC_MSG_RESULT([compiling alsa pmo plugin])
fi
@@ -109,7 +120,7 @@
AC_CHECK_LIB(ogg, ogg_sync_init, have_ogg="yes",)
AC_CHECK_LIB(vorbisfile, ov_info, have_vorbis="yes",, -lvorbis -logg)
-@@ -736,6 +740,7 @@
+@@ -736,6 +733,7 @@
OSDEPPLUGINS="$OSDEPPLUGINS plugins/vorbis.mdf";
AC_MSG_RESULT([compiling vorbis codec plugin])
fi
@@ -117,7 +128,7 @@
fi
ID3_LIBS=""
-@@ -749,6 +754,9 @@
+@@ -749,6 +747,9 @@
dnl Partly taken from SDL's configure.in
dnl -------------------------------------------------------------
@@ -127,7 +138,7 @@
AC_PATH_PROG(ARTSCCONFIG, artsc-config)
if test x$ARTSCCONFIG = x -o x$ARTSCCONFIG = x'"$ARTSCCONFIG"'; then
: # arts isn't installed
-@@ -765,6 +773,7 @@
+@@ -765,6 +766,7 @@
AC_MSG_RESULT([compiling arts pmo plugin])
])
fi
@@ -135,7 +146,7 @@
AC_SUBST(ARTS_LIBS)
AC_SUBST(EXTRALIBS)
-@@ -819,9 +828,9 @@
+@@ -819,9 +821,9 @@
gdk_pixbuf_micro_version=`$GDK_PIXBUF_CONFIG $gdk_pixbuf_config_args --version | \
sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
if test "x$enable_gdk_pixbuftest" = "xyes" ; then
@@ -147,7 +158,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
dnl
dnl Now check if the installed GDK_PIXBUF is sufficiently new. (Also sanity
-@@ -883,7 +892,7 @@
+@@ -883,7 +885,7 @@
}
],, no_gdk_pixbuf=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
@@ -156,7 +167,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -902,7 +911,7 @@
+@@ -902,7 +904,7 @@
:
else
echo "*** Could not run GDK_PIXBUF test program, checking why..."
@@ -165,7 +176,7 @@
LIBS="$LIBS $GDK_PIXBUF_LIBS"
AC_TRY_LINK([
#include <stdio.h>
-@@ -921,7 +930,7 @@
+@@ -921,7 +923,7 @@
echo "*** exact error that occured. This usually means GDK_PIXBUF was incorrectly installed"
echo "*** or that you have moved GDK_PIXBUF since it was installed. In the latter case, you"
echo "*** may want to edit the gdk-pixbuf-config script: $GDK_PIXBUF_CONFIG" ])
@@ -174,7 +185,7 @@
LIBS="$ac_save_LIBS"
fi
fi
-@@ -933,8 +942,8 @@
+@@ -933,8 +935,8 @@
AC_SUBST(GDK_PIXBUF_LIBS)
rm -f conf.gdk_pixbuftest
@@ -185,7 +196,7 @@
AC_LANG_SAVE
AC_LANG_CPLUSPLUS
-@@ -944,7 +953,7 @@
+@@ -944,7 +946,7 @@
echo "*** Download the library from "
echo "*** http://www.musicbrainz.org/download.html"
echo "***"
diff --git a/audio/zinf/pkg-plist b/audio/zinf/pkg-plist
index 8ea3ae02bf62..4fa3140c6248 100644
--- a/audio/zinf/pkg-plist
+++ b/audio/zinf/pkg-plist
@@ -3,7 +3,6 @@ etc/sdr/plugins/sdr2.plugin.S100.audio.rtp.mpa.freeamp
%%LIBARTS%%lib/freeamp/plugins/arts.pmo
lib/freeamp/plugins/cd.lmc
lib/freeamp/plugins/cd.pmo
-lib/freeamp/plugins/corba.ui
lib/freeamp/plugins/download.ui
%%ESOUND%%lib/freeamp/plugins/esound.pmo
lib/freeamp/plugins/freeamp.ui