aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorDima Panov <fluffy@FreeBSD.org>2010-06-05 12:49:01 +0000
committerDima Panov <fluffy@FreeBSD.org>2010-06-05 12:49:01 +0000
commit2588e8f4e972ee822cc4f75a333cd42616b11911 (patch)
treeb71ca27708b10845d10612956303bfa496c71a96 /audio
parent4070922aacfb6c34ccd987bccfaea6414adf86fb (diff)
downloadports-2588e8f4e972ee822cc4f75a333cd42616b11911.tar.gz
ports-2588e8f4e972ee822cc4f75a333cd42616b11911.zip
- New port: audio/alsa-utils Compatibility layer for ALSA support
PR: 145967 Submitted by: Aragon Gouveia <aragon AT phat.za.net>
Notes
Notes: svn path=/head/; revision=255776
Diffstat (limited to 'audio')
-rw-r--r--audio/alsa-utils/Makefile40
-rw-r--r--audio/alsa-utils/distinfo3
-rw-r--r--audio/alsa-utils/files/patch-alsa-utils77
-rw-r--r--audio/alsa-utils/pkg-descr3
-rw-r--r--audio/alsa-utils/pkg-plist35
5 files changed, 158 insertions, 0 deletions
diff --git a/audio/alsa-utils/Makefile b/audio/alsa-utils/Makefile
new file mode 100644
index 000000000000..ba1dcd5cc3f4
--- /dev/null
+++ b/audio/alsa-utils/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: alsa-utils
+# Date created: June 29, 2009
+# Whom: Aragon Gouveia <aragon@phat.za.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= alsa-utils
+PORTVERSION= 1.0.23
+CATEGORIES= audio
+MASTER_SITES= ftp://ftp.silug.org/pub/alsa/utils/ \
+ ftp://gd.tuwien.ac.at/opsys/linux/alsa/utils/ \
+ http://dl.ambiweb.de/mirrors/ftp.alsa-project.org/utils/ \
+ ftp://ftp.alsa-project.org/pub/utils/
+
+MAINTAINER= aragon@phat.za.net
+COMMENT= ALSA compatibility utils
+
+LIB_DEPENDS= asound.2:${PORTSDIR}/audio/alsa-lib
+BUILD_DEPENDS= xmlto:${PORTSDIR}/textproc/xmlto
+RUN_DEPENDS= ${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:${PORTSDIR}/audio/alsa-plugins
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS+= --disable-nls
+
+MANLANG= "" fr
+MAN1_EN= aconnect.1 alsactl.1 alsamixer.1 amidi.1 amixer.1 aplay.1 aplaymidi.1 \
+ arecordmidi.1 aseqdump.1 aseqnet.1 iecset.1 speaker-test.1
+MAN7_EN= alsactl_init.7
+MAN8_EN= alsaconf.8
+MAN8_FR= alsaconf.8
+MLINKS_EN= aplay.1 arecord.1
+
+post-patch: .SILENT
+ ${REINPLACE_CMD} '/LIBS/s/-ldl//g' ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/audio/alsa-utils/distinfo b/audio/alsa-utils/distinfo
new file mode 100644
index 000000000000..07feca049600
--- /dev/null
+++ b/audio/alsa-utils/distinfo
@@ -0,0 +1,3 @@
+MD5 (alsa-utils-1.0.23.tar.bz2) = cb0cf46029ac9549cf3a31bff6a4f4e1
+SHA256 (alsa-utils-1.0.23.tar.bz2) = b7d05e915e25f8540ad151c6dd558cf0fc1e9bb0ee23052d531c983666a1f7b0
+SIZE (alsa-utils-1.0.23.tar.bz2) = 1076937
diff --git a/audio/alsa-utils/files/patch-alsa-utils b/audio/alsa-utils/files/patch-alsa-utils
new file mode 100644
index 000000000000..efd3ecdbed64
--- /dev/null
+++ b/audio/alsa-utils/files/patch-alsa-utils
@@ -0,0 +1,77 @@
+--- aplay/aplay.c.orig 2010-04-16 13:11:06.000000000 +0200
++++ aplay/aplay.c 2010-04-23 04:17:13.000000000 +0200
+@@ -28,7 +28,9 @@
+
+ #define _GNU_SOURCE
+ #include <stdio.h>
++#ifndef __FreeBSD__
+ #include <malloc.h>
++#endif
+ #include <unistd.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -45,7 +47,11 @@
+ #include <sys/uio.h>
+ #include <sys/time.h>
+ #include <sys/signal.h>
++#ifndef __FreeBSD__
+ #include <asm/byteorder.h>
++#else
++#include <sys/stat.h>
++#endif
+ #include "aconfig.h"
+ #include "gettext.h"
+ #include "formats.h"
+@@ -116,6 +122,11 @@
+ static int use_strftime = 0;
+ volatile static int recycle_capture_file = 0;
+
++typedef off_t off64_t;
++
++#define lseek64 lseek
++#define open64 open
++
+ static int fd = -1;
+ static off64_t pbrec_count = LLONG_MAX, fdcount;
+ static int vocmajor, vocminor;
+@@ -1086,8 +1097,8 @@
+ err = snd_pcm_hw_params_get_buffer_time_max(params,
+ &buffer_time, 0);
+ assert(err >= 0);
+- if (buffer_time > 500000)
+- buffer_time = 500000;
++ /* if (buffer_time > 500000) XXX WHO CARES?!?!?
++ buffer_time = 500000; */
+ }
+ if (period_time == 0 && period_frames == 0) {
+ if (buffer_time > 0)
+--- aplay/formats.h.orig 2009-08-31 23:13:36.000000000 +0800
++++ aplay/formats.h 2009-09-15 01:22:05.000000000 +0800
+@@ -1,8 +1,15 @@
+ #ifndef FORMATS_H
+ #define FORMATS_H 1
+
++#ifdef __FreeBSD__
++#include <sys/endian.h>
++#define bswap_16(x) bswap16(x)
++#define bswap_32(x) bswap32(x)
++#define bswap_64(x) bswap64(x)
++#else
+ #include <endian.h>
+ #include <byteswap.h>
++#endif
+
+ /* Definitions for .VOC files */
+
+--- speaker-test/speaker-test.c.orig 2009-08-31 23:13:36.000000000 +0800
++++ speaker-test/speaker-test.c 2009-09-15 01:22:48.000000000 +0800
+@@ -44,7 +44,9 @@
+ #include <getopt.h>
+ #include <inttypes.h>
+ #include <ctype.h>
++#ifndef __FreeBSD__
+ #include <byteswap.h>
++#endif
+
+ #define ALSA_PCM_NEW_HW_PARAMS_API
+ #define ALSA_PCM_NEW_SW_PARAMS_API
diff --git a/audio/alsa-utils/pkg-descr b/audio/alsa-utils/pkg-descr
new file mode 100644
index 000000000000..ce5df1992aa8
--- /dev/null
+++ b/audio/alsa-utils/pkg-descr
@@ -0,0 +1,3 @@
+The Advanced Linux Sound Architecture (ALSA) utils
+
+WWW: http://www.alsa-project.org/
diff --git a/audio/alsa-utils/pkg-plist b/audio/alsa-utils/pkg-plist
new file mode 100644
index 000000000000..e53df4951e15
--- /dev/null
+++ b/audio/alsa-utils/pkg-plist
@@ -0,0 +1,35 @@
+bin/aconnect
+bin/alsamixer
+bin/amidi
+bin/amixer
+bin/aplay
+bin/aplaymidi
+bin/arecord
+bin/arecordmidi
+bin/aseqdump
+bin/aseqnet
+bin/iecset
+bin/speaker-test
+sbin/alsaconf
+sbin/alsactl
+share/alsa/init/00main
+share/alsa/init/default
+share/alsa/init/hda
+share/alsa/init/help
+share/alsa/init/info
+share/alsa/init/test
+share/alsa/speaker-test/sample_map.csv
+share/sounds/alsa/Front_Center.wav
+share/sounds/alsa/Front_Left.wav
+share/sounds/alsa/Front_Right.wav
+share/sounds/alsa/Noise.wav
+share/sounds/alsa/Rear_Center.wav
+share/sounds/alsa/Rear_Left.wav
+share/sounds/alsa/Rear_Right.wav
+share/sounds/alsa/Side_Left.wav
+share/sounds/alsa/Side_Right.wav
+@dirrm share/sounds/alsa
+@dirrm share/sounds
+@dirrm share/alsa/speaker-test
+@dirrm share/alsa/init
+@dirrm share/alsa