aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:35:46 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:35:46 +0000
commitd49657a458a6976d5044b1762c8930dec7a5f89d (patch)
tree9b58aad0081b032149ea568cfbdc6d65dd520d24 /audio
parent1aeeb546281d409424ccb6ad1640a22ac0ed1371 (diff)
downloadports-d49657a458a6976d5044b1762c8930dec7a5f89d.tar.gz
ports-d49657a458a6976d5044b1762c8930dec7a5f89d.zip
- New port: audio/fpc-sndfile
Free Pascal Interface to sndfile library PR: 146001 Submitted by: Christopher Key <cjk32 __ at __ cam.ac.uk>
Notes
Notes: svn path=/head/; revision=259384
Diffstat (limited to 'audio')
-rw-r--r--audio/Makefile1
-rw-r--r--audio/fpc-sndfile/Makefile23
-rw-r--r--audio/fpc-sndfile/pkg-plist9
3 files changed, 33 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 93aa2c17e200..98568af00e18 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -201,6 +201,7 @@
SUBDIR += fpc-modplug
SUBDIR += fpc-oggvorbis
SUBDIR += fpc-openal
+ SUBDIR += fpc-sndfile
SUBDIR += freealut
SUBDIR += freedesktop-sound-theme
SUBDIR += freepats
diff --git a/audio/fpc-sndfile/Makefile b/audio/fpc-sndfile/Makefile
new file mode 100644
index 000000000000..d7b6d29f6f66
--- /dev/null
+++ b/audio/fpc-sndfile/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-sndfile
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= audio lang
+PKGNAMESUFFIX= -sndfile
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal Interface to sndfile library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= LIBSNDFILE "Install sndfile library" on
+
+.include "${MASTERDIR}/Makefile"
diff --git a/audio/fpc-sndfile/pkg-plist b/audio/fpc-sndfile/pkg-plist
new file mode 100644
index 000000000000..32a68481c3c6
--- /dev/null
+++ b/audio/fpc-sndfile/pkg-plist
@@ -0,0 +1,9 @@
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sndfile/Package.fpc
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sndfile/sndfile.o
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sndfile/sndfile.ppu
+lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sndfile/libpsndfile.a
+@dirrm lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%/sndfile
+@dirrmtry lib/fpc/%%PORTVERSION%%/units/%%BUILDNAME%%
+@dirrmtry lib/fpc/%%PORTVERSION%%/units
+@dirrmtry lib/fpc/%%PORTVERSION%%
+@dirrmtry lib/fpc