aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2012-03-07 20:02:48 +0000
committerLars Thegler <lth@FreeBSD.org>2012-03-07 20:02:48 +0000
commit612bf9145238d7fb1ff5222a6f850201b619058c (patch)
tree6c0d0306b28d6312186414dc6f42c145e52cb2c2 /audio
parente35e673a7d3335f1134c6a2cdaefee3e6078560a (diff)
downloadports-612bf9145238d7fb1ff5222a6f850201b619058c.tar.gz
ports-612bf9145238d7fb1ff5222a6f850201b619058c.zip
- update to 1.27
- add _DEPENDS - add regression-test target
Notes
Notes: svn path=/head/; revision=292906
Diffstat (limited to 'audio')
-rw-r--r--audio/p5-Net-DAAP-DMAP/Makefile13
-rw-r--r--audio/p5-Net-DAAP-DMAP/distinfo4
-rw-r--r--audio/p5-Net-DAAP-DMAP/files/patch-lib::Net::DAAP::DMAP.pm11
3 files changed, 12 insertions, 16 deletions
diff --git a/audio/p5-Net-DAAP-DMAP/Makefile b/audio/p5-Net-DAAP-DMAP/Makefile
index 0c22240639aa..67a77b2e51ff 100644
--- a/audio/p5-Net-DAAP-DMAP/Makefile
+++ b/audio/p5-Net-DAAP-DMAP/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= Net-DAAP-DMAP
-PORTVERSION= 1.26
-PORTREVISION= 2
+PORTVERSION= 1.27
CATEGORIES= audio perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -15,8 +14,16 @@ PKGNAMEPREFIX= p5-
MAINTAINER= lth@FreeBSD.org
COMMENT= Perl module for reading and writing DAAP structures
-PERL_MODBUILD= yes
+BUILD_DEPENDS= p5-Math-BigInt>0:${PORTSDIR}/math/p5-Math-BigInt
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Data-HexDump>0:${PORTSDIR}/devel/p5-Data-HexDump \
+ p5-Test-Differences>0:${PORTSDIR}/devel/p5-Test-Differences
+
+PERL_CONFIGURE= yes
MAN3= Net::DAAP::DMAP.3
+regression-test: build
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} test
+
.include <bsd.port.mk>
diff --git a/audio/p5-Net-DAAP-DMAP/distinfo b/audio/p5-Net-DAAP-DMAP/distinfo
index f0b7fafd9458..37ae0aa979f3 100644
--- a/audio/p5-Net-DAAP-DMAP/distinfo
+++ b/audio/p5-Net-DAAP-DMAP/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Net-DAAP-DMAP-1.26.tar.gz) = 7ad7c73c101b1100cd270e6ade16e9a9d7cd37a2d6448a0737af105304d69b38
-SIZE (Net-DAAP-DMAP-1.26.tar.gz) = 9530
+SHA256 (Net-DAAP-DMAP-1.27.tar.gz) = c7676e7ff00042ea18ff73d02268d169fbf6eb36b6ca08e688df8f8b31bc2fba
+SIZE (Net-DAAP-DMAP-1.27.tar.gz) = 9373
diff --git a/audio/p5-Net-DAAP-DMAP/files/patch-lib::Net::DAAP::DMAP.pm b/audio/p5-Net-DAAP-DMAP/files/patch-lib::Net::DAAP::DMAP.pm
deleted file mode 100644
index 996c73061f20..000000000000
--- a/audio/p5-Net-DAAP-DMAP/files/patch-lib::Net::DAAP::DMAP.pm
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/Net/DAAP/DMAP.pm.orig Sat Aug 21 14:59:26 2004
-+++ lib/Net/DAAP/DMAP.pm Sat Aug 21 15:09:13 2004
-@@ -387,7 +387,7 @@
- my $struct = shift;
- my $out = '';
-
-- my %by_name = map { $_->{NAME} => $_ } values %$Types;
-+ my %by_name = map { $_->{NAME} => $_ } grep { %$_ } values %$Types;
- for my $pair (@$struct) {
- my ($name, $value) = @$pair;
- # dmap_unpack doesn't populate the name when its decoded