aboutsummaryrefslogtreecommitdiff
path: root/audio
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2011-12-04 09:48:40 +0000
committerMartin Wilke <miwi@FreeBSD.org>2011-12-04 09:48:40 +0000
commit7597510633adc2788a6cf48efd61853df5c2a2a5 (patch)
tree5eb9842e1164de62ca357315fa9630e8cb2feb4d /audio
parente8fc773159cebc7f04de51f144917870e8b25fd6 (diff)
downloadports-7597510633adc2788a6cf48efd61853df5c2a2a5.tar.gz
ports-7597510633adc2788a6cf48efd61853df5c2a2a5.zip
- Update to 0.2.0
PR: 163000 Submitted by: Olivier Duchateau <duchateau.olivier@gmail.com> (maintainer) Feature safe: yes
Notes
Notes: svn path=/head/; revision=286838
Diffstat (limited to 'audio')
-rw-r--r--audio/thunar-media-tags-plugin/Makefile12
-rw-r--r--audio/thunar-media-tags-plugin/distinfo4
-rw-r--r--audio/thunar-media-tags-plugin/files/patch-thunar-plugin_Makefile.am10
-rw-r--r--audio/thunar-media-tags-plugin/files/patch-thunar-plugin_audio-tags-page.c95
-rw-r--r--audio/thunar-media-tags-plugin/files/patch-thunar-plugin_tag-renamer.c51
-rw-r--r--audio/thunar-media-tags-plugin/pkg-plist33
6 files changed, 37 insertions, 168 deletions
diff --git a/audio/thunar-media-tags-plugin/Makefile b/audio/thunar-media-tags-plugin/Makefile
index 6cbb49397d41..34bb37c35aa2 100644
--- a/audio/thunar-media-tags-plugin/Makefile
+++ b/audio/thunar-media-tags-plugin/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= thunar-media-tags-plugin
-PORTVERSION= 0.1.2
-PORTREVISION= 20
+PORTVERSION= 0.2.0
CATEGORIES= audio xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR=/src/thunar-plugins//${PORTNAME}/${PORTVERSION:R}
@@ -23,14 +22,7 @@ USE_GMAKE= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GNOME= gnomehack gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libexo thunar thunarvfs
+USE_XFCE= configenv libexo thunar
USE_AUTOTOOLS= libtool
-post-patch:
- @${REINPLACE_CMD} -e 's|exo-0\.3|exo-1|g; \
- s|thunarx-1|thunarx-2|g' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|(libdir)/thunarx-1|(libdir)/thunarx-2|' \
- ${WRKSRC}/thunar-plugin/Makefile.in
-
.include <bsd.port.mk>
diff --git a/audio/thunar-media-tags-plugin/distinfo b/audio/thunar-media-tags-plugin/distinfo
index f75bbc0987f5..f27092c62d83 100644
--- a/audio/thunar-media-tags-plugin/distinfo
+++ b/audio/thunar-media-tags-plugin/distinfo
@@ -1,2 +1,2 @@
-SHA256 (xfce4/thunar-media-tags-plugin-0.1.2.tar.bz2) = 41305171a3f2a0962b1324fa402bc97e3e1e93595dd3168f6fe778f079bb0240
-SIZE (xfce4/thunar-media-tags-plugin-0.1.2.tar.bz2) = 282877
+SHA256 (xfce4/thunar-media-tags-plugin-0.2.0.tar.bz2) = 721b34a8a801ebd039469c8b8605b0bb332d498a6018a1b978df5c87bdb8750f
+SIZE (xfce4/thunar-media-tags-plugin-0.2.0.tar.bz2) = 321001
diff --git a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_Makefile.am b/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_Makefile.am
deleted file mode 100644
index eeaed131fc18..000000000000
--- a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_Makefile.am
+++ /dev/null
@@ -1,10 +0,0 @@
---- thunar-plugin/Makefile.am.orig 2006-06-08 15:04:45.000000000 +0200
-+++ thunar-plugin/Makefile.am 2011-05-15 19:53:34.000000000 +0200
-@@ -33,6 +33,7 @@
- -avoid-version \
- -export-dynamic \
- -module \
-+ $(EXO_LIBS) \
- $(THUNARX_LIBS) \
- $(THUNARVFS_LIBS) \
- $(TAGLIB_LIBS) \
diff --git a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_audio-tags-page.c b/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_audio-tags-page.c
deleted file mode 100644
index 6ae3a68e14ca..000000000000
--- a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_audio-tags-page.c
+++ /dev/null
@@ -1,95 +0,0 @@
---- thunar-plugin/audio-tags-page.c.orig 2006-09-11 11:40:56.000000000 +0200
-+++ thunar-plugin/audio-tags-page.c 2011-05-15 19:44:12.000000000 +0200
-@@ -90,7 +90,6 @@
- ThunarxPropertyPage __parent__;
-
- /* Widgets */
-- GtkTooltips *tooltips;
- GtkWidget *table;
- GtkWidget *save_button;
- GtkWidget *info_button;
-@@ -282,10 +281,6 @@
-
- gtk_container_set_border_width (GTK_CONTAINER (page), 8);
-
-- /* Allocate the shared tooltips */
-- page->tooltips = gtk_tooltips_new ();
-- exo_gtk_object_ref_sink (GTK_OBJECT (page->tooltips));
--
- /* Main container */
- vbox = gtk_vbox_new (FALSE, 8);
- gtk_container_add (GTK_CONTAINER (page), vbox);
-@@ -317,7 +312,8 @@
- /* Track spin button */
- spin = gtk_spin_button_new (GTK_ADJUSTMENT (adjustment), 1, 0);
- exo_mutual_binding_new (G_OBJECT (adjustment), "value", G_OBJECT (page), "track");
-- gtk_tooltips_set_tip (page->tooltips, spin, _("Enter the track number here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (spin), _("Enter the track number here."));
-+
- gtk_container_add (GTK_CONTAINER (alignment), spin);
- gtk_label_set_mnemonic_widget (GTK_LABEL (label), spin);
- gtk_widget_show (spin);
-@@ -340,7 +336,7 @@
- /* Year spin button */
- spin = gtk_spin_button_new (GTK_ADJUSTMENT (adjustment), 1, 0);
- exo_mutual_binding_new (G_OBJECT (adjustment), "value", G_OBJECT (page), "year");
-- gtk_tooltips_set_tip (page->tooltips, spin, _("Enter the release year here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (spin), _("Enter the release year here."));
- gtk_container_add (GTK_CONTAINER (alignment), spin);
- gtk_label_set_mnemonic_widget (GTK_LABEL (label), spin);
- gtk_widget_show (spin);
-@@ -355,7 +351,7 @@
- /* Artist entry */
- entry = gtk_entry_new ();
- exo_mutual_binding_new (G_OBJECT (entry), "text", G_OBJECT (page), "artist");
-- gtk_tooltips_set_tip (page->tooltips, entry, _("Enter the name of the artist or author of this file here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (entry), _("Enter the name of the artist or author of this file here."));
- gtk_table_attach (GTK_TABLE (page->table), entry, 1, 4, 1, 2, GTK_EXPAND | GTK_FILL, 0, 0, 0);
- gtk_label_set_mnemonic_widget (GTK_LABEL (label), entry);
- gtk_widget_show (entry);
-@@ -370,7 +366,7 @@
- /* Title entry */
- entry = gtk_entry_new ();
- exo_mutual_binding_new (G_OBJECT (entry), "text", G_OBJECT (page), "title");
-- gtk_tooltips_set_tip (page->tooltips, entry, _("Enter the song title here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (entry), _("Enter the song title here."));
- gtk_table_attach (GTK_TABLE (page->table), entry, 1, 4, 2, 3, GTK_EXPAND | GTK_FILL, 0, 0, 0);
- gtk_widget_show (entry);
-
-@@ -384,7 +380,7 @@
- /* Album entry */
- entry = gtk_entry_new ();
- exo_mutual_binding_new (G_OBJECT (entry), "text", G_OBJECT (page), "album");
-- gtk_tooltips_set_tip (page->tooltips, entry, _("Enter the album/record title here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (entry), _("Enter the album/record title here."));
- gtk_table_attach (GTK_TABLE (page->table), entry, 1, 4, 3, 4, GTK_EXPAND | GTK_FILL, 0, 0, 0);
- gtk_widget_show (entry);
-
-@@ -398,7 +394,7 @@
- /* Comment entry */
- entry = gtk_entry_new ();
- exo_mutual_binding_new (G_OBJECT (entry), "text", G_OBJECT (page), "comment");
-- gtk_tooltips_set_tip (page->tooltips, entry, _("Enter your comments here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (entry), _("Enter your comments here."));
- gtk_table_attach (GTK_TABLE (page->table), entry, 1, 4, 4, 5, GTK_EXPAND | GTK_FILL, 0, 0, 0);
- gtk_widget_show (entry);
-
-@@ -412,7 +408,7 @@
- /* Genre combo box */
- combo = gtk_combo_box_entry_new_text ();
- exo_mutual_binding_new (G_OBJECT (GTK_BIN (combo)->child), "text", G_OBJECT (page), "genre");
-- gtk_tooltips_set_tip (page->tooltips, combo, _("Select or enter the genre of this song here."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (combo), _("Select or enter the genre of this song here."));
- gtk_table_attach (GTK_TABLE (page->table), combo, 1, 4, 5, 6, GTK_FILL, 0, 0, 0);
- gtk_widget_show (combo);
-
-@@ -512,9 +508,6 @@
- if (G_LIKELY (page->genre != NULL))
- g_free (page->genre);
-
-- /* Release the tooltips */
-- g_object_unref (G_OBJECT (page->tooltips));
--
- (*G_OBJECT_CLASS (audio_tags_page_parent_class)->finalize) (object);
- }
-
diff --git a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_tag-renamer.c b/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_tag-renamer.c
deleted file mode 100644
index 6b9a227ccb8e..000000000000
--- a/audio/thunar-media-tags-plugin/files/patch-thunar-plugin_tag-renamer.c
+++ /dev/null
@@ -1,51 +0,0 @@
---- thunar-plugin/tag-renamer.c.orig 2006-06-17 21:10:05.000000000 +0200
-+++ thunar-plugin/tag-renamer.c 2011-05-15 19:51:13.000000000 +0200
-@@ -116,9 +116,6 @@
- {
- ThunarxRenamer __parent__;
-
-- /* Widgets */
-- GtkTooltips *tooltips;
--
- /* Properties */
- TagRenamerFormat format;
- gboolean replace_spaces;
-@@ -209,10 +206,6 @@
- GEnumClass *klass;
- gint n;
-
-- /* Allocate shared tooltips */
-- tag_renamer->tooltips = gtk_tooltips_new ();
-- exo_gtk_object_ref_sink (GTK_OBJECT (tag_renamer->tooltips));
--
- table = gtk_table_new (2, 3, FALSE);
- gtk_table_set_row_spacings (GTK_TABLE (table), 6);
- gtk_table_set_col_spacings (GTK_TABLE (table), 12);
-@@ -245,14 +238,14 @@
-
- button = gtk_check_button_new_with_mnemonic (_("_Underscores"));
- exo_mutual_binding_new (G_OBJECT (button), "active", G_OBJECT (tag_renamer), "replace-spaces");
-- gtk_tooltips_set_tip (tag_renamer->tooltips, button, _("Activating this option will replace all spaces in the target filename "
-- "with underscores."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (button), _("Activating this option will replace all spaces in the target filename "
-+ "with underscores."));
- gtk_table_attach (GTK_TABLE (table), button, 2, 3, 0, 1, GTK_FILL, 0, 0, 0);
- gtk_widget_show (button);
-
- button = gtk_check_button_new_with_mnemonic (_("_Lowercase"));
- exo_mutual_binding_new (G_OBJECT (button), "active", G_OBJECT (tag_renamer), "lowercase");
-- gtk_tooltips_set_tip (tag_renamer->tooltips, button, _("If you activate this, the resulting filename will only contain lowercase letters."), NULL);
-+ gtk_widget_set_tooltip_text (GTK_WIDGET (button), _("If you activate this, the resulting filename will only contain lowercase letters."));
- gtk_table_attach (GTK_TABLE (table), button, 2, 3, 1, 2, GTK_FILL, 0, 0, 0);
- gtk_widget_show (button);
-
-@@ -272,9 +265,6 @@
- {
- TagRenamer *tag_renamer = TAG_RENAMER (object);
-
-- /* release the tooltips */
-- g_object_unref (G_OBJECT (tag_renamer->tooltips));
--
- /* Free strings */
- g_free (tag_renamer->artist);
- g_free (tag_renamer->title);
diff --git a/audio/thunar-media-tags-plugin/pkg-plist b/audio/thunar-media-tags-plugin/pkg-plist
index 1360de5876cf..c5b5288c6c78 100644
--- a/audio/thunar-media-tags-plugin/pkg-plist
+++ b/audio/thunar-media-tags-plugin/pkg-plist
@@ -1,18 +1,51 @@
lib/thunarx-2/thunar-media-tags-plugin.a
lib/thunarx-2/thunar-media-tags-plugin.la
lib/thunarx-2/thunar-media-tags-plugin.so
+share/locale/ar/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/ast/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/ca/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/cs/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/da/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/de/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/el/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/en_GB/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/es/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/eu/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/fi/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/fr/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/gl/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/hr/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/hu/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/id/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/it/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/ja/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/kk/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/lv/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/nb/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/nl/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/pa/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/pl/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/pt/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/pt_BR/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/ru/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/sk/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/sq/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/sv/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/tr/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/ug/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/uk/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/ur/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/ur_PK/LC_MESSAGES/thunar-media-tags-plugin.mo
+share/locale/zh_CN/LC_MESSAGES/thunar-media-tags-plugin.mo
share/locale/zh_TW/LC_MESSAGES/thunar-media-tags-plugin.mo
+@dirrmtry share/locale/ur_PK/LC_MESSAGES
+@dirrmtry share/locale/ur_PK
+@dirrmtry share/locale/ur/LC_MESSAGES
+@dirrmtry share/locale/ur
+@dirrmtry share/locale/ug/LC_MESSAGES
+@dirrmtry share/locale/ug
+@dirrmtry share/locale/kk/LC_MESSAGES
+@dirrmtry share/locale/kk
+@dirrmtry share/locale/ast/LC_MESSAGES
+@dirrmtry share/locale/ast
@dirrmtry lib/thunarx-2