aboutsummaryrefslogtreecommitdiff
path: root/benchmarks/xengine
diff options
context:
space:
mode:
authorAndreas Klemm <andreas@FreeBSD.org>1997-02-16 13:30:45 +0000
committerAndreas Klemm <andreas@FreeBSD.org>1997-02-16 13:30:45 +0000
commit5474e1b9dd92681079a50f5fcf19860b16d1d66c (patch)
treef5b61c2c81fbf27d31d4613888163e7241ef12f1 /benchmarks/xengine
parent2b004da19e7bc0ac59f48678b0864a3b24db1128 (diff)
downloadports-5474e1b9dd92681079a50f5fcf19860b16d1d66c.tar.gz
ports-5474e1b9dd92681079a50f5fcf19860b16d1d66c.zip
new xengine port. Closes PR 2249.
It displays a part of a motor. The faster your X server is, the more rpm you get ;-) Guess how many rpm's I got, when I started with X11 years ago .... 32 rpm with an ET4000 VGA card on a 386 4MB running Interactive Unix ;-))
Notes
Notes: svn path=/head/; revision=5647
Diffstat (limited to 'benchmarks/xengine')
-rw-r--r--benchmarks/xengine/Makefile34
-rw-r--r--benchmarks/xengine/distinfo2
-rw-r--r--benchmarks/xengine/files/patch-aa26
-rw-r--r--benchmarks/xengine/pkg-comment1
-rw-r--r--benchmarks/xengine/pkg-descr7
-rw-r--r--benchmarks/xengine/pkg-plist3
6 files changed, 73 insertions, 0 deletions
diff --git a/benchmarks/xengine/Makefile b/benchmarks/xengine/Makefile
new file mode 100644
index 000000000000..3bc0162133e6
--- /dev/null
+++ b/benchmarks/xengine/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: xengine
+# Version required: pl1
+# Date created: 17 January 1997
+# Whom: FURUSAWA,Kazuhisa <furusawa@com.cs.osakafu-u.ac.jp>
+
+DISTNAME= xengine-pl1
+PKGNAME= xengine
+CATEGORIES= benchmarks x11
+MASTER_SITES= ftp://ftp.lab.kdd.co.jp/Usenet/comp.sources.x/volume09/xengine/
+DISTFILES= part01.z patch1.z
+
+MAINTAINER= furusawa@com.cs.osakafu-u.ac.jp
+
+BUILD_DEPENDS= gunshar:${PORTSDIR}/archivers/gshar+gunshar
+
+DIST_SUBDIR= xengine
+WRKSRC= $(WRKDIR)
+USE_IMAKE= yes
+
+EXTRACT_CMD= zcat
+EXTRACT_SUFX= .z
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= | gunshar -d $(WRKDIR)
+
+pre-patch:
+ @cd $(WRKSRC) ; patch < xengine.patch1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @mkdir -p $(PREFIX)/share/doc/xengine
+ @install -c $(WRKSRC)/README $(PREFIX)/share/doc/xengine
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/xengine/distinfo b/benchmarks/xengine/distinfo
new file mode 100644
index 000000000000..3e30bf7b45cf
--- /dev/null
+++ b/benchmarks/xengine/distinfo
@@ -0,0 +1,2 @@
+MD5 (xengine/part01.z) = 9ea60511319318b905e6da2604ef35e9
+MD5 (xengine/patch1.z) = 1dc52c711280c0f2567fdf43264e728c
diff --git a/benchmarks/xengine/files/patch-aa b/benchmarks/xengine/files/patch-aa
new file mode 100644
index 000000000000..78fbbdfb03d8
--- /dev/null
+++ b/benchmarks/xengine/files/patch-aa
@@ -0,0 +1,26 @@
+*** xengine.c~ Wed Oct 3 10:58:17 1990
+--- xengine.c Sun Dec 8 22:17:43 1996
+***************
+*** 180,191 ****
+
+ Arg args[10];
+
+! XtSetArg(args[0], XtNwidth, 0);
+! XtSetArg(args[1], XtNheight, 0);
+ XtGetValues(w, args, 2);
+-
+- width = args[0].value;
+- height = args[1].value;
+
+ XFreePixmap(XtDisplay(engine), enginePixmap);
+ enginePixmap = XCreatePixmap(XtDisplay(engine), XtWindow(engine), width, height, DefaultDepthOfScreen(XtScreen(engine)));
+--- 180,188 ----
+
+ Arg args[10];
+
+! XtSetArg(args[0], XtNwidth, &width);
+! XtSetArg(args[1], XtNheight, &height);
+ XtGetValues(w, args, 2);
+
+ XFreePixmap(XtDisplay(engine), enginePixmap);
+ enginePixmap = XCreatePixmap(XtDisplay(engine), XtWindow(engine), width, height, DefaultDepthOfScreen(XtScreen(engine)));
diff --git a/benchmarks/xengine/pkg-comment b/benchmarks/xengine/pkg-comment
new file mode 100644
index 000000000000..4f4773cb58d4
--- /dev/null
+++ b/benchmarks/xengine/pkg-comment
@@ -0,0 +1 @@
+reciprocating engine for X
diff --git a/benchmarks/xengine/pkg-descr b/benchmarks/xengine/pkg-descr
new file mode 100644
index 000000000000..28f98b3739fb
--- /dev/null
+++ b/benchmarks/xengine/pkg-descr
@@ -0,0 +1,7 @@
+`xengine' is a reciprocating engine for X. This program used as
+benchmark for X.
+
+See README and man page for details.
+
+Orignal xengine written by shutoh@cbx.emi.yamaha.co.jp.
+This port is done by furusawa@com.cs.osakafu-u.ac.jp.
diff --git a/benchmarks/xengine/pkg-plist b/benchmarks/xengine/pkg-plist
new file mode 100644
index 000000000000..52987d36a980
--- /dev/null
+++ b/benchmarks/xengine/pkg-plist
@@ -0,0 +1,3 @@
+bin/xengine
+share/doc/xengine/README
+man/man1/xengine.1.gz