aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2014-05-26 08:47:51 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2014-05-26 08:47:51 +0000
commit62abe08f9d8e3060d7a6954bfd1494445b0a33f7 (patch)
treeac1879ebb5d6ee56413bac9ff4d397beb2c9df04 /benchmarks
parent1e279835ef6ba3461c85f942997cf0423932931d (diff)
downloadports-62abe08f9d8e3060d7a6954bfd1494445b0a33f7.tar.gz
ports-62abe08f9d8e3060d7a6954bfd1494445b0a33f7.zip
- Fix parallel builds (-jX) and remove MAKE_JOBS_UNSAFE
- Utilize PLIST_FILES and PORTDOCS instead of pkg-plist - Reword port description a bit; fix Makefile header
Notes
Notes: svn path=/head/; revision=355289
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/nbench/Makefile12
-rw-r--r--benchmarks/nbench/files/patch-ad11
-rw-r--r--benchmarks/nbench/pkg-descr6
-rw-r--r--benchmarks/nbench/pkg-plist8
4 files changed, 20 insertions, 17 deletions
diff --git a/benchmarks/nbench/Makefile b/benchmarks/nbench/Makefile
index 53536964fd86..d6a6d1b7f0d2 100644
--- a/benchmarks/nbench/Makefile
+++ b/benchmarks/nbench/Makefile
@@ -1,4 +1,4 @@
-# Created by: Andrey Zakhvatov
+# Created by: Andrey Zakhvatov <andy@FreeBSD.org>
# $FreeBSD$
PORTNAME= nbench
@@ -11,15 +11,17 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= BYTE Magazine's native benchmarks
ALL_TARGET= # empty
-MAKE_JOBS_UNSAFE= yes
+
+PLIST_FILES= bin/nbench share/nbench/NNET.DAT
+PORTDOCS= README README.submit RESULTS bdoc.txt
+
+OPTIONS_DEFINE= DOCS
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/nbench ${STAGEDIR}${PREFIX}/bin
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${WRKSRC}/NNET.DAT ${STAGEDIR}${DATADIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for f in README README.submit RESULTS bdoc.txt
- ${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/benchmarks/nbench/files/patch-ad b/benchmarks/nbench/files/patch-ad
index e8f921ed49de..3617df942f52 100644
--- a/benchmarks/nbench/files/patch-ad
+++ b/benchmarks/nbench/files/patch-ad
@@ -1,6 +1,6 @@
--- Makefile.orig Mon Oct 18 00:07:05 2004
+++ Makefile Mon Oct 18 00:07:51 2004
-@@ -19,10 +19,10 @@
+@@ -19,10 +19,10 @@ default: nbench
# You should leave -static in the CFLAGS so that your sysinfo can be
# compiled into the executable.
@@ -13,3 +13,12 @@
# if your gcc lets you do it, then try this one
#CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
+@@ -126,7 +126,7 @@ pointer.h: pointer Makefile
+ if [ "4" = `./pointer` ] ; then touch pointer.h ;\
+ else echo "#define LONG64" >pointer.h ; fi
+
+-misc.o: misc.h misc.c Makefile
++misc.o: misc.h misc.c nmglobal.h pointer.h Makefile
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+ -c misc.c
+
diff --git a/benchmarks/nbench/pkg-descr b/benchmarks/nbench/pkg-descr
index f02ca03bc82b..186eae85b6d9 100644
--- a/benchmarks/nbench/pkg-descr
+++ b/benchmarks/nbench/pkg-descr
@@ -1,5 +1,5 @@
-BYTE Magazine's native benchmarks (also called BYTEmark), which are
-designed to expose the capabilities of a system's CPU, FPU, and memory
-system.
+This is a Linux/Unix port of release 2 of BYTE Magazine's BYTEmark benchmark
+program (previously known as BYTE's Native Mode Benchmarks). It is designed
+to expose the capabilities of a system's CPU, FPU, and memory system.
WWW: http://www.tux.org/~mayer/linux/bmark.html
diff --git a/benchmarks/nbench/pkg-plist b/benchmarks/nbench/pkg-plist
deleted file mode 100644
index f3c070195b60..000000000000
--- a/benchmarks/nbench/pkg-plist
+++ /dev/null
@@ -1,8 +0,0 @@
-bin/nbench
-share/nbench/NNET.DAT
-%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%%%DOCSDIR%%/README.submit
-%%PORTDOCS%%%%DOCSDIR%%/RESULTS
-%%PORTDOCS%%%%DOCSDIR%%/bdoc.txt
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm share/nbench