aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-16 11:29:56 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2014-02-16 11:29:56 +0000
commitf51d12e24c8025179daabb62943aeceb57dae3a0 (patch)
tree96ee8978c561f4b28871eace8a71d3bf6286f261 /benchmarks
parent9b0fa1eda08ba5e2c4ba960e5b6c1c41429ff193 (diff)
downloadports-f51d12e24c8025179daabb62943aeceb57dae3a0.tar.gz
ports-f51d12e24c8025179daabb62943aeceb57dae3a0.zip
- Support staging
- Add LICENSE
Notes
Notes: svn path=/head/; revision=344534
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/spp/Makefile8
-rw-r--r--benchmarks/spp/files/patch-Makefile40
2 files changed, 42 insertions, 6 deletions
diff --git a/benchmarks/spp/Makefile b/benchmarks/spp/Makefile
index 765f9f8946f9..a67e29fd2a1b 100644
--- a/benchmarks/spp/Makefile
+++ b/benchmarks/spp/Makefile
@@ -9,12 +9,8 @@ MASTER_SITES= http://caia.swin.edu.au/tools/spp/downloads/
MAINTAINER= lars@eggert.org
COMMENT= Calculates round trip time from pcap files or live capture
-PLIST_FILES= bin/spp
-MAN1= spp.1
+LICENSE= GPLv2
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -E '/(-DDEBUG|-g)/s|^|#|g' \
- ${WRKSRC}/Makefile
+PLIST_FILES= bin/spp man/man1/spp.1.gz
.include <bsd.port.mk>
diff --git a/benchmarks/spp/files/patch-Makefile b/benchmarks/spp/files/patch-Makefile
new file mode 100644
index 000000000000..e0b354d4ed7a
--- /dev/null
+++ b/benchmarks/spp/files/patch-Makefile
@@ -0,0 +1,40 @@
+--- ./Makefile.orig 2013-05-22 03:50:24.000000000 +0200
++++ ./Makefile 2014-02-16 12:29:01.767731648 +0100
+@@ -39,8 +39,8 @@
+ SLIBS= -pthread -lpcap
+ BINDIR=./bin
+ PROGRAM= $(BINDIR)/$(NAME)
+-CFLAGS += -I/usr/local/include
+-LDFLAGS += -L/usr/local/lib
++CFLAGS += -I$(LOCALBASE)/include
++LDFLAGS += -L$(LOCALBASE)/lib
+ INSTALL= install
+
+
+@@ -48,11 +48,11 @@
+ # If, for some reason, you don't want debugging info to bewww
+ # logged, then comment the following line.
+ #
+-CFLAGS+= -DDEBUG
++#CFLAGS+= -DDEBUG
+
+ # If you want the program with support for debuggers
+ # (gdb, etc), then uncomment the following line
+-CFLAGS+= -g
++#CFLAGS+= -g
+
+ # turn on optimisation
+ CFLAGS += -O2
+@@ -80,9 +80,10 @@
+ echo "You must be root to install" && exit 1 ; \
+ fi ;
+ @echo "Installing spp binary"
+- $(INSTALL) -c -m 755 $(PROGRAM) /usr/local/bin/
++ @strip $(PROGRAM)
++ $(INSTALL) -c -m 755 $(PROGRAM) $(DESTDIR)$(PREFIX)/bin/
+ @echo "Installing manual page"
+- $(INSTALL) -c -m 644 doc/spp.1 /usr/local/man/man1/
++ $(INSTALL) -c -m 644 doc/spp.1 $(DESTDIR)$(PREFIX)/man/man1/
+
+ # target 'distro'
+ #