aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-14 12:25:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-14 12:25:44 +0000
commitd04ad0c0230484b40f05d649d3085bc8a36261c0 (patch)
treed339e4e87945c8f81914845b56a2b296a91a9be8 /benchmarks
parentec1a9016a726866967f26d6ac7d31a7d37553bc6 (diff)
downloadports-d04ad0c0230484b40f05d649d3085bc8a36261c0.tar.gz
ports-d04ad0c0230484b40f05d649d3085bc8a36261c0.zip
- Update to 3.0.6
- Remove RESTRICTED [1] - Pass maintainership to submitter [1] Project has changed the license to apache2, please see changelog http://www.web-polygraph.org/downloads/changelog.html Submitted by: Aron Schlesinger (as@bsdgroup.de) via irc
Notes
Notes: svn path=/head/; revision=199486
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/polygraph/Makefile26
-rw-r--r--benchmarks/polygraph/distinfo6
-rw-r--r--benchmarks/polygraph/files/patch-tools-ReportGen-Makefile.in22
-rw-r--r--benchmarks/polygraph/files/patch-workloads-Makefile.in95
-rw-r--r--benchmarks/polygraph/files/patch-workloads-include-Makefile.in55
-rw-r--r--benchmarks/polygraph/pkg-plist19
-rw-r--r--benchmarks/polygraph31/Makefile26
-rw-r--r--benchmarks/polygraph31/distinfo6
-rw-r--r--benchmarks/polygraph31/files/patch-tools-ReportGen-Makefile.in22
-rw-r--r--benchmarks/polygraph31/files/patch-workloads-Makefile.in95
-rw-r--r--benchmarks/polygraph31/files/patch-workloads-include-Makefile.in55
-rw-r--r--benchmarks/polygraph31/pkg-plist19
12 files changed, 96 insertions, 350 deletions
diff --git a/benchmarks/polygraph/Makefile b/benchmarks/polygraph/Makefile
index afabffb55a20..d0f8dd6f4291 100644
--- a/benchmarks/polygraph/Makefile
+++ b/benchmarks/polygraph/Makefile
@@ -6,22 +6,34 @@
#
PORTNAME= polygraph
-PORTVERSION= 2.8.1
+PORTVERSION= 3.0.6
CATEGORIES= benchmarks www
-MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
+MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/ \
+ http://people.bsdgroup.de/~as/freebsd/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= as@bsdgroup.org
COMMENT= A benchmarking tool for Web proxies
-RESTRICTED= Redistribution forbidden by license
-IS_INTERACTIVE= yes
-
GNU_CONFIGURE= YES
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+CONFIGURE_ARGS+=--datadir=${DATADIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFLICTS= ltrace-0*
-.include <bsd.port.mk>
+OPTIONS= GNUPLOT "gnuplot if you want full report functionality" ON \
+ PERL "install Perl for polygraph tools" OFF
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNUPLOT)
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+.endif
+
+.if !defined(WITHOUT_PERL)
+USE_PERL5_RUN= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/benchmarks/polygraph/distinfo b/benchmarks/polygraph/distinfo
index 6ba80ea1b8cd..29637c4f979b 100644
--- a/benchmarks/polygraph/distinfo
+++ b/benchmarks/polygraph/distinfo
@@ -1,3 +1,3 @@
-MD5 (polygraph-2.8.1-src.tgz) = f42e70d3fa383f42bf3676c086b2d16c
-SHA256 (polygraph-2.8.1-src.tgz) = 0fbd101421385538e31187186f07476e91e1a66281e1e3c393dd9cbd2049508b
-SIZE (polygraph-2.8.1-src.tgz) = 710841
+MD5 (polygraph-3.0.6-src.tgz) = 36124ba0e8354b6e6c573a25ccf35b72
+SHA256 (polygraph-3.0.6-src.tgz) = 71c19c5c6d5472c9a3d254dc71353d365d7bc04f58b640e5c0c890d7e53043a2
+SIZE (polygraph-3.0.6-src.tgz) = 1064674
diff --git a/benchmarks/polygraph/files/patch-tools-ReportGen-Makefile.in b/benchmarks/polygraph/files/patch-tools-ReportGen-Makefile.in
deleted file mode 100644
index 130457622a3d..000000000000
--- a/benchmarks/polygraph/files/patch-tools-ReportGen-Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- tools/ReportGen/Makefile.in.orig Tue Jun 12 02:04:12 2001
-+++ tools/ReportGen/Makefile.in Sat Aug 3 13:55:53 2002
-@@ -15,7 +15,7 @@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
-
--rgen_dir = @prefix@/ReportGen
-+rgen_dir = @prefix@/share/polygraph/ReportGen
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -42,8 +42,8 @@
- fi
-
- install_mkdirs:
-- @for d in $(prefix) $(rgen_dir); do \
-- if test ! -d $$d; then echo mkdir $$d; mkdir $$d; fi; \
-+ @for d in $(rgen_dir); do \
-+ if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
- clean:
diff --git a/benchmarks/polygraph/files/patch-workloads-Makefile.in b/benchmarks/polygraph/files/patch-workloads-Makefile.in
index 9bc6ff415c93..7730c87b518e 100644
--- a/benchmarks/polygraph/files/patch-workloads-Makefile.in
+++ b/benchmarks/polygraph/files/patch-workloads-Makefile.in
@@ -1,84 +1,11 @@
---- workloads/Makefile.in.orig Sun Jul 29 06:45:59 2001
-+++ workloads/Makefile.in Sat Aug 3 13:56:45 2002
-@@ -45,55 +45,55 @@
- default: all
-
- datacomm-1.pg_install: install_dirs datacomm-1.pg
-- $(INSTALL_DTA) datacomm-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) datacomm-1.pg ${datadir}/polygraph/workloads
-
- downtime-2.pg_install: install_dirs downtime-2.pg
-- $(INSTALL_DTA) downtime-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) downtime-2.pg ${datadir}/polygraph/workloads
-
- nolb-l4-4.pg_install: install_dirs nolb-l4-4.pg
-- $(INSTALL_DTA) nolb-l4-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) nolb-l4-4.pg ${datadir}/polygraph/workloads
-
- polyfill-2.pg_install: install_dirs polyfill-2.pg
-- $(INSTALL_DTA) polyfill-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polyfill-2.pg ${datadir}/polygraph/workloads
-
- polymix-1.pg_install: install_dirs polymix-1.pg
-- $(INSTALL_DTA) polymix-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-1.pg ${datadir}/polygraph/workloads
-
- polymix-2.pg_install: install_dirs polymix-2.pg
-- $(INSTALL_DTA) polymix-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-2.pg ${datadir}/polygraph/workloads
-
- polymix-3.pg_install: install_dirs polymix-3.pg
-- $(INSTALL_DTA) polymix-3.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-3.pg ${datadir}/polygraph/workloads
-
- polymix-4.pg_install: install_dirs polymix-4.pg
-- $(INSTALL_DTA) polymix-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-4.pg ${datadir}/polygraph/workloads
-
- pxylb-4.pg_install: install_dirs pxylb-4.pg
-- $(INSTALL_DTA) pxylb-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) pxylb-4.pg ${datadir}/polygraph/workloads
-
- simple.pg_install: install_dirs simple.pg
-- $(INSTALL_DTA) simple.pg ${prefix}/workloads
-+ $(INSTALL_DTA) simple.pg ${datadir}/polygraph/workloads
-
- srvlb-l4-4.pg_install: install_dirs srvlb-l4-4.pg
-- $(INSTALL_DTA) srvlb-l4-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) srvlb-l4-4.pg ${datadir}/polygraph/workloads
-
- srvlb-l7-4.pg_install: install_dirs srvlb-l7-4.pg
-- $(INSTALL_DTA) srvlb-l7-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) srvlb-l7-4.pg ${datadir}/polygraph/workloads
-
- test_csm.pg_install: install_dirs test_csm.pg
-- $(INSTALL_DTA) test_csm.pg ${prefix}/workloads
-+ $(INSTALL_DTA) test_csm.pg ${datadir}/polygraph/workloads
-
- test_polypxy.pg_install: install_dirs test_polypxy.pg
-- $(INSTALL_DTA) test_polypxy.pg ${prefix}/workloads
-+ $(INSTALL_DTA) test_polypxy.pg ${datadir}/polygraph/workloads
-
- webaxe-1.pg_install: install_dirs webaxe-1.pg
-- $(INSTALL_DTA) webaxe-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-1.pg ${datadir}/polygraph/workloads
-
- webaxe-3.pg_install: install_dirs webaxe-3.pg
-- $(INSTALL_DTA) webaxe-3.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-3.pg ${datadir}/polygraph/workloads
-
- webaxe-4.pg_install: install_dirs webaxe-4.pg
-- $(INSTALL_DTA) webaxe-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-4.pg ${datadir}/polygraph/workloads
-
- all: all_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
-
-@@ -122,7 +122,7 @@
-
- install: install_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
- install_dirs:
-- @for d in ${prefix}/workloads/; do \
-+ @for d in ${datadir}/polygraph/workloads ; do \
- if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
+--- workloads/Makefile.in.orig Thu Sep 13 05:21:49 2007
++++ workloads/Makefile.in Thu Sep 13 05:26:27 2007
+@@ -175,7 +175,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ SUBDIRS = include
+-workloads_pkgdir = ${prefix}/workloads
++workloads_pkgdir = ${datadir}/workloads
+ dist_workloads_pkg_DATA = \
+ datacomm-1.pg \
+ downtime-2.pg \
diff --git a/benchmarks/polygraph/files/patch-workloads-include-Makefile.in b/benchmarks/polygraph/files/patch-workloads-include-Makefile.in
index 3852d88cc9bf..c8b99735e547 100644
--- a/benchmarks/polygraph/files/patch-workloads-include-Makefile.in
+++ b/benchmarks/polygraph/files/patch-workloads-include-Makefile.in
@@ -1,44 +1,11 @@
---- workloads/include/Makefile.in.orig Sat Aug 3 14:23:13 2002
-+++ workloads/include/Makefile.in Sat Aug 3 14:24:50 2002
-@@ -45,25 +45,25 @@
- default: all
-
- benches.pg_install: install_dirs benches.pg
-- $(INSTALL_DTA) benches.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) benches.pg ${datadir}/polygraph/workloads/include
-
- contents.pg_install: install_dirs contents.pg
-- $(INSTALL_DTA) contents.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) contents.pg ${datadir}/polygraph/workloads/include
-
- phases.pg_install: install_dirs phases.pg
-- $(INSTALL_DTA) phases.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) phases.pg ${datadir}/polygraph/workloads/include
-
- pipes.pg_install: install_dirs pipes.pg
-- $(INSTALL_DTA) pipes.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) pipes.pg ${datadir}/polygraph/workloads/include
-
- polymix-3-guts.pg_install: install_dirs polymix-3-guts.pg
-- $(INSTALL_DTA) polymix-3-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) polymix-3-guts.pg ${datadir}/polygraph/workloads/include
-
- polymix-4-guts.pg_install: install_dirs polymix-4-guts.pg
-- $(INSTALL_DTA) polymix-4-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) polymix-4-guts.pg ${datadir}/polygraph/workloads/include
-
- webaxe-4-guts.pg_install: install_dirs webaxe-4-guts.pg
-- $(INSTALL_DTA) webaxe-4-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) webaxe-4-guts.pg ${datadir}/polygraph/workloads/include
-
- all: all_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
-
-@@ -80,7 +80,7 @@
-
- install: install_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
- install_dirs:
-- @for d in ${prefix}/workloads/include/; do \
-+ @for d in ${datadir}/polygraph/workloads/include/; do \
- if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
+--- workloads/include/Makefile.in.orig Thu Sep 13 05:26:52 2007
++++ workloads/include/Makefile.in Thu Sep 13 05:27:24 2007
+@@ -165,7 +165,7 @@
+ std_include = @std_include@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-winclude_pkgdir = ${prefix}/workloads/include
++winclude_pkgdir = ${datadir}/workloads/include
+ dist_winclude_pkg_DATA = \
+ benches.pg \
+ contents.pg \
diff --git a/benchmarks/polygraph/pkg-plist b/benchmarks/polygraph/pkg-plist
index 927b65a85e09..4ecf14a08af3 100644
--- a/benchmarks/polygraph/pkg-plist
+++ b/benchmarks/polygraph/pkg-plist
@@ -1,4 +1,5 @@
bin/aka
+bin/beepmon.pl
bin/cdb
bin/distr_test
bin/dns_cfg
@@ -9,10 +10,11 @@ bin/pgl2acl
bin/pgl2eng
bin/pgl2ldif
bin/pgl_test
+bin/pmix2-ips.pl
+bin/pmix3-ips.pl
bin/polyclt
bin/polymon
bin/polyprobe
-bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
@@ -20,19 +22,7 @@ bin/reporter
bin/rng_test
bin/tcp2xmld
bin/udp2tcpd
-%%DATADIR%%/ReportGen/label_results
-%%DATADIR%%/ReportGen/make_report
-%%DATADIR%%/ReportGen/make_card
-%%DATADIR%%/ReportGen/plot_traces
-%%DATADIR%%/ReportGen/plot_table
-%%DATADIR%%/ReportGen/Globs.pm
-%%DATADIR%%/ReportGen/Line.pm
-%%DATADIR%%/ReportGen/ObjDbase.pm
-%%DATADIR%%/ReportGen/ObjManip.pm
-%%DATADIR%%/ReportGen/Opts.pm
-%%DATADIR%%/ReportGen/Plot.pm
-%%DATADIR%%/ReportGen/RepFormat.pm
-%%DATADIR%%/ReportGen/reportgen.cfg
+bin/webaxe4-ips.pl
%%DATADIR%%/workloads/datacomm-1.pg
%%DATADIR%%/workloads/downtime-2.pg
%%DATADIR%%/workloads/include/benches.pg
@@ -57,7 +47,6 @@ bin/udp2tcpd
%%DATADIR%%/workloads/webaxe-1.pg
%%DATADIR%%/workloads/webaxe-3.pg
%%DATADIR%%/workloads/webaxe-4.pg
-@dirrm %%DATADIR%%/ReportGen
@dirrm %%DATADIR%%/workloads/include
@dirrm %%DATADIR%%/workloads
@dirrm %%DATADIR%%
diff --git a/benchmarks/polygraph31/Makefile b/benchmarks/polygraph31/Makefile
index afabffb55a20..d0f8dd6f4291 100644
--- a/benchmarks/polygraph31/Makefile
+++ b/benchmarks/polygraph31/Makefile
@@ -6,22 +6,34 @@
#
PORTNAME= polygraph
-PORTVERSION= 2.8.1
+PORTVERSION= 3.0.6
CATEGORIES= benchmarks www
-MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
+MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/ \
+ http://people.bsdgroup.de/~as/freebsd/distfiles/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= as@bsdgroup.org
COMMENT= A benchmarking tool for Web proxies
-RESTRICTED= Redistribution forbidden by license
-IS_INTERACTIVE= yes
-
GNU_CONFIGURE= YES
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -Wno-deprecated"
+CONFIGURE_ARGS+=--datadir=${DATADIR}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
CONFLICTS= ltrace-0*
-.include <bsd.port.mk>
+OPTIONS= GNUPLOT "gnuplot if you want full report functionality" ON \
+ PERL "install Perl for polygraph tools" OFF
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_GNUPLOT)
+RUN_DEPENDS+= gnuplot:${PORTSDIR}/math/gnuplot
+.endif
+
+.if !defined(WITHOUT_PERL)
+USE_PERL5_RUN= yes
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/benchmarks/polygraph31/distinfo b/benchmarks/polygraph31/distinfo
index 6ba80ea1b8cd..29637c4f979b 100644
--- a/benchmarks/polygraph31/distinfo
+++ b/benchmarks/polygraph31/distinfo
@@ -1,3 +1,3 @@
-MD5 (polygraph-2.8.1-src.tgz) = f42e70d3fa383f42bf3676c086b2d16c
-SHA256 (polygraph-2.8.1-src.tgz) = 0fbd101421385538e31187186f07476e91e1a66281e1e3c393dd9cbd2049508b
-SIZE (polygraph-2.8.1-src.tgz) = 710841
+MD5 (polygraph-3.0.6-src.tgz) = 36124ba0e8354b6e6c573a25ccf35b72
+SHA256 (polygraph-3.0.6-src.tgz) = 71c19c5c6d5472c9a3d254dc71353d365d7bc04f58b640e5c0c890d7e53043a2
+SIZE (polygraph-3.0.6-src.tgz) = 1064674
diff --git a/benchmarks/polygraph31/files/patch-tools-ReportGen-Makefile.in b/benchmarks/polygraph31/files/patch-tools-ReportGen-Makefile.in
deleted file mode 100644
index 130457622a3d..000000000000
--- a/benchmarks/polygraph31/files/patch-tools-ReportGen-Makefile.in
+++ /dev/null
@@ -1,22 +0,0 @@
---- tools/ReportGen/Makefile.in.orig Tue Jun 12 02:04:12 2001
-+++ tools/ReportGen/Makefile.in Sat Aug 3 13:55:53 2002
-@@ -15,7 +15,7 @@
- exec_prefix = @exec_prefix@
- bindir = @bindir@
-
--rgen_dir = @prefix@/ReportGen
-+rgen_dir = @prefix@/share/polygraph/ReportGen
-
- INSTALL = @INSTALL@
- INSTALL_PROGRAM = @INSTALL_PROGRAM@
-@@ -42,8 +42,8 @@
- fi
-
- install_mkdirs:
-- @for d in $(prefix) $(rgen_dir); do \
-- if test ! -d $$d; then echo mkdir $$d; mkdir $$d; fi; \
-+ @for d in $(rgen_dir); do \
-+ if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
- clean:
diff --git a/benchmarks/polygraph31/files/patch-workloads-Makefile.in b/benchmarks/polygraph31/files/patch-workloads-Makefile.in
index 9bc6ff415c93..7730c87b518e 100644
--- a/benchmarks/polygraph31/files/patch-workloads-Makefile.in
+++ b/benchmarks/polygraph31/files/patch-workloads-Makefile.in
@@ -1,84 +1,11 @@
---- workloads/Makefile.in.orig Sun Jul 29 06:45:59 2001
-+++ workloads/Makefile.in Sat Aug 3 13:56:45 2002
-@@ -45,55 +45,55 @@
- default: all
-
- datacomm-1.pg_install: install_dirs datacomm-1.pg
-- $(INSTALL_DTA) datacomm-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) datacomm-1.pg ${datadir}/polygraph/workloads
-
- downtime-2.pg_install: install_dirs downtime-2.pg
-- $(INSTALL_DTA) downtime-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) downtime-2.pg ${datadir}/polygraph/workloads
-
- nolb-l4-4.pg_install: install_dirs nolb-l4-4.pg
-- $(INSTALL_DTA) nolb-l4-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) nolb-l4-4.pg ${datadir}/polygraph/workloads
-
- polyfill-2.pg_install: install_dirs polyfill-2.pg
-- $(INSTALL_DTA) polyfill-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polyfill-2.pg ${datadir}/polygraph/workloads
-
- polymix-1.pg_install: install_dirs polymix-1.pg
-- $(INSTALL_DTA) polymix-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-1.pg ${datadir}/polygraph/workloads
-
- polymix-2.pg_install: install_dirs polymix-2.pg
-- $(INSTALL_DTA) polymix-2.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-2.pg ${datadir}/polygraph/workloads
-
- polymix-3.pg_install: install_dirs polymix-3.pg
-- $(INSTALL_DTA) polymix-3.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-3.pg ${datadir}/polygraph/workloads
-
- polymix-4.pg_install: install_dirs polymix-4.pg
-- $(INSTALL_DTA) polymix-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) polymix-4.pg ${datadir}/polygraph/workloads
-
- pxylb-4.pg_install: install_dirs pxylb-4.pg
-- $(INSTALL_DTA) pxylb-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) pxylb-4.pg ${datadir}/polygraph/workloads
-
- simple.pg_install: install_dirs simple.pg
-- $(INSTALL_DTA) simple.pg ${prefix}/workloads
-+ $(INSTALL_DTA) simple.pg ${datadir}/polygraph/workloads
-
- srvlb-l4-4.pg_install: install_dirs srvlb-l4-4.pg
-- $(INSTALL_DTA) srvlb-l4-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) srvlb-l4-4.pg ${datadir}/polygraph/workloads
-
- srvlb-l7-4.pg_install: install_dirs srvlb-l7-4.pg
-- $(INSTALL_DTA) srvlb-l7-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) srvlb-l7-4.pg ${datadir}/polygraph/workloads
-
- test_csm.pg_install: install_dirs test_csm.pg
-- $(INSTALL_DTA) test_csm.pg ${prefix}/workloads
-+ $(INSTALL_DTA) test_csm.pg ${datadir}/polygraph/workloads
-
- test_polypxy.pg_install: install_dirs test_polypxy.pg
-- $(INSTALL_DTA) test_polypxy.pg ${prefix}/workloads
-+ $(INSTALL_DTA) test_polypxy.pg ${datadir}/polygraph/workloads
-
- webaxe-1.pg_install: install_dirs webaxe-1.pg
-- $(INSTALL_DTA) webaxe-1.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-1.pg ${datadir}/polygraph/workloads
-
- webaxe-3.pg_install: install_dirs webaxe-3.pg
-- $(INSTALL_DTA) webaxe-3.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-3.pg ${datadir}/polygraph/workloads
-
- webaxe-4.pg_install: install_dirs webaxe-4.pg
-- $(INSTALL_DTA) webaxe-4.pg ${prefix}/workloads
-+ $(INSTALL_DTA) webaxe-4.pg ${datadir}/polygraph/workloads
-
- all: all_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
-
-@@ -122,7 +122,7 @@
-
- install: install_subdirs datacomm-1.pg downtime-2.pg nolb-l4-4.pg polyfill-2.pg polymix-1.pg polymix-2.pg polymix-3.pg polymix-4.pg pxylb-4.pg simple.pg srvlb-l4-4.pg srvlb-l7-4.pg test_csm.pg test_polypxy.pg webaxe-1.pg webaxe-3.pg webaxe-4.pg
- install_dirs:
-- @for d in ${prefix}/workloads/; do \
-+ @for d in ${datadir}/polygraph/workloads ; do \
- if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
+--- workloads/Makefile.in.orig Thu Sep 13 05:21:49 2007
++++ workloads/Makefile.in Thu Sep 13 05:26:27 2007
+@@ -175,7 +175,7 @@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+ SUBDIRS = include
+-workloads_pkgdir = ${prefix}/workloads
++workloads_pkgdir = ${datadir}/workloads
+ dist_workloads_pkg_DATA = \
+ datacomm-1.pg \
+ downtime-2.pg \
diff --git a/benchmarks/polygraph31/files/patch-workloads-include-Makefile.in b/benchmarks/polygraph31/files/patch-workloads-include-Makefile.in
index 3852d88cc9bf..c8b99735e547 100644
--- a/benchmarks/polygraph31/files/patch-workloads-include-Makefile.in
+++ b/benchmarks/polygraph31/files/patch-workloads-include-Makefile.in
@@ -1,44 +1,11 @@
---- workloads/include/Makefile.in.orig Sat Aug 3 14:23:13 2002
-+++ workloads/include/Makefile.in Sat Aug 3 14:24:50 2002
-@@ -45,25 +45,25 @@
- default: all
-
- benches.pg_install: install_dirs benches.pg
-- $(INSTALL_DTA) benches.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) benches.pg ${datadir}/polygraph/workloads/include
-
- contents.pg_install: install_dirs contents.pg
-- $(INSTALL_DTA) contents.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) contents.pg ${datadir}/polygraph/workloads/include
-
- phases.pg_install: install_dirs phases.pg
-- $(INSTALL_DTA) phases.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) phases.pg ${datadir}/polygraph/workloads/include
-
- pipes.pg_install: install_dirs pipes.pg
-- $(INSTALL_DTA) pipes.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) pipes.pg ${datadir}/polygraph/workloads/include
-
- polymix-3-guts.pg_install: install_dirs polymix-3-guts.pg
-- $(INSTALL_DTA) polymix-3-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) polymix-3-guts.pg ${datadir}/polygraph/workloads/include
-
- polymix-4-guts.pg_install: install_dirs polymix-4-guts.pg
-- $(INSTALL_DTA) polymix-4-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) polymix-4-guts.pg ${datadir}/polygraph/workloads/include
-
- webaxe-4-guts.pg_install: install_dirs webaxe-4-guts.pg
-- $(INSTALL_DTA) webaxe-4-guts.pg ${prefix}/workloads/include
-+ $(INSTALL_DTA) webaxe-4-guts.pg ${datadir}/polygraph/workloads/include
-
- all: all_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
-
-@@ -80,7 +80,7 @@
-
- install: install_subdirs benches.pg contents.pg phases.pg pipes.pg polymix-3-guts.pg polymix-4-guts.pg webaxe-4-guts.pg
- install_dirs:
-- @for d in ${prefix}/workloads/include/; do \
-+ @for d in ${datadir}/polygraph/workloads/include/; do \
- if test ! -d $$d; then echo mkdir -p $$d; mkdir -p $$d; fi; \
- done
-
+--- workloads/include/Makefile.in.orig Thu Sep 13 05:26:52 2007
++++ workloads/include/Makefile.in Thu Sep 13 05:27:24 2007
+@@ -165,7 +165,7 @@
+ std_include = @std_include@
+ sysconfdir = @sysconfdir@
+ target_alias = @target_alias@
+-winclude_pkgdir = ${prefix}/workloads/include
++winclude_pkgdir = ${datadir}/workloads/include
+ dist_winclude_pkg_DATA = \
+ benches.pg \
+ contents.pg \
diff --git a/benchmarks/polygraph31/pkg-plist b/benchmarks/polygraph31/pkg-plist
index 927b65a85e09..4ecf14a08af3 100644
--- a/benchmarks/polygraph31/pkg-plist
+++ b/benchmarks/polygraph31/pkg-plist
@@ -1,4 +1,5 @@
bin/aka
+bin/beepmon.pl
bin/cdb
bin/distr_test
bin/dns_cfg
@@ -9,10 +10,11 @@ bin/pgl2acl
bin/pgl2eng
bin/pgl2ldif
bin/pgl_test
+bin/pmix2-ips.pl
+bin/pmix3-ips.pl
bin/polyclt
bin/polymon
bin/polyprobe
-bin/polypxy
bin/polyrrd
bin/polysrv
bin/pop_test
@@ -20,19 +22,7 @@ bin/reporter
bin/rng_test
bin/tcp2xmld
bin/udp2tcpd
-%%DATADIR%%/ReportGen/label_results
-%%DATADIR%%/ReportGen/make_report
-%%DATADIR%%/ReportGen/make_card
-%%DATADIR%%/ReportGen/plot_traces
-%%DATADIR%%/ReportGen/plot_table
-%%DATADIR%%/ReportGen/Globs.pm
-%%DATADIR%%/ReportGen/Line.pm
-%%DATADIR%%/ReportGen/ObjDbase.pm
-%%DATADIR%%/ReportGen/ObjManip.pm
-%%DATADIR%%/ReportGen/Opts.pm
-%%DATADIR%%/ReportGen/Plot.pm
-%%DATADIR%%/ReportGen/RepFormat.pm
-%%DATADIR%%/ReportGen/reportgen.cfg
+bin/webaxe4-ips.pl
%%DATADIR%%/workloads/datacomm-1.pg
%%DATADIR%%/workloads/downtime-2.pg
%%DATADIR%%/workloads/include/benches.pg
@@ -57,7 +47,6 @@ bin/udp2tcpd
%%DATADIR%%/workloads/webaxe-1.pg
%%DATADIR%%/workloads/webaxe-3.pg
%%DATADIR%%/workloads/webaxe-4.pg
-@dirrm %%DATADIR%%/ReportGen
@dirrm %%DATADIR%%/workloads/include
@dirrm %%DATADIR%%/workloads
@dirrm %%DATADIR%%