aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorSergey A. Osokin <osa@FreeBSD.org>2015-05-31 20:05:25 +0000
committerSergey A. Osokin <osa@FreeBSD.org>2015-05-31 20:05:25 +0000
commit8fe3cdf35004e5aa0d296e293211b674a2835ed5 (patch)
tree26466a192b9efb527953b07a8ff9fc67d8174883 /benchmarks
parent3640a250205558ef2bfd8e4f38cb4aff6beb1747 (diff)
downloadports-8fe3cdf35004e5aa0d296e293211b674a2835ed5.tar.gz
ports-8fe3cdf35004e5aa0d296e293211b674a2835ed5.zip
Unhide compiler and linker output.
Use CFLAGS defined in port's Makefile. Bump PORTREVISION.
Notes
Notes: svn path=/head/; revision=388163
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/wrk/Makefile2
-rw-r--r--benchmarks/wrk/files/patch-Makefile24
2 files changed, 20 insertions, 6 deletions
diff --git a/benchmarks/wrk/Makefile b/benchmarks/wrk/Makefile
index 8ce5ec9e1ab4..a26e8003e766 100644
--- a/benchmarks/wrk/Makefile
+++ b/benchmarks/wrk/Makefile
@@ -3,7 +3,7 @@
PORTNAME= wrk
PORTVERSION= 4.0.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= benchmarks www
DISTNAME= ${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
diff --git a/benchmarks/wrk/files/patch-Makefile b/benchmarks/wrk/files/patch-Makefile
index 827aa07fed20..6407c911cddd 100644
--- a/benchmarks/wrk/files/patch-Makefile
+++ b/benchmarks/wrk/files/patch-Makefile
@@ -1,6 +1,14 @@
---- Makefile.orig 2014-08-05 16:50:32.000000000 +0400
-+++ Makefile 2014-09-13 02:29:01.000000000 +0400
-@@ -24,28 +24,28 @@
+--- Makefile.orig 2015-03-24 13:03:52.000000000 +0300
++++ Makefile 2015-05-31 22:58:26.276469000 +0300
+@@ -1,5 +1,5 @@
+-CFLAGS := -std=c99 -Wall -O2 -D_REENTRANT
+-LIBS := -lpthread -lm -lcrypto -lssl
++CFLAGS += -std=c99 -Wall -O2 -D_REENTRANT
++LIBS := -pthread -lm -lcrypto -lssl
+
+ TARGET := $(shell uname -s | tr '[A-Z]' '[a-z]' 2>/dev/null || echo unknown)
+
+@@ -25,32 +25,32 @@
OBJ := $(patsubst %.c,$(ODIR)/%.o,$(SRC)) $(ODIR)/bytecode.o
LDIR = deps/luajit/src
@@ -18,7 +26,8 @@
$(BIN): $(OBJ)
@echo LINK $(BIN)
- @$(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
+- @$(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
++ $(CC) $(LDFLAGS) -o $@ $^ $(LIBS)
-$(OBJ): config.h Makefile $(LDIR)/libluajit.a | $(ODIR)
+$(OBJ): config.h Makefile | $(ODIR)
@@ -29,7 +38,12 @@
$(ODIR)/bytecode.o: src/wrk.lua
@echo LUAJIT $<
- @$(SHELL) -c 'cd $(LDIR) && ./luajit -b $(CURDIR)/$< $(CURDIR)/$@'
-+ @$(SHELL) -c 'cd $(LDIR) && ${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'
++ $(SHELL) -c 'cd $(LDIR) && ${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'
$(ODIR)/%.o : %.c
@echo CC $<
+- @$(CC) $(CFLAGS) -c -o $@ $<
++ $(CC) $(CFLAGS) -c -o $@ $<
+
+ $(LDIR)/libluajit.a:
+ @echo Building LuaJIT...