aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorGabor Pali <pgj@FreeBSD.org>2010-06-08 12:47:24 +0000
committerGabor Pali <pgj@FreeBSD.org>2010-06-08 12:47:24 +0000
commitb8b3508bdf7b9fe7e2852bf144113c5f3e1d30d6 (patch)
treeb974fad09b3c5d4f02b265df8f18c71f5ec51186 /benchmarks
parent7eafd44e5560a8c750909be3be375216bd4f5647 (diff)
downloadports-b8b3508bdf7b9fe7e2852bf144113c5f3e1d30d6.tar.gz
ports-b8b3508bdf7b9fe7e2852bf144113c5f3e1d30d6.zip
- Update to 0.5.0.0
Notes
Notes: svn path=/head/; revision=256126
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/hs-criterion/Makefile6
-rw-r--r--benchmarks/hs-criterion/distinfo6
-rw-r--r--benchmarks/hs-criterion/files/patch-Criterion__Main.hs12
-rw-r--r--benchmarks/hs-criterion/files/patch-criterion.cabal11
4 files changed, 29 insertions, 6 deletions
diff --git a/benchmarks/hs-criterion/Makefile b/benchmarks/hs-criterion/Makefile
index d0cef601fb26..a3e523effef2 100644
--- a/benchmarks/hs-criterion/Makefile
+++ b/benchmarks/hs-criterion/Makefile
@@ -6,15 +6,15 @@
#
PORTNAME= criterion
-PORTVERSION= 0.4.1.0
+PORTVERSION= 0.5.0.0
CATEGORIES= benchmarks haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Robust, reliable performance measurement and analysis for Haskell
CABAL_SETUP= Setup.hs
-USE_HACKAGE= deepseq>=1.1.0.0 statistics>=0.3.5 uvector>=0.1.0.5 \
- uvector-algorithms>=0.2
+USE_HACKAGE= deepseq>=1.1.0.0 mwc-random>=0.5.0.0 statistics>=0.5.1.0 \
+ vector>=0.5 vector-algorithms>=0.3
PORTEXAMPLES= *
INSTALL_PORTEXAMPLES= \
diff --git a/benchmarks/hs-criterion/distinfo b/benchmarks/hs-criterion/distinfo
index bc8fe9222e34..9bca01b383da 100644
--- a/benchmarks/hs-criterion/distinfo
+++ b/benchmarks/hs-criterion/distinfo
@@ -1,3 +1,3 @@
-MD5 (criterion-0.4.1.0.tar.gz) = 55f90d0fff67dff305fde7fa684fab54
-SHA256 (criterion-0.4.1.0.tar.gz) = 2bebfd3c8bfd7eeb3cc30ff23c6be067cf1dc9af11a1edda92f3fbe967b3dcf6
-SIZE (criterion-0.4.1.0.tar.gz) = 17529
+MD5 (criterion-0.5.0.0.tar.gz) = 8c84f3a9cc0b8fccf0ad999d46e0d0fc
+SHA256 (criterion-0.5.0.0.tar.gz) = 1f27da214dbb0600ac35e752665f83e7eaa201b07427c3bb1d4752a34225bd0a
+SIZE (criterion-0.5.0.0.tar.gz) = 17737
diff --git a/benchmarks/hs-criterion/files/patch-Criterion__Main.hs b/benchmarks/hs-criterion/files/patch-Criterion__Main.hs
new file mode 100644
index 000000000000..dd41dac0c7f2
--- /dev/null
+++ b/benchmarks/hs-criterion/files/patch-Criterion__Main.hs
@@ -0,0 +1,12 @@
+--- ./Criterion/Main.hs.orig 2010-03-30 00:56:34.000000000 +0200
++++ ./Criterion/Main.hs 2010-06-07 11:28:30.097091827 +0200
+@@ -58,8 +58,7 @@
+ import System.Console.GetOpt
+ import System.Environment (getArgs, getProgName)
+ import System.Exit (ExitCode(..), exitWith)
+-import Text.Parsec
+-import Text.Parsec.String
++import Text.ParserCombinators.Parsec
+
+ -- | Parse a plot output.
+ parsePlot :: Parser PlotOutput
diff --git a/benchmarks/hs-criterion/files/patch-criterion.cabal b/benchmarks/hs-criterion/files/patch-criterion.cabal
new file mode 100644
index 000000000000..332975b4395e
--- /dev/null
+++ b/benchmarks/hs-criterion/files/patch-criterion.cabal
@@ -0,0 +1,11 @@
+--- ./criterion.cabal.orig 2010-03-30 00:56:34.000000000 +0200
++++ ./criterion.cabal 2010-06-07 11:22:44.032554295 +0200
+@@ -53,7 +53,7 @@
+ mtl,
+ mwc-random >= 0.5.0.0,
+ parallel,
+- parsec >= 3.1.0,
++ parsec,
+ statistics >= 0.5.1.0,
+ time,
+ vector >= 0.5,