aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-24 07:26:36 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2008-09-24 07:26:36 +0000
commite4ca61134fb81ebb34713ff2313e7e24270b2fb0 (patch)
tree9f25ff951fd03a0dd72d8490e20ee7ae194f9ca8 /benchmarks
parentadec137063a79b09a510c7e9556a045a1e69dfae (diff)
downloadports-e4ca61134fb81ebb34713ff2313e7e24270b2fb0.tar.gz
ports-e4ca61134fb81ebb34713ff2313e7e24270b2fb0.zip
The octave-forge package is the result of The GNU Octave Repositry project,
which is intended to be a central location for custom scripts, functions and extensions for GNU Octave. contains the source for all the functions plus build and install scripts. This is benchmark. The package contains code used to benchmark speed of Octave. WWW: http://octave.sourceforge.net/ PR: 127301 Submitted by: Stephen Montgomery-Smith <stephen at math dot missouri dot edu>
Notes
Notes: svn path=/head/; revision=220612
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/octave-forge-benchmark/Makefile17
-rw-r--r--benchmarks/octave-forge-benchmark/distinfo3
-rw-r--r--benchmarks/octave-forge-benchmark/pkg-descr10
-rw-r--r--benchmarks/octave-forge-benchmark/pkg-plist1
5 files changed, 32 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index ebdecdd20219..f841f822afe9 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -32,6 +32,7 @@
SUBDIR += netpipe
SUBDIR += nqueens
SUBDIR += nttcp
+ SUBDIR += octave-forge-benchmark
SUBDIR += p5-Benchmark-Forking
SUBDIR += p5-Benchmark-Stopwatch
SUBDIR += pathchirp
diff --git a/benchmarks/octave-forge-benchmark/Makefile b/benchmarks/octave-forge-benchmark/Makefile
new file mode 100644
index 000000000000..45d56b206ae7
--- /dev/null
+++ b/benchmarks/octave-forge-benchmark/Makefile
@@ -0,0 +1,17 @@
+# New ports collection makefile for: octave-forge-benchmark
+# Date created: 11 September 2008
+# Whom: Stephen Montgomery-Smith <stephen@math.missouri.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= octave-forge-benchmark
+PORTVERSION= 1.0.0
+CATEGORIES= benchmarks math
+
+MAINTAINER= stephen@math.missouri.edu
+COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/Mk/bsd.octave.mk"
+.include <bsd.port.post.mk>
diff --git a/benchmarks/octave-forge-benchmark/distinfo b/benchmarks/octave-forge-benchmark/distinfo
new file mode 100644
index 000000000000..63a82b154a17
--- /dev/null
+++ b/benchmarks/octave-forge-benchmark/distinfo
@@ -0,0 +1,3 @@
+MD5 (octave-forge/benchmark-1.0.0.tar.gz) = 211a810feb960fad486d2c9c9bb7d0a8
+SHA256 (octave-forge/benchmark-1.0.0.tar.gz) = c039c664127e4dd4f3e4ac1fd49f8d60af77c6f1d8369161abbf2fccd589898d
+SIZE (octave-forge/benchmark-1.0.0.tar.gz) = 11940
diff --git a/benchmarks/octave-forge-benchmark/pkg-descr b/benchmarks/octave-forge-benchmark/pkg-descr
new file mode 100644
index 000000000000..8b034abc3dd6
--- /dev/null
+++ b/benchmarks/octave-forge-benchmark/pkg-descr
@@ -0,0 +1,10 @@
+The octave-forge package is the result of The GNU Octave Repositry project,
+which is intended to be a central location for custom scripts, functions and
+extensions for GNU Octave. contains the source for all the functions plus
+build and install scripts.
+
+This is benchmark.
+
+The package contains code used to benchmark speed of Octave.
+
+WWW: http://octave.sourceforge.net/
diff --git a/benchmarks/octave-forge-benchmark/pkg-plist b/benchmarks/octave-forge-benchmark/pkg-plist
new file mode 100644
index 000000000000..a999ec86c07e
--- /dev/null
+++ b/benchmarks/octave-forge-benchmark/pkg-plist
@@ -0,0 +1 @@
+@comment This file intentionally left empty