aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-06 20:17:17 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-06 20:17:17 +0000
commit20364ec3d44993d5550a4d8b21b77a04cfd2894e (patch)
tree29d8b05b05a644cbced299fdd88ca05acc7a917b /benchmarks
parent9184f8ca1e8761933258da75c9fc3f727f1434ff (diff)
downloadports-20364ec3d44993d5550a4d8b21b77a04cfd2894e.tar.gz
ports-20364ec3d44993d5550a4d8b21b77a04cfd2894e.zip
Add stream-1.0, a synthetic benchmark program that measures sustainable
memory bandwidth PR: 27272 Submitted by: Scott Flatman <sf@dsinw.com>
Notes
Notes: svn path=/head/; revision=49688
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/stream/Makefile25
-rw-r--r--benchmarks/stream/distinfo2
-rw-r--r--benchmarks/stream/files/Makefile24
-rw-r--r--benchmarks/stream/files/patch-stream_d.c13
-rw-r--r--benchmarks/stream/pkg-comment1
-rw-r--r--benchmarks/stream/pkg-descr7
-rw-r--r--benchmarks/stream/pkg-plist1
8 files changed, 74 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 5620dfd0086b..7f844bd18b8c 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -17,6 +17,7 @@
SUBDIR += pybench
SUBDIR += rawio
SUBDIR += siege
+ SUBDIR += stream
SUBDIR += tcpblast
SUBDIR += tmetric
SUBDIR += ubench
diff --git a/benchmarks/stream/Makefile b/benchmarks/stream/Makefile
new file mode 100644
index 000000000000..bab83bfac488
--- /dev/null
+++ b/benchmarks/stream/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: stream
+# Date created: 10 May 2001
+# Whom: Scott Flatman <sf@dsinw.com>
+#
+# $FreeBSD$
+
+PORTNAME= stream
+PORTVERSION= 1.0
+CATEGORIES= benchmarks
+MASTER_SITES= ftp://ftp.cs.virginia.edu/pub/stream/Code/
+DISTFILES= second_cpu.c stream_d.c
+DIST_SUBDIR= stream-${PORTVERSION}
+
+MAINTAINER= sf@dsinw.com
+
+MAKEFILE= ${FILESDIR}/Makefile
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} -r ${_DISTDIR} ${WRKDIR}
+
+post-install:
+ strip ${PREFIX}/bin/stream
+
+.include <bsd.port.mk>
diff --git a/benchmarks/stream/distinfo b/benchmarks/stream/distinfo
new file mode 100644
index 000000000000..f0049749fb63
--- /dev/null
+++ b/benchmarks/stream/distinfo
@@ -0,0 +1,2 @@
+MD5 (stream-1.0/second_cpu.c) = ec4d884bbe6832f21615617e54af187f
+MD5 (stream-1.0/stream_d.c) = 1b064704a0e87599fa773b7928034be3
diff --git a/benchmarks/stream/files/Makefile b/benchmarks/stream/files/Makefile
new file mode 100644
index 000000000000..c0516fcee132
--- /dev/null
+++ b/benchmarks/stream/files/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+# stream didn't come with a makefile
+
+CFLAGS+= -Wall -pedantic -ansi -pipe
+BINOWN= root
+BINGRP= wheel
+BINMODE= 0555
+INSTALLDIR= ${PREFIX}/bin
+
+# season to flavor, see the stream docs
+NSIZE= 1000000
+
+#
+all: stream_d.o second_cpu.o
+ ${CC} -o stream stream_d.o second_cpu.o -lm
+
+stream_d.o: stream_d.c
+ ${CC} ${CFLAGS} -DNSIZE=${NSIZE} -c stream_d.c
+
+second_cpu.o: second_cpu.c
+ ${CC} ${CFLAGS} -c second_cpu.c
+
+install:
+ ${INSTALL} -c -o ${BINOWN} -g ${BINGRP} -m ${BINMODE} stream ${INSTALLDIR}
diff --git a/benchmarks/stream/files/patch-stream_d.c b/benchmarks/stream/files/patch-stream_d.c
new file mode 100644
index 000000000000..e2d95b14857e
--- /dev/null
+++ b/benchmarks/stream/files/patch-stream_d.c
@@ -0,0 +1,13 @@
+$FreeBSD$
+
+--- stream_d.c.orig Tue Nov 6 15:02:21 2001
++++ stream_d.c Tue Nov 6 15:03:11 2001
+@@ -23,7 +23,7 @@
+ * that should be good to about 5% precision.
+ */
+
+-# define N 1000000
++# define N NSIZE
+ # define NTIMES 10
+ # define OFFSET 0
+
diff --git a/benchmarks/stream/pkg-comment b/benchmarks/stream/pkg-comment
new file mode 100644
index 000000000000..cf452066ebe6
--- /dev/null
+++ b/benchmarks/stream/pkg-comment
@@ -0,0 +1 @@
+Synthetic benchmark program that measures sustainable memory bandwidth
diff --git a/benchmarks/stream/pkg-descr b/benchmarks/stream/pkg-descr
new file mode 100644
index 000000000000..64fbcb1e7535
--- /dev/null
+++ b/benchmarks/stream/pkg-descr
@@ -0,0 +1,7 @@
+The STREAM benchmark is a simple synthetic benchmark program that
+measures sustainable memory bandwidth (in MB/s) and the corresponding
+computation rate for simple vector kernels.
+
+WWW: http://www.cs.virginia.edu/stream/
+
+- Scott Flatman <sf@dsinw.com>
diff --git a/benchmarks/stream/pkg-plist b/benchmarks/stream/pkg-plist
new file mode 100644
index 000000000000..a5bd75c67d6b
--- /dev/null
+++ b/benchmarks/stream/pkg-plist
@@ -0,0 +1 @@
+bin/stream