aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 06:23:50 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-04-02 06:23:50 +0000
commit4e852e5be4f5710a276ef1f2b79ebe284c9fc932 (patch)
treef75804338fc552734bb987978d687c52a7e6668e /benchmarks
parentcb96989f7e16e8bc9e694f51ea75548c21d2bad4 (diff)
downloadports-4e852e5be4f5710a276ef1f2b79ebe284c9fc932.tar.gz
ports-4e852e5be4f5710a276ef1f2b79ebe284c9fc932.zip
add postal, a SMTP/POP benchmark tester
Notes
Notes: svn path=/head/; revision=40719
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/Makefile1
-rw-r--r--benchmarks/postal/Makefile25
-rw-r--r--benchmarks/postal/distinfo1
-rw-r--r--benchmarks/postal/pkg-comment1
-rw-r--r--benchmarks/postal/pkg-descr8
-rw-r--r--benchmarks/postal/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/benchmarks/Makefile b/benchmarks/Makefile
index 50dd289cd984..4430da156649 100644
--- a/benchmarks/Makefile
+++ b/benchmarks/Makefile
@@ -12,6 +12,7 @@
SUBDIR += netperf
SUBDIR += netpipe
SUBDIR += polygraph
+ SUBDIR += postal
SUBDIR += postmark
SUBDIR += pybench
SUBDIR += rawio
diff --git a/benchmarks/postal/Makefile b/benchmarks/postal/Makefile
new file mode 100644
index 000000000000..12299543ff4e
--- /dev/null
+++ b/benchmarks/postal/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# New ports collection makefile for: postal
+# Date created: Apr 2, 2001
+# Whom: Ying-Chieh Liao <ijliao@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= postal
+PORTVERSION= 0.59
+CATEGORIES= benchmarks mail
+MASTER_SITES= http://www.coker.com.au/postal/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ijliao@FreeBSD.org
+
+USE_OPENSSL= yes
+GNU_CONFIGURE= yes
+
+MAN8= postal.8 postal-list.8 rabid.8
+
+post-patch:
+ @${PERL} -pi -e "s,-pthread,${PTHREAD_LIBS},g" ${WRKSRC}/configure
+
+.include <bsd.port.mk>
diff --git a/benchmarks/postal/distinfo b/benchmarks/postal/distinfo
new file mode 100644
index 000000000000..a6cc09ab7d99
--- /dev/null
+++ b/benchmarks/postal/distinfo
@@ -0,0 +1 @@
+MD5 (postal-0.59.tgz) = aa4dc1051176286c21699773eaea8b18
diff --git a/benchmarks/postal/pkg-comment b/benchmarks/postal/pkg-comment
new file mode 100644
index 000000000000..db65ac07def7
--- /dev/null
+++ b/benchmarks/postal/pkg-comment
@@ -0,0 +1 @@
+Benchmark SMTP/POP servers
diff --git a/benchmarks/postal/pkg-descr b/benchmarks/postal/pkg-descr
new file mode 100644
index 000000000000..2c5a4f42859a
--- /dev/null
+++ b/benchmarks/postal/pkg-descr
@@ -0,0 +1,8 @@
+Postal is a SMTP benchmark.
+
+Postal-list will list all the possible expansions for an account name (used
+for creating a list of accounts to create on your test server).
+
+Rabid is the mad Biff, it is a POP benchmark.
+
+WWW: http://www.coker.com.au/postal/
diff --git a/benchmarks/postal/pkg-plist b/benchmarks/postal/pkg-plist
new file mode 100644
index 000000000000..f85e614f2f2c
--- /dev/null
+++ b/benchmarks/postal/pkg-plist
@@ -0,0 +1,3 @@
+sbin/postal
+sbin/postal-list
+sbin/rabid