aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-04-04 05:51:54 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-04-04 05:51:54 +0000
commita6f56c02006341dc161e3c7a3a7b95801a17a200 (patch)
tree47fcfdc2f913f410b29e90ee8a79860c4fdd1d9b /benchmarks
parentd168ffd59cd98d66161903c6cd3abe6c73733dbc (diff)
downloadports-a6f56c02006341dc161e3c7a3a7b95801a17a200.tar.gz
ports-a6f56c02006341dc161e3c7a3a7b95801a17a200.zip
Respect CC and CFLAGS
Noticed by: My new Ultra 30
Notes
Notes: svn path=/head/; revision=57297
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/lmbench/files/patch-aa22
1 files changed, 20 insertions, 2 deletions
diff --git a/benchmarks/lmbench/files/patch-aa b/benchmarks/lmbench/files/patch-aa
index b3002a109508..ab8a4793ecd1 100644
--- a/benchmarks/lmbench/files/patch-aa
+++ b/benchmarks/lmbench/files/patch-aa
@@ -1,5 +1,23 @@
---- src/Makefile.orig Wed May 28 01:21:10 1997
-+++ src/Makefile Wed May 28 01:19:40 1997
+--- src/Makefile.orig Sat Nov 11 18:42:41 1995
++++ src/Makefile Thu Apr 4 05:19:26 2002
+@@ -27,7 +27,7 @@
+ # I finally know why Larry Wall's Makefile says "Grrrr".
+ SHELL=/bin/sh
+
+-CC = gcc
++CC ?= gcc
+ O= ../bin/unknown
+ OS=`../scripts/os`
+ BINDIR=../bin/$(OS)
+@@ -37,7 +37,7 @@
+ lmbench/Results/osf1/alpha lmbench/Results/solaris/ss20*
+
+ SYS5=
+-CFLAGS = -O $(SYS5)
++CFLAGS += $(SYS5)
+
+ COMPILE=$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS)
+
@@ -93,7 +93,7 @@
$(MAKE) O=$O CC=cc CFLAGS="$(CFLAGS)" all