aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
committerStanislav Sedov <stas@FreeBSD.org>2008-04-06 08:58:21 +0000
commitfae8e0f615b1dfcff35249a7a11ebfba7391bc56 (patch)
treecbba292aa57c0d2e7bb423ca0366362b198eec85 /benchmarks
parent090dbb7b77d15ec9d072089f51c17e73d6e22f59 (diff)
downloadports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.tar.gz
ports-fae8e0f615b1dfcff35249a7a11ebfba7391bc56.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Notes
Notes: svn path=/head/; revision=210636
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/rubygem-railsbench/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/benchmarks/rubygem-railsbench/Makefile b/benchmarks/rubygem-railsbench/Makefile
index 915680a9dbc2..f2afbafef1c3 100644
--- a/benchmarks/rubygem-railsbench/Makefile
+++ b/benchmarks/rubygem-railsbench/Makefile
@@ -16,6 +16,9 @@ COMMENT= Scripts designed for benchmarking of Rails applications
BUILD_DEPENDS= rubygem-hoe>=1.2.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
OPTIONS= GRUFF "Plotting of perf data support using gruff" off
OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
@@ -25,5 +28,4 @@ OPTIONSFILE= ${PORT_DBDIR}/rubygem-${PORTNAME}/options
RUN_DEPENDS+= rubygem-gruff>=0.2.8:${PORTSDIR}/graphics/rubygem-gruff
.endif
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
.include <bsd.port.post.mk>