aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-09-19 20:05:36 +0000
committerIon-Mihai Tetcu <itetcu@FreeBSD.org>2009-09-19 20:05:36 +0000
commit4c0562fe1be7c2bf9c0bf9ecfa3dc5ec5765042e (patch)
tree34dcb289873d2e0ba90a8d967665e5efaa0e928d /benchmarks
parent779f4c2a4c71ed739ef0ee5ae8064090ecfdd0ac (diff)
downloadports-4c0562fe1be7c2bf9c0bf9ecfa3dc5ec5765042e.tar.gz
ports-4c0562fe1be7c2bf9c0bf9ecfa3dc5ec5765042e.zip
- Update to 0.9
- use rc.d script - Update MASTER_SITES - use PORTDOCS - USE_LDCONFIG - obey custom PREFIX PR: 138366 Submitted by: Sylvio Cesar Approved by: maintainer Feature safe: yes
Notes
Notes: svn path=/head/; revision=241767
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/thrulay/Makefile28
-rw-r--r--benchmarks/thrulay/distinfo6
-rw-r--r--benchmarks/thrulay/files/thrulayd.sh.sample14
-rw-r--r--benchmarks/thrulay/pkg-message13
-rw-r--r--benchmarks/thrulay/pkg-plist10
5 files changed, 39 insertions, 32 deletions
diff --git a/benchmarks/thrulay/Makefile b/benchmarks/thrulay/Makefile
index c7ba92a3a830..7f56099997f4 100644
--- a/benchmarks/thrulay/Makefile
+++ b/benchmarks/thrulay/Makefile
@@ -5,10 +5,9 @@
# $FreeBSD$
PORTNAME= thrulay
-PORTVERSION= 0.8
+PORTVERSION= 0.9
CATEGORIES= benchmarks net ipv6
-MASTER_SITES= http://unc.dl.sourceforge.net/sourceforge/thrulay/ \
- http://internap.dl.sourceforge.net/sourceforge/thrulay/ \
+MASTER_SITES= SF \
http://www.internet2.edu/~shalunov/thrulay/
MAINTAINER= shalunov@shlang.com
@@ -19,12 +18,25 @@ MAN8= thrulayd.8
MANCOMPRESSED= no
HAS_CONFIGURE= yes
USE_GMAKE= yes
+USE_LDCONFIG= yes
+USE_RC_SUBR= thrulayd
+SUB_FILES= thrulayd
+
+PORTDOCS= ChangeLog README thrulay-protocol.txt thrulay-index.html
+
+post-patch:
+ ${REINPLACE_CMD} -e '922s,datarootdir,prefix,g' ${WRKSRC}/configure
+
+post-extract:
+ @${CP} ${WRKSRC}/doc/*.[ht]* ${WRKSRC}/
post-install:
- ${INSTALL_SCRIPT} ${FILESDIR}/thrulayd.sh.sample ${PREFIX}/etc/rc.d/
- @if [ ! -f ${PREFIX}/etc/rc.d/thrulayd.sh ]; then \
- ${CP} -p ${PREFIX}/etc/rc.d/thrulayd.sh.sample \
- ${PREFIX}/etc/rc.d/thrulayd.sh ; \
- fi
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${docs} ${DOCSDIR}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/benchmarks/thrulay/distinfo b/benchmarks/thrulay/distinfo
index 8cd295be3ab8..a89035f2208c 100644
--- a/benchmarks/thrulay/distinfo
+++ b/benchmarks/thrulay/distinfo
@@ -1,3 +1,3 @@
-MD5 (thrulay-0.8.tar.gz) = 725fb13344608a652e818bcd16fe9ef6
-SHA256 (thrulay-0.8.tar.gz) = f118a16fe95aac3a93d430f5adf6e20d9437b759617b7596077897c5c4bba8b7
-SIZE (thrulay-0.8.tar.gz) = 88881
+MD5 (thrulay-0.9.tar.gz) = e7ada3c0634d2aa688299a434161f5c8
+SHA256 (thrulay-0.9.tar.gz) = 373d5613dfe371f6b4f48fc853f6c27701b2981ba4100388c9881cb802d1780d
+SIZE (thrulay-0.9.tar.gz) = 370312
diff --git a/benchmarks/thrulay/files/thrulayd.sh.sample b/benchmarks/thrulay/files/thrulayd.sh.sample
deleted file mode 100644
index a571253778a9..000000000000
--- a/benchmarks/thrulay/files/thrulayd.sh.sample
+++ /dev/null
@@ -1,14 +0,0 @@
-#!/bin/sh
-
-thrulayd=/usr/local/sbin/thrulayd
-
-case "$1" in
-start)
- [ -x $thrulayd ] && $thrulayd && echo -n ' thrulayd'
- ;;
-*)
- echo "Usage: `basename $0` {start}" >&2
- ;;
-esac
-
-exit 0
diff --git a/benchmarks/thrulay/pkg-message b/benchmarks/thrulay/pkg-message
index c2ab049263de..1945c55b7c40 100644
--- a/benchmarks/thrulay/pkg-message
+++ b/benchmarks/thrulay/pkg-message
@@ -1,4 +1,9 @@
-The package consists of a client (thrulay) and a daemon (thrulayd).
-The thrulay client is usable immediately. The thrulayd deamon needs to be
-started, which will happen automatically in the next boot cycle. You may
-also start it manually by entering thrulayd as root.
+**************************************************************************
+* *
+* The package consists of a client (thrulay) and a daemon (thrulayd). *
+* The thrulay client is usable immediately. *
+* *
+* To run thrulayd from startup, add thrulayd_enable="YES" *
+* in your /etc/rc.conf *
+* *
+**************************************************************************
diff --git a/benchmarks/thrulay/pkg-plist b/benchmarks/thrulay/pkg-plist
index f18066c04eae..616398e7e7d0 100644
--- a/benchmarks/thrulay/pkg-plist
+++ b/benchmarks/thrulay/pkg-plist
@@ -1,5 +1,9 @@
bin/thrulay
sbin/thrulayd
-@unexec if cmp -s %D/etc/rc.d/thrulayd.sh.sample %D/etc/rc.d/thrulayd.sh; then rm -f %D/etc/rc.d/thrulayd.sh; fi
-etc/rc.d/thrulayd.sh.sample
-@exec if [ ! -f %D/etc/rc.d/thrulayd.sh ] ; then cp -p %D/%F %B/thrulayd.sh; fi
+include/thrulay/client.h
+include/thrulay/server.h
+lib/libthrulay.a
+lib/libthrulay.la
+lib/libthrulay.so
+lib/libthrulay.so.0
+@dirrm include/thrulay