aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-07 01:36:46 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-07 01:36:46 +0000
commit7e6a341e652c243b3aa858a9e58a117320174bc3 (patch)
tree6dc4f2f934cbafb6955f2f96ef7eac2a09c18b6f /benchmarks
parent340b0dbddc6de8fb9df4dd73cc9955204ee01a95 (diff)
downloadports-7e6a341e652c243b3aa858a9e58a117320174bc3.tar.gz
ports-7e6a341e652c243b3aa858a9e58a117320174bc3.zip
- Switch to USES=tar
- Switch to options helpers
Notes
Notes: svn path=/head/; revision=398734
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/mdtest/Makefile20
1 files changed, 8 insertions, 12 deletions
diff --git a/benchmarks/mdtest/Makefile b/benchmarks/mdtest/Makefile
index aac1944440aa..a3b72e30c4d0 100644
--- a/benchmarks/mdtest/Makefile
+++ b/benchmarks/mdtest/Makefile
@@ -6,13 +6,13 @@ PORTVERSION= 1.9.3
PORTREVISION= 7
CATEGORIES= benchmarks
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20latest/${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Filesystem metadata benchmark utility
LICENSE= GPLv2
+USES= tar:tgz
NO_WRKSUBDIR= yes
CFLAGS+= -DDarwin
@@ -23,17 +23,13 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= OPENMPI EXAMPLES
OPENMPI_DESC= Use Open MPI instead of MPICH2
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MOPENMPI}
-BUILD_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
-RUN_DEPENDS+= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
-MPICC= ${LOCALBASE}/mpi/openmpi/bin/mpicc
-.else
-BUILD_DEPENDS+= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
-RUN_DEPENDS+= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
-MPICC= ${LOCALBASE}/bin/mpicc
-.endif
+OPENMPI_BUILD_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpicc:${PORTSDIR}/net/openmpi
+OPENMPI_RUN_DEPENDS= ${LOCALBASE}/mpi/openmpi/bin/mpirun:${PORTSDIR}/net/openmpi
+OPENMPI_VARS= MPICC=${LOCALBASE}/mpi/openmpi/bin/mpicc
+
+OPENMPI_BUILD_DEPENDS_OFF= ${LOCALBASE}/bin/mpicc:${PORTSDIR}/net/mpich2
+OPENMPI_RUN_DEPENDS_OFF= ${LOCALBASE}/bin/mpirun:${PORTSDIR}/net/mpich2
+OPENMPI_VARS_OFF= MPICC=${LOCALBASE}/bin/mpicc
do-build:
(cd ${WRKSRC} && ${MPICC} ${CFLAGS} -o ${PORTNAME} ${PORTNAME}.c -lm)