aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorStefan Eßer <se@FreeBSD.org>1996-01-05 16:38:12 +0000
committerStefan Eßer <se@FreeBSD.org>1996-01-05 16:38:12 +0000
commitac16c18c0389d235d2494afaa162e49550820a5b (patch)
treecda688eb73f75e8d70ef472cb209718bb98b65f1 /benchmarks
parentbe7c6b52a696677faa3c24a2e50158b62c739647 (diff)
downloadports-ac16c18c0389d235d2494afaa162e49550820a5b.tar.gz
ports-ac16c18c0389d235d2494afaa162e49550820a5b.zip
Make this run from a R/O /usr file system:
- Temporary files are written into $TMPDIR (default /var/tmp) (some 18MB of free space are required for the file system test). - Results are stored into $RESULTDIR (default /tmp).
Notes
Notes: svn path=/head/; revision=2608
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/bytebench/Makefile14
-rw-r--r--benchmarks/bytebench/files/patch-aa50
-rw-r--r--benchmarks/unixbench/Makefile14
-rw-r--r--benchmarks/unixbench/files/patch-aa50
4 files changed, 112 insertions, 16 deletions
diff --git a/benchmarks/bytebench/Makefile b/benchmarks/bytebench/Makefile
index 98a5fc4ba822..5fa5bf80879a 100644
--- a/benchmarks/bytebench/Makefile
+++ b/benchmarks/bytebench/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 December 1995
# Whom: se
#
-# $Id: Makefile,v 1.1.1.1 1996/01/01 22:57:36 se Exp $
+# $Id: Makefile,v 1.3 1996/01/03 00:06:21 se Exp $
#
DISTNAME= bytebench-3.1
@@ -17,12 +17,12 @@ do-install:
-mkdir -p $(PREFIX)/lib/bytebench
for f in Makefile README Run doc pgms results testdir; \
do cp -R $(WRKSRC)/$$f $(PREFIX)/lib/bytebench; done
- echo "#!/bin/sh" > $(PREFIX)/bin/bytebench
- echo "TMPDIR=/var/tmp" >> $(PREFIX)/bin/bytebench
- echo "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
- echo "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
- echo "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
- echo "exec ./Run" >> $(PREFIX)/bin/bytebench
+ echo "#!/bin/sh" > $(PREFIX)/bin/bytebench
+ echo "TMPDIR=\$${TMPDIR-/var/tmp}" >> $(PREFIX)/bin/bytebench
+ echo "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
+ echo "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
+ echo "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
+ echo "exec ./Run \"\$$@\"" >> $(PREFIX)/bin/bytebench
chmod 755 $(PREFIX)/bin/bytebench
chmod 644 $(PREFIX)/lib/bytebench/Makefile
chmod 644 $(PREFIX)/lib/bytebench/README
diff --git a/benchmarks/bytebench/files/patch-aa b/benchmarks/bytebench/files/patch-aa
index a69d87ddb1b7..ca94d39f53f7 100644
--- a/benchmarks/bytebench/files/patch-aa
+++ b/benchmarks/bytebench/files/patch-aa
@@ -14,7 +14,7 @@
--- 25,34 ----
ID="@(#)Makefile:3.9 -- 5/15/91 19:30:15";
SHELL = /bin/sh
-! HZ = 100
+! HZ = 128
CFLAGS = -DTIME
! OPTON = -s -static -O -m486 -finline-functions -funroll-loops -fomit-frame-pointer
! #optimization on (give it your best shot)
@@ -96,6 +96,27 @@
cd $TMPDIR
TMPDIR=`pwd`
***************
+*** 304,312 ****
+ C)
+ logmsg="C Compiler Test"
+! prog="looper ${looper-60} cc cctest.c"
+ stdout=/dev/null
+ repeat="$shortloop"
+ cleanopt="-m $TMPTIMES"
+! rm -f ${TESTDIR}/cctest.o ${TESTDIR}/a.out
+ ;;
+
+--- 304,312 ----
+ C)
+ logmsg="C Compiler Test"
+! prog="looper ${looper-60} cc cctest.c -o ${TMPDIR}/a.out"
+ stdout=/dev/null
+ repeat="$shortloop"
+ cleanopt="-m $TMPTIMES"
+! rm -f ${TESTDIR}/cctest.o ${TMPDIR}/a.out
+ ;;
+
+***************
*** 418,426 ****
if test "$stdin" = ""
then # without redirected stdin
@@ -115,3 +136,30 @@
fi
###############################################
cd $pwd # move back home
+*** pgms/cleanup.sh.orig Wed Feb 5 11:08:37 1992
+--- pgms/cleanup.sh Wed Jan 3 19:27:21 1996
+***************
+*** 87,92 ****
+
+ -r) : reason for failure
+! echo $1
+! echo $1 >>$LOGFILE
+ shift
+ ;;
+--- 87,92 ----
+
+ -r) : reason for failure
+! echo -e $1
+! echo -e $1 >>$LOGFILE
+ shift
+ ;;
+*** pgms/multi.sh.orig Thu Jan 4 15:16:20 1996
+--- pgms/multi.sh Thu Jan 4 15:17:26 1996
+***************
+*** 15,18 ****
+--- 15,19 ----
+ ###############################################################################
+ ID="@(#)multi.sh:3.4 -- 5/15/91 19:30:24";
++ cd $TMPDIR
+ for i
+ do
diff --git a/benchmarks/unixbench/Makefile b/benchmarks/unixbench/Makefile
index 98a5fc4ba822..5fa5bf80879a 100644
--- a/benchmarks/unixbench/Makefile
+++ b/benchmarks/unixbench/Makefile
@@ -3,7 +3,7 @@
# Date created: 28 December 1995
# Whom: se
#
-# $Id: Makefile,v 1.1.1.1 1996/01/01 22:57:36 se Exp $
+# $Id: Makefile,v 1.3 1996/01/03 00:06:21 se Exp $
#
DISTNAME= bytebench-3.1
@@ -17,12 +17,12 @@ do-install:
-mkdir -p $(PREFIX)/lib/bytebench
for f in Makefile README Run doc pgms results testdir; \
do cp -R $(WRKSRC)/$$f $(PREFIX)/lib/bytebench; done
- echo "#!/bin/sh" > $(PREFIX)/bin/bytebench
- echo "TMPDIR=/var/tmp" >> $(PREFIX)/bin/bytebench
- echo "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
- echo "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
- echo "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
- echo "exec ./Run" >> $(PREFIX)/bin/bytebench
+ echo "#!/bin/sh" > $(PREFIX)/bin/bytebench
+ echo "TMPDIR=\$${TMPDIR-/var/tmp}" >> $(PREFIX)/bin/bytebench
+ echo "RESULTDIR=/tmp" >> $(PREFIX)/bin/bytebench
+ echo "export TMPDIR RESULTDIR" >> $(PREFIX)/bin/bytebench
+ echo "cd $(PREFIX)/lib/bytebench" >> $(PREFIX)/bin/bytebench
+ echo "exec ./Run \"\$$@\"" >> $(PREFIX)/bin/bytebench
chmod 755 $(PREFIX)/bin/bytebench
chmod 644 $(PREFIX)/lib/bytebench/Makefile
chmod 644 $(PREFIX)/lib/bytebench/README
diff --git a/benchmarks/unixbench/files/patch-aa b/benchmarks/unixbench/files/patch-aa
index a69d87ddb1b7..ca94d39f53f7 100644
--- a/benchmarks/unixbench/files/patch-aa
+++ b/benchmarks/unixbench/files/patch-aa
@@ -14,7 +14,7 @@
--- 25,34 ----
ID="@(#)Makefile:3.9 -- 5/15/91 19:30:15";
SHELL = /bin/sh
-! HZ = 100
+! HZ = 128
CFLAGS = -DTIME
! OPTON = -s -static -O -m486 -finline-functions -funroll-loops -fomit-frame-pointer
! #optimization on (give it your best shot)
@@ -96,6 +96,27 @@
cd $TMPDIR
TMPDIR=`pwd`
***************
+*** 304,312 ****
+ C)
+ logmsg="C Compiler Test"
+! prog="looper ${looper-60} cc cctest.c"
+ stdout=/dev/null
+ repeat="$shortloop"
+ cleanopt="-m $TMPTIMES"
+! rm -f ${TESTDIR}/cctest.o ${TESTDIR}/a.out
+ ;;
+
+--- 304,312 ----
+ C)
+ logmsg="C Compiler Test"
+! prog="looper ${looper-60} cc cctest.c -o ${TMPDIR}/a.out"
+ stdout=/dev/null
+ repeat="$shortloop"
+ cleanopt="-m $TMPTIMES"
+! rm -f ${TESTDIR}/cctest.o ${TMPDIR}/a.out
+ ;;
+
+***************
*** 418,426 ****
if test "$stdin" = ""
then # without redirected stdin
@@ -115,3 +136,30 @@
fi
###############################################
cd $pwd # move back home
+*** pgms/cleanup.sh.orig Wed Feb 5 11:08:37 1992
+--- pgms/cleanup.sh Wed Jan 3 19:27:21 1996
+***************
+*** 87,92 ****
+
+ -r) : reason for failure
+! echo $1
+! echo $1 >>$LOGFILE
+ shift
+ ;;
+--- 87,92 ----
+
+ -r) : reason for failure
+! echo -e $1
+! echo -e $1 >>$LOGFILE
+ shift
+ ;;
+*** pgms/multi.sh.orig Thu Jan 4 15:16:20 1996
+--- pgms/multi.sh Thu Jan 4 15:17:26 1996
+***************
+*** 15,18 ****
+--- 15,19 ----
+ ###############################################################################
+ ID="@(#)multi.sh:3.4 -- 5/15/91 19:30:24";
++ cd $TMPDIR
+ for i
+ do