aboutsummaryrefslogtreecommitdiff
path: root/benchmarks
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 17:42:23 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-05-27 17:42:23 +0000
commiteaef815e2a8b63f6efd9a683c5c6be73810d5f68 (patch)
treee6689817d04a128afc77ed6f8aaadc31446b8cd1 /benchmarks
parent0ed6d16f6ec9b867f2e52dadd75734403c48c6a9 (diff)
downloadports-eaef815e2a8b63f6efd9a683c5c6be73810d5f68.tar.gz
ports-eaef815e2a8b63f6efd9a683c5c6be73810d5f68.zip
add iperf
A tool to measure maximum TCP and UDP bandwidth PR: 27462 Submitted by: Pete Fritchman <petef@databits.net>
Notes
Notes: svn path=/head/; revision=43158
Diffstat (limited to 'benchmarks')
-rw-r--r--benchmarks/iperf/Makefile27
-rw-r--r--benchmarks/iperf/distinfo1
-rw-r--r--benchmarks/iperf/files/patch-cfg::Makefile11
-rw-r--r--benchmarks/iperf/files/patch-cfg::configure40
-rw-r--r--benchmarks/iperf/pkg-comment1
-rw-r--r--benchmarks/iperf/pkg-descr9
-rw-r--r--benchmarks/iperf/pkg-plist8
7 files changed, 97 insertions, 0 deletions
diff --git a/benchmarks/iperf/Makefile b/benchmarks/iperf/Makefile
new file mode 100644
index 000000000000..ecdd5dc3bd5b
--- /dev/null
+++ b/benchmarks/iperf/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: iperf
+# Date Created: 20 May 2001
+# Whom: Pete Fritchman <petef@databits.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= iperf
+PORTVERSION= 1.2
+CATEGORIES= net
+MASTER_SITES= http://dast.nlanr.net/Projects/Iperf/
+
+MAINTAINER= petef@databits.net
+
+NO_CDROM= "can't charge a fee for the software"
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/iperf ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${PREFIX}/share/doc/iperf
+.for file in README doc/index.html doc/jperf.gif doc/lib.html doc/release.html \
+ doc/ui_license.html
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/iperf
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/benchmarks/iperf/distinfo b/benchmarks/iperf/distinfo
new file mode 100644
index 000000000000..c6ef0c7d5e94
--- /dev/null
+++ b/benchmarks/iperf/distinfo
@@ -0,0 +1 @@
+MD5 (iperf-1.2.tar.gz) = b727074c779f8f3087dec5e455840201
diff --git a/benchmarks/iperf/files/patch-cfg::Makefile b/benchmarks/iperf/files/patch-cfg::Makefile
new file mode 100644
index 000000000000..01ab09ce0e2c
--- /dev/null
+++ b/benchmarks/iperf/files/patch-cfg::Makefile
@@ -0,0 +1,11 @@
+--- cfg/Makefile.orig Sat May 19 23:54:00 2001
++++ cfg/Makefile Sat May 19 23:54:12 2001
+@@ -31,7 +31,7 @@
+ #
+
+ all: configure
+- ./configure
++ ./configure --cc=${CC} --cxx=${CXX}
+
+ clean:
+ -rm -f $(CLEAN_FILES)
diff --git a/benchmarks/iperf/files/patch-cfg::configure b/benchmarks/iperf/files/patch-cfg::configure
new file mode 100644
index 000000000000..92c8a2e87637
--- /dev/null
+++ b/benchmarks/iperf/files/patch-cfg::configure
@@ -0,0 +1,40 @@
+--- cfg/configure.orig Sat May 19 23:45:26 2001
++++ cfg/configure Sat May 19 23:54:28 2001
+@@ -90,6 +90,12 @@
+ | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
+ cache_file="$ac_optarg" ;;
+
++ --cc=*)
++ ac_cv_prog_CC="$ac_optarg" ;;
++
++ --cxx=*)
++ ac_cv_prog_CXX="$ac_optarg" ;;
++
+ -datadir | --datadir | --datadi | --datad | --data | --dat | --da)
+ ac_prev=datadir ;;
+ -datadir=* | --datadir=* | --datadi=* | --datad=* | --data=* | --dat=* \
+@@ -952,7 +958,7 @@
+ echo $ac_n "checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler""... $ac_c" 1>&6
+ echo "configure:954: checking whether the C++ compiler ($CXX $CXXFLAGS $LDFLAGS) is a cross-compiler" >&5
+ echo "$ac_t""$ac_cv_prog_cxx_cross" 1>&6
+-cross_compiling=$ac_cv_prog_cxx_cross
++cross_compiling="no"
+
+ echo $ac_n "checking whether we are using GNU C++""... $ac_c" 1>&6
+ echo "configure:959: checking whether we are using GNU C++" >&5
+@@ -1065,14 +1071,7 @@
+ echo
+
+
+-if test -z "$ac_cv_use_pthread"; then
+- ac_cv_use_pthread="yes"
+-fi
+-echo "Make iperf multi-threaded (using pthreads)? [$ac_cv_use_pthread] "
+-read tmp
+-if test -n "$tmp"; then
+- ac_cv_use_pthread="$tmp"
+-fi
++ac_cv_use_pthread="no"
+
+
+ if test "$ac_cv_use_pthread" = yes ; then
diff --git a/benchmarks/iperf/pkg-comment b/benchmarks/iperf/pkg-comment
new file mode 100644
index 000000000000..5d78b5a2f384
--- /dev/null
+++ b/benchmarks/iperf/pkg-comment
@@ -0,0 +1 @@
+A tool to measure maximum TCP and UDP bandwidth
diff --git a/benchmarks/iperf/pkg-descr b/benchmarks/iperf/pkg-descr
new file mode 100644
index 000000000000..e930a3b166a8
--- /dev/null
+++ b/benchmarks/iperf/pkg-descr
@@ -0,0 +1,9 @@
+Iperf is a tool for measuring maximum TCP and UDP bandwidth,
+reminiscent of ttcp and nettest. It has been written to overcome
+the shortcomings of those aging tools. Iperf can also test UDP
+bandwidth, loss, and jitter.
+
+WWW: http://dast.nlanr.net/Projects/Iperf/
+
+- Pete
+petef@databits.net
diff --git a/benchmarks/iperf/pkg-plist b/benchmarks/iperf/pkg-plist
new file mode 100644
index 000000000000..08e2333e8b08
--- /dev/null
+++ b/benchmarks/iperf/pkg-plist
@@ -0,0 +1,8 @@
+bin/iperf
+%%PORTDOCS%%share/doc/iperf/README
+%%PORTDOCS%%share/doc/iperf/index.html
+%%PORTDOCS%%share/doc/iperf/jperf.gif
+%%PORTDOCS%%share/doc/iperf/lib.html
+%%PORTDOCS%%share/doc/iperf/release.html
+%%PORTDOCS%%share/doc/iperf/ui_license.html
+%%PORTDOCS%%@dirrm share/doc/iperf