aboutsummaryrefslogtreecommitdiff
path: root/biology/babel
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1997-12-21 21:57:37 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1997-12-21 21:57:37 +0000
commit77daf87099d085bed5b9ce9f9caeb485b7e6607c (patch)
tree74721d0a2370567d1b79a2f9f8ac82eab710c520 /biology/babel
parentcd524aef9707e38b70ed113310793c88d135aade (diff)
downloadports-77daf87099d085bed5b9ce9f9caeb485b7e6607c.tar.gz
ports-77daf87099d085bed5b9ce9f9caeb485b7e6607c.zip
This is a port of a molecular file format converter, babel.
Babel is developed by Dolata Group, Department of Chemistry, University of Arizona and Ohio State University. PR: ports/5215 Submitted by: Frank Chen Hsiung Chan <frankch@waru.life.nthu.edu.tw>
Notes
Notes: svn path=/head/; revision=9147
Diffstat (limited to 'biology/babel')
-rw-r--r--biology/babel/Makefile19
-rw-r--r--biology/babel/distinfo1
-rw-r--r--biology/babel/files/patch-aa24
-rw-r--r--biology/babel/files/patch-ab37
-rw-r--r--biology/babel/pkg-comment1
-rw-r--r--biology/babel/pkg-descr6
-rw-r--r--biology/babel/pkg-plist7
7 files changed, 95 insertions, 0 deletions
diff --git a/biology/babel/Makefile b/biology/babel/Makefile
new file mode 100644
index 000000000000..c6346cd588a3
--- /dev/null
+++ b/biology/babel/Makefile
@@ -0,0 +1,19 @@
+# New ports collection Makefile for: babel
+# Version required: 1.6
+# Date created: Dec 4 1997
+# Whom: frankch@waru.life.nthu.edu.tw
+#
+# $Id$
+#
+
+DISTNAME= babel-1.6
+CATEGORIES= biology
+MASTER_SITES= ftp://ccl.osc.edu/pub/chemistry/software/MAC/babel/
+EXTRACT_SUFX= .tar.Z
+
+MAINTAINER= frankch@waru.life.nthu.edu.tw
+
+post-install:
+ @ ${CAT} ${PKGDIR}/INSTALL
+
+.include <bsd.port.mk>
diff --git a/biology/babel/distinfo b/biology/babel/distinfo
new file mode 100644
index 000000000000..bcd232fdeacb
--- /dev/null
+++ b/biology/babel/distinfo
@@ -0,0 +1 @@
+MD5 (babel-1.6.tar.Z) = 101a5dc4858ecacac123571db52b272e
diff --git a/biology/babel/files/patch-aa b/biology/babel/files/patch-aa
new file mode 100644
index 000000000000..2cbbdf919829
--- /dev/null
+++ b/biology/babel/files/patch-aa
@@ -0,0 +1,24 @@
+--- Makefile.orig Tue Jan 21 23:53:05 1997
++++ Makefile Sat Dec 20 05:12:51 1997
+@@ -1,6 +1,6 @@
+-CFLAGS = -O
++DEST = /usr/local/share/babel
+
+-LIBFLAGS = -O -DLIBRARY
++LIBFLAGS = -DLIBRARY
+
+ CC = cc
+
+@@ -334,7 +334,11 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
+- install -s $(PROGRAM) $(DEST)
++ install -s $(PROGRAM) /usr/local/bin/$(PROGRAM)
++ install -d -o bin -g bin $(DEST)
++ install -c -o bin -g bin README.1ST $(DEST)
++ install -c -o bin -g bin element.lis new.lis $(DEST)
++ install -c -o bin -g bin quanta.lis types.lis $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
+
diff --git a/biology/babel/files/patch-ab b/biology/babel/files/patch-ab
new file mode 100644
index 000000000000..4770277b67e8
--- /dev/null
+++ b/biology/babel/files/patch-ab
@@ -0,0 +1,37 @@
+--- menus.c.orig Thu Dec 4 20:20:28 1997
++++ menus.c Thu Dec 4 20:21:46 1997
+@@ -63,9 +63,9 @@
+ }
+ }
+ printf("Input file name : ");
+- gets(InfileName);
++ fgets(InfileName, BUFF_SIZE - 1, stdin);
+ printf("Keywords : ");
+- gets(InputKeywords);
++ fgets(InputKeywords, BUFF_SIZE - 1, stdin);
+
+ if (strlen(InputKeywords) < 1)
+ strcpy(InputKeywords,"KEYWORDS GO HERE");
+@@ -108,11 +108,11 @@
+ }
+ }
+ printf("Output file name : ");
+- gets(OutfileName);
++ fgets(OutfileName, BUFF_SIZE - 1, stdin);
+ if (has_keywords)
+ {
+ printf("Keywords : ");
+- gets(OutputKeywords);
++ fgets(OutputKeywords, BUFF_SIZE - 1, stdin);
+ if (strlen(OutputKeywords) < 1)
+ strcpy(OutputKeywords,"KEYWORDS GO HERE");
+ }
+@@ -167,7 +167,7 @@
+ while (done == FALSE)
+ {
+ printf("Choice : ");
+- gets(choice_string);
++ fgets(choice_string, 99, stdin);
+ for (i = 0; i < (int) strlen(choice_string); i++)
+ {
+ if (!isdigit(choice_string[i]))
diff --git a/biology/babel/pkg-comment b/biology/babel/pkg-comment
new file mode 100644
index 000000000000..a7633be03ae8
--- /dev/null
+++ b/biology/babel/pkg-comment
@@ -0,0 +1 @@
+Conversion program among various molecular file formats.
diff --git a/biology/babel/pkg-descr b/biology/babel/pkg-descr
new file mode 100644
index 000000000000..7823c5be345e
--- /dev/null
+++ b/biology/babel/pkg-descr
@@ -0,0 +1,6 @@
+Babel is a conversion program which is able to convert among dozens of
+molecular file formats.
+Babel is developed by Dolata Group, Department of Chemistry,
+Arizona University and Ohio State University.
+The homepage of babel could be found at
+ http://mercury.aichem.arizona.edu/babel.html
diff --git a/biology/babel/pkg-plist b/biology/babel/pkg-plist
new file mode 100644
index 000000000000..9acff72a342f
--- /dev/null
+++ b/biology/babel/pkg-plist
@@ -0,0 +1,7 @@
+bin/babel
+share/babel/README.1ST
+share/babel/element.lis
+share/babel/new.lis
+share/babel/quanta.lis
+share/babel/types.lis
+@dirrm share/babel