aboutsummaryrefslogtreecommitdiff
path: root/biology/gperiodic
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2013-06-19 19:05:47 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2013-06-19 19:05:47 +0000
commit6c227ca468397f94ec9dd7eba83f764c66aa7215 (patch)
tree554a70e6631fa7d2ae2b6b3e57d4339239008f4b /biology/gperiodic
parent0ed60a672e536928fa1ad7954eaf7533768f96b7 (diff)
downloadports-6c227ca468397f94ec9dd7eba83f764c66aa7215.tar.gz
ports-6c227ca468397f94ec9dd7eba83f764c66aa7215.zip
. NOPORTDOCS -> PORT_OPTIONS:MDOCS;
. use PORTDOCS at Makefile (thus simplify pkg-plist); . use plain install instead of a .for loop; . trim Makefile headers.
Notes
Notes: svn path=/head/; revision=321310
Diffstat (limited to 'biology/gperiodic')
-rw-r--r--biology/gperiodic/Makefile17
-rw-r--r--biology/gperiodic/pkg-plist4
2 files changed, 9 insertions, 12 deletions
diff --git a/biology/gperiodic/Makefile b/biology/gperiodic/Makefile
index ba4d2e5cd209..c398fc8f2175 100644
--- a/biology/gperiodic/Makefile
+++ b/biology/gperiodic/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: gperiodic
-# Date created: 16 July 1999
-# Whom: Andrey Zakhvatov
-#
+# Created by: Andrey Zakhvatov
# $FreeBSD$
# $MCom: ports/biology/gperiodic/Makefile,v 1.1 2006/09/29 23:42:13 ahze Exp $
@@ -19,6 +16,10 @@ USES= gettext
LANGS= da fr gl it pl ru sv tr
+PORTDOCS= AUTHORS ChangeLog README
+
+OPTIONS_DEFINE= DOCS
+
do-build:
cd ${WRKSRC} && ${CC} ${CFLAGS} `pkg-config --cflags --libs gtk+-2.0` \
gperiodic.c -o gperiodic
@@ -26,6 +27,8 @@ do-build:
cd ${WRKSRC}/po && msgfmt -f -v -o ${lang}.mo ${lang}.po
.endfor
+.include <bsd.port.options.mk>
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gperiodic ${PREFIX}/bin
@${MKDIR} ${PREFIX}/share/applications
@@ -41,11 +44,9 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/po/${lang}.mo \
${PREFIX}/share/locale/${lang}/LC_MESSAGES/${PORTNAME}.mo
.endfor
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
-.for file in AUTHORS ChangeLog README
- ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
-.endfor
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/biology/gperiodic/pkg-plist b/biology/gperiodic/pkg-plist
index 8256232e9780..cf1839f7c641 100644
--- a/biology/gperiodic/pkg-plist
+++ b/biology/gperiodic/pkg-plist
@@ -1,8 +1,5 @@
bin/gperiodic
share/applications/gperiodic.desktop
-%%PORTDOCS%%%%DOCSDIR%%/AUTHORS
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/README
share/locale/da/LC_MESSAGES/gperiodic.mo
share/locale/fr/LC_MESSAGES/gperiodic.mo
share/locale/gl/LC_MESSAGES/gperiodic.mo
@@ -13,5 +10,4 @@ share/locale/sv/LC_MESSAGES/gperiodic.mo
share/locale/tr/LC_MESSAGES/gperiodic.mo
share/pixmaps/gperiodic.png
share/pixmaps/gperiodic-crystal.png
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrmtry share/applications