aboutsummaryrefslogtreecommitdiff
path: root/biology/linux-foldingathome
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-08-28 22:33:45 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-08-28 22:33:45 +0000
commit940da0dc4a25d0ba7fe5face6ba5bace3973dda7 (patch)
tree553157d0bc582a4d715dea2dd2fc5286b3302f24 /biology/linux-foldingathome
parentf20ed2f9f5b5a894bd9adb078a05ae8285239ee1 (diff)
downloadports-940da0dc4a25d0ba7fe5face6ba5bace3973dda7.tar.gz
ports-940da0dc4a25d0ba7fe5face6ba5bace3973dda7.zip
Folding@Home is a distributed computing project -- people from through out the
world download and run software to band together to make one of the largest supercomputers in the world. Every computer makes the project closer to our goals. Folding@Home uses novel computational methods coupled to distributed computing, to simulate problems thousands to millions of times more challenging than previously achieved. WWW: http://folding.standford.edu PR: ports/101235 Submitted by: Yonatan <onatan@gmail.com>
Notes
Notes: svn path=/head/; revision=171590
Diffstat (limited to 'biology/linux-foldingathome')
-rw-r--r--biology/linux-foldingathome/Makefile43
-rw-r--r--biology/linux-foldingathome/distinfo3
-rw-r--r--biology/linux-foldingathome/pkg-descr9
-rw-r--r--biology/linux-foldingathome/scripts/FoldingAtHome5
4 files changed, 60 insertions, 0 deletions
diff --git a/biology/linux-foldingathome/Makefile b/biology/linux-foldingathome/Makefile
new file mode 100644
index 000000000000..ed8878efba18
--- /dev/null
+++ b/biology/linux-foldingathome/Makefile
@@ -0,0 +1,43 @@
+# Ports collection makefile for: foldingathome
+# Date created: 2/8/2006
+# Whom: Yonatan <onatan@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= foldingathome
+PORTVERSION= 5.02
+CATEGORIES= biology
+MASTER_SITES= http://www.stanford.edu/group/pandegroup/release/
+PKGNAMEPREFIX= linux-
+DISTNAME= FAH${PORTVERSION:S/.//}-Linux
+EXTRACT_SUFX= .exe
+
+MAINTAINER= onatan@gmail.com
+COMMENT= Distributed client for Protein Folding
+
+USE_LINUX= yes
+ONLY_FOR_ARCHS= i386 amd64
+REINPLACE_ARGS=
+PLIST_FILES= share/${PORTNAME}/${DISTNAME}${EXTRACT_SUFX} \
+ bin/FoldingAtHome
+PLIST_DIRS= share/${PORTNAME}
+
+do-extract:
+ ${MKDIR} ${WRKSRC}
+ ${CP} ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX} ${WRKSRC}
+
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+ ${CHMOD} 755 ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX}
+
+do-install:
+ ${MKDIR} ${PREFIX}/bin
+ ${REINPLACE_CMD} -e "s|DATADIR|${DATADIR}|" ${SCRIPTDIR}/FoldingAtHome \
+ | ${REINPLACE_CMD} -e "s|BINNAME|${DISTNAME}${EXTRACT_SUFX}|" \
+ > ${PREFIX}/bin/FoldingAtHome
+ ${CHMOD} 755 ${PREFIX}/bin/FoldingAtHome
+ ${MKDIR} ${DATADIR}
+ ${CP} ${WRKSRC}/${DISTNAME}${EXTRACT_SUFX} ${DATADIR}/
+
+.include <bsd.port.mk>
diff --git a/biology/linux-foldingathome/distinfo b/biology/linux-foldingathome/distinfo
new file mode 100644
index 000000000000..2cfac333d0ef
--- /dev/null
+++ b/biology/linux-foldingathome/distinfo
@@ -0,0 +1,3 @@
+MD5 (FAH502-Linux.exe) = 4855e808fb94e6d2c5fde345aea0cdc3
+SHA256 (FAH502-Linux.exe) = 02e2d3665a6e8f8fc89c7751b8faadff6885d34860643bdd4107d92825754d33
+SIZE (FAH502-Linux.exe) = 249236
diff --git a/biology/linux-foldingathome/pkg-descr b/biology/linux-foldingathome/pkg-descr
new file mode 100644
index 000000000000..b9b85bf68f8c
--- /dev/null
+++ b/biology/linux-foldingathome/pkg-descr
@@ -0,0 +1,9 @@
+Folding@Home is a distributed computing project -- people from through out the
+world download and run software to band together to make one of the largest
+supercomputers in the world. Every computer makes the project closer to our
+goals.
+Folding@Home uses novel computational methods coupled to distributed computing,
+to simulate problems thousands to millions of times more challenging than
+previously achieved.
+
+WWW: http://folding.standford.edu
diff --git a/biology/linux-foldingathome/scripts/FoldingAtHome b/biology/linux-foldingathome/scripts/FoldingAtHome
new file mode 100644
index 000000000000..3bd56fcb9f39
--- /dev/null
+++ b/biology/linux-foldingathome/scripts/FoldingAtHome
@@ -0,0 +1,5 @@
+#!/bin/sh
+CURDIR=`pwd`
+cd DATADIR
+nice -n 20 ./BINNAME -freeBSD
+cd $CURDIR