aboutsummaryrefslogtreecommitdiff
path: root/biology/platon
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-19 17:56:05 +0000
commit3e4ed01146cfe2bdca465bd0e4d199341f62a0b6 (patch)
treed573ea09b2bf6be67cb497df199932da9e2707c4 /biology/platon
parent40049f4af2200d0dcf33596508688623fc75f764 (diff)
downloadports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.tar.gz
ports-3e4ed01146cfe2bdca465bd0e4d199341f62a0b6.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Notes
Notes: svn path=/head/; revision=211584
Diffstat (limited to 'biology/platon')
-rw-r--r--biology/platon/Makefile6
-rw-r--r--biology/platon/files/Makefile4
2 files changed, 5 insertions, 5 deletions
diff --git a/biology/platon/Makefile b/biology/platon/Makefile
index 6f6cd353b948..97aa9f5139e0 100644
--- a/biology/platon/Makefile
+++ b/biology/platon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= platon
PORTVERSION= 2007.01.09
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= biology
MASTER_SITES= ftp://xraysoft.chem.uu.nl/pub/unix/
DISTNAME= platon
@@ -20,7 +20,7 @@ COMMENT= Tool for viewing molecular/crystallographic structures
# There is a charge of US$ 5000 for commercial users.
RESTRICTED= free for academic, US$ 5000 for commercial users
-USE_XLIB= yes
+USE_XORG= x11
USE_FORTRAN= yes
# This port only has snapshot archive
@@ -43,7 +43,7 @@ pre-patch:
post-patch:
${CP} ${FILESDIR}/Makefile ${WRKSRC}/Makefile
- ${REINPLACE_CMD} -e "s+%%X11BASE%%+${X11BASE}+" ${WRKSRC}/Makefile
+ ${REINPLACE_CMD} -e "s+%%LOCALBASE%%+${LOCALBASE}+" ${WRKSRC}/Makefile
pre-install:
${STRIP_CMD} ${WRKDIR}/${DISTNAME}/platon
diff --git a/biology/platon/files/Makefile b/biology/platon/files/Makefile
index 4f6ca0bfb445..2cda1996ee01 100644
--- a/biology/platon/files/Makefile
+++ b/biology/platon/files/Makefile
@@ -9,8 +9,8 @@ FOPT= ${FFLAGS}
.else
FOPT= ${FFLAGS} -Nx800 -NL400 -Nn802
.endif
-COPT= ${CFLAGS} -I%%X11BASE%%/include
-LOPT= -L%%X11BASE%%/lib -lX11
+COPT= ${CFLAGS} -I%%LOCALBASE%%/include
+LOPT= -L%%LOCALBASE%%/lib -lX11
all: ${OBJS}
${FC} -o ${TARGET} ${OBJS} ${LOPT}