aboutsummaryrefslogtreecommitdiff
path: root/biology/primer3
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 15:31:09 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-09-17 15:31:09 +0000
commit47be6d4a102ce76c4ab7c5bd371401670dc48fbe (patch)
treed610aeda3aa9c93ce52f697d04937e9c6f49f781 /biology/primer3
parentfe2235cdcede32739ec0008688d6e7500d508c98 (diff)
downloadports-47be6d4a102ce76c4ab7c5bd371401670dc48fbe.tar.gz
ports-47be6d4a102ce76c4ab7c5bd371401670dc48fbe.zip
add primer3 0.9
Primer3 helps to choose primers for PCR reactions PR: 35298 Submitted by: Tony Maher <tonym@biolateral.com.au>
Notes
Notes: svn path=/head/; revision=66513
Diffstat (limited to 'biology/primer3')
-rw-r--r--biology/primer3/Makefile51
-rw-r--r--biology/primer3/distinfo1
-rw-r--r--biology/primer3/pkg-comment1
-rw-r--r--biology/primer3/pkg-descr23
-rw-r--r--biology/primer3/pkg-plist360
5 files changed, 436 insertions, 0 deletions
diff --git a/biology/primer3/Makefile b/biology/primer3/Makefile
new file mode 100644
index 000000000000..077940ab8964
--- /dev/null
+++ b/biology/primer3/Makefile
@@ -0,0 +1,51 @@
+# New ports collection makefile for: primer3
+# Date created: 25 February 2002
+# Whom: Tony Maher <tonym@biolateral.com.au>
+#
+# $FreeBSD$
+#
+
+PORTNAME= primer3
+PORTVERSION= 0.9
+CATEGORIES= biology
+MASTER_SITES= http://www-genome.wi.mit.edu/ftp/distribution/software/
+DISTNAME= ${PORTNAME}_${PORTVERSION:S/./_/}_test
+
+MAINTAINER= tonym@biolateral.com.au
+
+USE_REINPLACE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+CPIO= cpio --quiet -pdum -R
+DOCUMENTS= README example
+CGI_EXAMPLES= primer3_www.cgi primer3_www_help.html \
+ primer3_www_results.cgi primer3_www_results_help.html
+
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's#^CFLAGS.*#CFLAGS += \$$\(CC_OPTS\)#;' \
+ -e 's#CC_OPTS = -g#CC_OPTS =#;' \
+ -e 's#LDFLAGS = -g#LDFLAGS ?=#;' \
+ -e 's#^WHITEHEAD_SPECIFIC_HACK.*##;' \
+ ${WRKDIR}/${DISTNAME}/src/Makefile
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/primer3_core ${PREFIX}/bin/primer3
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/Copyright ${DATADIR}
+.for file in ${CGI_EXAMPLES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DATADIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOCUMENTS}
+ @${INSTALL_DATA} ${WRKDIR}/${DISTNAME}/${file} ${DOCSDIR}
+.endfor
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKDIR}/${DISTNAME}/test && ${FIND} * | \
+ ${CPIO} ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+.endif
+
+post-install:
+ @${CAT} ${DATADIR}/Copyright
+
+.include <bsd.port.mk>
diff --git a/biology/primer3/distinfo b/biology/primer3/distinfo
new file mode 100644
index 000000000000..dfbb2a6526b0
--- /dev/null
+++ b/biology/primer3/distinfo
@@ -0,0 +1 @@
+MD5 (primer3_0_9_test.tar.gz) = 1ae09013c982eb67953cc4dd5b837088
diff --git a/biology/primer3/pkg-comment b/biology/primer3/pkg-comment
new file mode 100644
index 000000000000..cdae8a3feb94
--- /dev/null
+++ b/biology/primer3/pkg-comment
@@ -0,0 +1 @@
+Primer3 helps to choose primers for PCR reactions
diff --git a/biology/primer3/pkg-descr b/biology/primer3/pkg-descr
new file mode 100644
index 000000000000..d2f5b37e65fb
--- /dev/null
+++ b/biology/primer3/pkg-descr
@@ -0,0 +1,23 @@
+"Primer3 is a complete rewrite of the original PRIMER program
+(Primer 0.5), written by Steve Lincoln, Mark Daly, and Eric
+Lander. See DIFFERENCES FROM EARLIER VERSIONS for a discussion
+of how Primer3 differs from its predecessors, Primer 0.5 and
+Primer v2.
+
+Primer3 picks primers for PCR reactions, considering as criteria:
+
+o oligonucleotide melting temperature, size, GC content,
+ and primer-dimer possibilities,
+o PCR product size,
+o positional constraints within the source sequence, and
+o miscellaneous other constraints.
+
+All of these criteria are user-specifiable as constraints, and
+some are specifiable as terms in an objective function that
+characterizes an optimal primer pair."
+- from the README file
+
+WWW: http://www-genome.wi.mit.edu/genome_software/other/primer3.html
+
+--
+Tony Maher <tonym@biolateral.com.au>
diff --git a/biology/primer3/pkg-plist b/biology/primer3/pkg-plist
new file mode 100644
index 000000000000..5a1733ccc9c0
--- /dev/null
+++ b/biology/primer3/pkg-plist
@@ -0,0 +1,360 @@
+%%PORTDOCS%%share/doc/primer3/README
+%%PORTDOCS%%share/doc/primer3/example
+%%PORTDOCS%%share/examples/primer3/dpal_gen.pl
+%%PORTDOCS%%share/examples/primer3/dpal_input
+%%PORTDOCS%%share/examples/primer3/dpal_long_input
+%%PORTDOCS%%share/examples/primer3/dpal_long_score_output
+%%PORTDOCS%%share/examples/primer3/dpal_output
+%%PORTDOCS%%share/examples/primer3/dpal_score_output
+%%PORTDOCS%%share/examples/primer3/dpal_test.pl
+%%PORTDOCS%%share/examples/primer3/long_seq_input
+%%PORTDOCS%%share/examples/primer3/long_seq_output
+%%PORTDOCS%%share/examples/primer3/not_for_production.lib
+%%PORTDOCS%%share/examples/primer3/primer1_input
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/AGAG.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/AGAG.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-02.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-02.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-03.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-03.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-06.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-06.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-19.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-19.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-21.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP01-21.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP04-07.txt.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/SP04-07.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/included_test.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/included_test.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/included_test_w_middle.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/included_test_w_middle.int
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/long_seq.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/included_test_w_middle.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/long_seq.rev
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/targets_test.for
+%%PORTDOCS%%share/examples/primer3/primer1_list_last/targets_test.rev
+%%PORTDOCS%%share/examples/primer3/primer1_output
+%%PORTDOCS%%share/examples/primer3/primer_boundary1_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_boundary1_input
+%%PORTDOCS%%share/examples/primer3/primer_boundary1_output
+%%PORTDOCS%%share/examples/primer3/primer_boundary_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_boundary_input
+%%PORTDOCS%%share/examples/primer3/primer_boundary_output
+%%PORTDOCS%%share/examples/primer3/primer_check_input
+%%PORTDOCS%%share/examples/primer3/primer_check_output
+%%PORTDOCS%%share/examples/primer3/primer_end_pathology_input
+%%PORTDOCS%%share/examples/primer3/primer_end_pathology_output
+%%PORTDOCS%%share/examples/primer3/primer_global_err/MAX_PRIMER_LENGTH.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_dna_conc.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_4.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_4.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_salt_conc.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_product_size.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/gc_clamp_min_size.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/incorrect_task.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_gc_content_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_limit_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mishyb_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mispr_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no=.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no_terminal=.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size_int.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pair_mispr.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pr_gc_content_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_size_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_tm_obj_fn.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err4.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err5.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err6.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err4.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err5.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err6.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality1.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality2.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality3.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality4.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/too_many_product_sizes.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_min_size.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_num_return.in
+%%PORTDOCS%%share/examples/primer3/primer_global_err/MAX_PRIMER_LENGTH.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_dna_conc.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_4.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_4.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_salt_conc.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_product_size.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/gc_clamp_min_size.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/incorrect_task.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_gc_content_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_limit_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mishyb_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mispr_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no=.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no_terminal=.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size_int.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pair_mispr.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pr_gc_content_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_size_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_tm_obj_fn.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err4.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err5.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err6.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err4.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err5.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err6.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality1.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality2.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality3.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality4.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/too_many_product_sizes.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_min_size.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_num_return.out
+%%PORTDOCS%%share/examples/primer3/primer_global_err/MAX_PRIMER_LENGTH.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_dna_conc.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_float_4.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_gc_int_3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_num_ns_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_product_sizes_4.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_salt_conc.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_any_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/bad_self_end_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/empty_product_size.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/gc_clamp_min_size.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/incorrect_task.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_gc_content_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/io_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_min_tm_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_opt_tm_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_limit_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/max_size_min_product_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/min_opt_tm_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mishyb_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/mispr_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no=.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/no_terminal=.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_max_size_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/opt_min_size_int.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pair_mispr.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/pr_gc_content_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_size_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/product_tm_obj_fn.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err4.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err5.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_err6.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err4.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err5.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/repeat_lib_int_err6.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality1.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality2.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality3.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/seq_quality4.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/too_many_product_sizes.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_min_size.out2
+%%PORTDOCS%%share/examples/primer3/primer_global_err/zero_num_return.out2
+%%PORTDOCS%%share/examples/primer3/primer_human_input
+%%PORTDOCS%%share/examples/primer3/primer_human_output
+%%PORTDOCS%%share/examples/primer3/primer_input
+%%PORTDOCS%%share/examples/primer3/primer_internal1_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_internal1_input
+%%PORTDOCS%%share/examples/primer3/primer_internal1_output
+%%PORTDOCS%%share/examples/primer3/primer_internal_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_internal_input
+%%PORTDOCS%%share/examples/primer3/primer_internal_output
+%%PORTDOCS%%share/examples/primer3/primer_list_last/AGAG.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/AGAG.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-02.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-02.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-03.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-03.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat1.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat1.int
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat1.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat2.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat2.int
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat2.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat3.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat3.int
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06-with-repeat3.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-06.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-19.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-19.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-21.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP01-21.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP04-07.txt.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/SP04-07.txt.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/case_problem_test.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/case_problem_test.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/included_test.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/included_test.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/included_test_w_middle.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/included_test_w_middle.int
+%%PORTDOCS%%share/examples/primer3/primer_list_last/included_test_w_middle.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/long_seq.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/long_seq.rev
+%%PORTDOCS%%share/examples/primer3/primer_list_last/targets_test.for
+%%PORTDOCS%%share/examples/primer3/primer_list_last/targets_test.rev
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary1_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary1_input
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary1_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary2_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary2_input
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_boundary2_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_input
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_long_lib_input
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_long_lib_output
+%%PORTDOCS%%share/examples/primer3/primer_mispriming_output
+%%PORTDOCS%%share/examples/primer3/primer_must_use_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_must_use_input
+%%PORTDOCS%%share/examples/primer3/primer_must_use_output
+%%PORTDOCS%%share/examples/primer3/primer_num_best_input
+%%PORTDOCS%%share/examples/primer3/primer_num_best_output
+%%PORTDOCS%%share/examples/primer3/primer_obj_fn_input
+%%PORTDOCS%%share/examples/primer3/primer_obj_fn_output
+%%PORTDOCS%%share/examples/primer3/primer_output
+%%PORTDOCS%%share/examples/primer3/primer_position_penalty_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_position_penalty_input
+%%PORTDOCS%%share/examples/primer3/primer_position_penalty_output
+%%PORTDOCS%%share/examples/primer3/primer_quality_boundary_input
+%%PORTDOCS%%share/examples/primer3/primer_quality_boundary_output
+%%PORTDOCS%%share/examples/primer3/primer_rat_input
+%%PORTDOCS%%share/examples/primer3/primer_rat_output
+%%PORTDOCS%%share/examples/primer3/primer_repeat_boundary1_lib
+%%PORTDOCS%%share/examples/primer3/primer_repeat_boundary2_lib
+%%PORTDOCS%%share/examples/primer3/primer_repeat_long_lib
+%%PORTDOCS%%share/examples/primer3/primer_start_codon_input
+%%PORTDOCS%%share/examples/primer3/primer_start_codon_output
+%%PORTDOCS%%share/examples/primer3/primer_syntax_input
+%%PORTDOCS%%share/examples/primer3/primer_syntax_output
+%%PORTDOCS%%share/examples/primer3/primer_task_formated_output
+%%PORTDOCS%%share/examples/primer3/primer_task_input
+%%PORTDOCS%%share/examples/primer3/primer_task_output
+%%PORTDOCS%%share/examples/primer3/primer_test.pl
+%%PORTDOCS%%share/examples/primer3/repeat_lib1
+%%PORTDOCS%%share/examples/primer3/repeat_lib2
+%%PORTDOCS%%share/examples/primer3/repeat_lib3
+%%PORTDOCS%%share/examples/primer3/repeat_lib4
+%%PORTDOCS%%share/examples/primer3/repeat_lib5
+%%PORTDOCS%%share/examples/primer3/repeat_lib6
+bin/primer3
+share/primer3/Copyright
+share/primer3/primer3_www.cgi
+share/primer3/primer3_www_help.html
+share/primer3/primer3_www_results.cgi
+share/primer3/primer3_www_results_help.html
+@dirrm share/primer3
+%%PORTDOCS%%@dirrm share/doc/primer3/
+%%PORTDOCS%%@dirrm share/examples/primer3/primer1_list_last
+%%PORTDOCS%%@dirrm share/examples/primer3/primer1_list_tmp
+%%PORTDOCS%%@dirrm share/examples/primer3/primer_global_err
+%%PORTDOCS%%@dirrm share/examples/primer3/primer_list_last
+%%PORTDOCS%%@dirrm share/examples/primer3/primer_list_tmp
+%%PORTDOCS%%@dirrm share/examples/primer3/