aboutsummaryrefslogtreecommitdiff
path: root/biology/rasmol/Makefile
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2001-09-06 21:25:13 +0000
committerAnton Berezin <tobez@FreeBSD.org>2001-09-06 21:25:13 +0000
commitfc3d9f848215142c094f1c3cac9fa96740f4ce02 (patch)
tree4abba9be2640801108503d16757a7526f2868ed9 /biology/rasmol/Makefile
parenta7d4f95817d12febf33635e7e722a2d2217dd571 (diff)
downloadports-fc3d9f848215142c094f1c3cac9fa96740f4ce02.tar.gz
ports-fc3d9f848215142c094f1c3cac9fa96740f4ce02.zip
Make biology/rasmol work at all color depths.
PR: 30406 Submitted by: Glenn Johnson <gjohnson@srrc.ars.usda.gov>
Notes
Notes: svn path=/head/; revision=47480
Diffstat (limited to 'biology/rasmol/Makefile')
-rw-r--r--biology/rasmol/Makefile29
1 files changed, 21 insertions, 8 deletions
diff --git a/biology/rasmol/Makefile b/biology/rasmol/Makefile
index 62792838e29d..32f73ae06619 100644
--- a/biology/rasmol/Makefile
+++ b/biology/rasmol/Makefile
@@ -7,22 +7,35 @@
PORTNAME= rasmol
PORTVERSION= 2.7.2
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= ftp://ftp.bernstein-plus-sons.com/software/RasMol_2.7.2/
DISTNAME= RasMol
MAINTAINER= ports@FreeBSD.org
-WRKSRC= $(WRKDIR)/RasMol_2.7.2/src/
-USE_IMAKE= yes
+WRKSRC= ${WRKDIR}/RasMol_2.7.2/src
+
+USE_X_PREFIX= yes
+
+.if ${XFREE86_VERSION} == 3
+BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake
+.elif ${XFREE86_VERSION} == 4
+BUILD_DEPENDS+= imake:${PORTSDIR}/devel/imake-4
+.endif
MAN1= rasmol.1
-pre-extract:
- @${ECHO} ""
- @${ECHO} You can set the color depth to match your X server in
- @${ECHO} ${WRKSRC}Imakefile
- @${ECHO} before building.
- @${ECHO} ""
+do-build:
+ ${SETENV} ${SCRIPTS_ENV} ${SH} ${SCRIPTDIR}/build_viewer
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/rasmol-* ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${FILESDIR}/rasmol ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/rasmol.man ${PREFIX}/man/man1/rasmol.1
+ ${MKDIR} ${PREFIX}/lib/X11/rasmol
+ ${INSTALL_DATA} ${WRKSRC}/rasmol.hlp ${PREFIX}/lib/X11/rasmol
+ ${INSTALL_DATA} ${WRKSRC}/../data/1crn.pdb ${PREFIX}/lib/X11/rasmol
+ ${INSTALL_DATA} ${WRKSRC}/../data/3cro.pdb ${PREFIX}/lib/X11/rasmol
.include <bsd.port.mk>