aboutsummaryrefslogtreecommitdiff
path: root/biology/ruby-bio
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2013-03-18 06:55:42 +0000
committerJason Helfman <jgh@FreeBSD.org>2013-03-18 06:55:42 +0000
commit3005e8f2fccb1d1a12c544cd4f7a38c9576bdf3e (patch)
treebd5841693140a6f5e534b27f03c757193470dd6a /biology/ruby-bio
parent4153f3e96b9ed9f7defd4e0d8c02bc3d6dd051aa (diff)
downloadports-3005e8f2fccb1d1a12c544cd4f7a38c9576bdf3e.tar.gz
ports-3005e8f2fccb1d1a12c544cd4f7a38c9576bdf3e.zip
- adoption of optionsNG
- trim historical header Approved by: portmgr (miwi)
Notes
Notes: svn path=/head/; revision=314532
Diffstat (limited to 'biology/ruby-bio')
-rw-r--r--biology/ruby-bio/Makefile27
1 files changed, 12 insertions, 15 deletions
diff --git a/biology/ruby-bio/Makefile b/biology/ruby-bio/Makefile
index fc7d5bd7565b..436a34aff152 100644
--- a/biology/ruby-bio/Makefile
+++ b/biology/ruby-bio/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: BioRuby
-# Date created: 24 October 2001
-# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
-#
+# Created by: Akinori MUSHA aka knu <knu@idaemons.org>
# $FreeBSD$
-#
PORTNAME= bio
PORTVERSION= 1.4.1
@@ -16,27 +12,28 @@ DIST_SUBDIR= ruby
MAINTAINER= mauricio@arareko.net
COMMENT= Integrated environment for Bioinformatics written in Ruby
-OPTIONS= XMLPARSER "xmlparser support for faster Blast processing" off \
- BDB4 "bdb4 support for faster flat file indexing" off \
- MYSQL "MySQL database support for BioSQL" off \
- PGSQL "PostgreSQL database support for BioSQL" off
+OPTIONS_DEFINE= XMLPARSER BDB4 MYSQL PGSQL
+XMLPARSER_DESC= xmlparser support for faster Blast processing
+BDB4_DESC= bdb4 support for faster flat file indexing
+
OPTIONSFILE= ${PORT_DBDIR}/ruby-${PORTNAME}/options
USE_RUBY= yes
USE_RUBY_SETUP= yes
.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_XMLPARSER)
+.if ${PORT_OPTIONS:MXMLPARSER}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/xmlparser.so:${PORTSDIR}/textproc/ruby-xmlparser
.endif
-.if defined(WITH_BDB4)
+.if ${PORT_OPTIONS:MBDB4}
RUN_DEPENDS+= ${RUBY_SITEARCHLIBDIR}/bdb.so:${PORTSDIR}/databases/ruby-bdb
.endif
-.if defined(WITH_MYSQL)
+.if ${PORT_OPTIONS:MMYSQL}
RUN_DEPENDS+= ${RUBY_SITELIBDIR}/DBD/Mysql/Mysql.rb:${PORTSDIR}/databases/ruby-dbd_mysql
.endif
-.if defined(WITH_PGSQL)
+.if ${PORT_OPTIONS:MPGSQL}
RUN_DEPENDS+= ${RUBY_SITELIBDIR}/DBD/Pg/Pg.rb:${PORTSDIR}/databases/ruby-dbd_pg
.endif
@@ -53,11 +50,11 @@ do-install:
${CP} -p ${PREFIX}/${f}.sample ${PREFIX}/${f}; \
fi
.endfor
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/sample/ ${RUBY_MODEXAMPLESDIR}/
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${RUBY_MODDOCDIR}/ja
${INSTALL_DATA} ${WRKSRC}/ChangeLog ${WRKSRC}/README.rdoc ${RUBY_MODDOCDIR}/
${INSTALL_DATA} ${WRKSRC}/doc/*.rd ${RUBY_MODDOCDIR}/