aboutsummaryrefslogtreecommitdiff
path: root/biology/seaview
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>1997-12-21 22:04:39 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>1997-12-21 22:04:39 +0000
commit9e9c823ade90a7037d5758bf240b24e3cc064003 (patch)
treef344a3171170363d0897b89bd54caaee665b715d /biology/seaview
parent862cbba9c792f834ae1bed81f86455fd59ea1aa4 (diff)
downloadports-9e9c823ade90a7037d5758bf240b24e3cc064003.tar.gz
ports-9e9c823ade90a7037d5758bf240b24e3cc064003.zip
Seaview is a multiple DNA sequence alignment editor.
It is capable of align DNA sequences from various organisms and assign their position in the phylogenic tree. PR: ports/5229 Submitted by: Frank Chen Hsiung Chan <frankch@waru.life.nthu.edu.tw>
Notes
Notes: svn path=/head/; revision=9150
Diffstat (limited to 'biology/seaview')
-rw-r--r--biology/seaview/Makefile31
-rw-r--r--biology/seaview/distinfo1
-rw-r--r--biology/seaview/files/patch-aa20
-rw-r--r--biology/seaview/pkg-comment1
-rw-r--r--biology/seaview/pkg-descr16
-rw-r--r--biology/seaview/pkg-plist3
6 files changed, 72 insertions, 0 deletions
diff --git a/biology/seaview/Makefile b/biology/seaview/Makefile
new file mode 100644
index 000000000000..b08dd0919015
--- /dev/null
+++ b/biology/seaview/Makefile
@@ -0,0 +1,31 @@
+# New ports collection Makefile for: seaview
+# Version required: 1.0
+# Date created: Dec 5 1997
+# Whom: frankch@waru.life.nthu.edu.tw
+#
+# $Id$
+#
+
+DISTNAME= seaview
+PKGNAME= seaview-1.0
+CATEGORIES= biology x11
+MASTER_SITES= ftp://biom3.univ-lyon1.fr/pub/mol_phylogeny/seaview/
+EXTRACT_SUFX= .tar
+
+MAINTAINER= frankch@waru.life.nthu.edu.tw
+
+LIB_DEPEND= xforms\\.0\\.:${PORTSDIR}/x11/xforms
+
+USE_X11= YES
+NO_WRKSUBDIR= YES
+EXTRACT_BEFORE_ARGS= -xf
+
+do-install:
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+ @ (mkdir ${PREFIX}/lib/X11/seaview)
+ @ ${INSTALL_DATA} ${WRKSRC}/seaview.help ${PREFIX}/lib/X11/seaview
+
+post-install:
+ @ ${CAT} ${PKGDIR}/DESCR
+
+.include <bsd.port.mk>
diff --git a/biology/seaview/distinfo b/biology/seaview/distinfo
new file mode 100644
index 000000000000..6314b12682db
--- /dev/null
+++ b/biology/seaview/distinfo
@@ -0,0 +1 @@
+MD5 (seaview.tar) = 15ccf55fb21fe06a01862a1b963640c5
diff --git a/biology/seaview/files/patch-aa b/biology/seaview/files/patch-aa
new file mode 100644
index 000000000000..3e326a80032b
--- /dev/null
+++ b/biology/seaview/files/patch-aa
@@ -0,0 +1,20 @@
+--- Makefile.orig Fri Dec 5 13:22:24 1997
++++ Makefile Fri Dec 5 13:20:45 1997
+@@ -0,0 +1,17 @@
++#matpt.h
++#seaview.h
++CC = gcc
++CFLAGS+= -I/usr/X11R6/include
++LIBS = -L/usr/X11R6/lib -lxforms -lX11 -lm
++SRCS = align.c load_seq.c regions.c seaview.c use_mase_files.c xfmatpt.c
++OBJS = align.o load_seq.o regions.o seaview.o use_mase_files.o xfmatpt.o
++
++all: seaview
++
++seaview: $(OBJS)
++ $(CC) -o seaview $(OBJS) $(LIBS)
++
++c.o.: $(SRCS)
++ $(CC) $(CFLAGS) -c $(SRCS)
++
++
diff --git a/biology/seaview/pkg-comment b/biology/seaview/pkg-comment
new file mode 100644
index 000000000000..624e358fd953
--- /dev/null
+++ b/biology/seaview/pkg-comment
@@ -0,0 +1 @@
+Multiple DNA sequence alignment editor
diff --git a/biology/seaview/pkg-descr b/biology/seaview/pkg-descr
new file mode 100644
index 000000000000..e45ecb6c6f97
--- /dev/null
+++ b/biology/seaview/pkg-descr
@@ -0,0 +1,16 @@
+Seaview is a multiple DNA sequence alignment editor.
+You can align DNA sequences from several organisms, and find out their
+relative postions in phylogenic tree.
+
+File test.mase can be used as an example file.
+Open the on-line help window through button 'Help' to learn seaview usage.
+
+The HomePage of seaview is at
+ http://acnuc.univ-lyon1.fr/phylogeny/seaview.html
+
+*****************************************************************************
+* The help file (seaview.help) is located in /usr/X11R6/lib/X11/seaview/ .
+* Add an entry in your Xresources or Xdefaults file with:
+*
+* seaview*helpfile: /usr/X11R6/lib/X11/seaview/seaview.help
+*****************************************************************************
diff --git a/biology/seaview/pkg-plist b/biology/seaview/pkg-plist
new file mode 100644
index 000000000000..b4a419f0bd9f
--- /dev/null
+++ b/biology/seaview/pkg-plist
@@ -0,0 +1,3 @@
+bin/seaview
+lib/X11/seaview/seaview.help
+@dirrm lib/X11/seaview