aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-03-15 10:26:12 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-03-15 10:26:12 +0000
commit0694735737dbc60d44107eef0b44c0c5256541d6 (patch)
treec9ee3b3a044d173e471932f4e5f508c47b7bfe0b /biology
parentbfe1c1f2602aa83afd3a37e632891b90666d73c7 (diff)
downloadports-0694735737dbc60d44107eef0b44c0c5256541d6.tar.gz
ports-0694735737dbc60d44107eef0b44c0c5256541d6.zip
Add blat 33, a fast tool for local sequence similarity searches.
PR: ports/93060 Submitted by: Fernan Aguero <fernan@iib.unsam.edu.ar>
Notes
Notes: svn path=/head/; revision=157190
Diffstat (limited to 'biology')
-rw-r--r--biology/Makefile1
-rw-r--r--biology/blat/Makefile57
-rw-r--r--biology/blat/distinfo3
-rw-r--r--biology/blat/files/pkg-message.in8
-rw-r--r--biology/blat/pkg-descr14
-rw-r--r--biology/blat/pkg-plist17
6 files changed, 100 insertions, 0 deletions
diff --git a/biology/Makefile b/biology/Makefile
index a16c682cf739..f8ecae099be7 100644
--- a/biology/Makefile
+++ b/biology/Makefile
@@ -13,6 +13,7 @@
SUBDIR += blast
SUBDIR += clustalw
SUBDIR += coalesce
+ SUBDIR += blat
SUBDIR += chemeq
SUBDIR += crimap
SUBDIR += distribfold
diff --git a/biology/blat/Makefile b/biology/blat/Makefile
new file mode 100644
index 000000000000..8e96c552e4d9
--- /dev/null
+++ b/biology/blat/Makefile
@@ -0,0 +1,57 @@
+# ex:ts=8
+# New ports collection makefile for: blat
+# Date created: 08 Dec 2005
+# Whom: Fernan Aguero <fernan@iib.unsam.edu.ar>
+#
+# $FreeBSD$
+#
+
+PORTNAME= blat
+PORTVERSION= 33
+CATEGORIES= biology
+MASTER_SITES= http://www.soe.ucsc.edu/~kent/src/
+DISTNAME= ${PORTNAME}Src${PORTVERSION}
+
+MAINTAINER= fernan@iib.unsam.edu.ar
+COMMENT= A fast tool for local sequence similarity searches
+
+USE_ZIP= yes
+USE_GMAKE= yes
+USE_GCC= 3.4+
+MAKEFILE= makefile
+WRKSRC= ${WRKDIR}/${PORTNAME}Src
+MAKE_ENV+= HOME="${WRKSRC}/${BINDIR}"
+
+SUB_FILES= pkg-message
+
+EXECUTABLES= blat faToNib faToTwoBit gfClient gfServer nibFrag \
+ pslPretty pslReps pslSort twoBitInfo twoBitToFa
+
+.include <bsd.port.pre.mk>
+
+post-patch:
+ @${MKDIR} ${WRKSRC}/bin/${MACHTYPE}
+ @${MKDIR} ${WRKSRC}/lib/${MACHTYPE}
+ @${REINPLACE_CMD} -E 's,^(CC|CFLAGS)=,\1 ?=,g' \
+ ${WRKSRC}/inc/common.mk
+.if ${OSVERSION} <= 500000
+ @${REINPLACE_CMD} -e 's,strtof,\(float\) strtod,g' \
+ ${WRKSRC}/lib/sqlNum.c
+.endif
+
+do-install:
+.for exe in ${EXECUTABLES}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${MACHTYPE}/${exe} ${PREFIX}/bin
+.endfor
+ ${MKDIR} ${DATADIR}/webBlat
+ ${INSTALL_PROGRAM} ${WRKSRC}/webBlat/webBlat ${DATADIR}/webBlat
+ ${INSTALL_DATA} ${WRKSRC}/webBlat/install.txt ${DATADIR}/webBlat
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>
diff --git a/biology/blat/distinfo b/biology/blat/distinfo
new file mode 100644
index 000000000000..aa2a1eab4db8
--- /dev/null
+++ b/biology/blat/distinfo
@@ -0,0 +1,3 @@
+MD5 (blatSrc33.zip) = 5f9d3a4a88e57dfc435b5dd465209918
+SHA256 (blatSrc33.zip) = 4ca932721f529d815e64b51940c94d8136faec52c6b8bf8c3fcd3706337d9a29
+SIZE (blatSrc33.zip) = 1308517
diff --git a/biology/blat/files/pkg-message.in b/biology/blat/files/pkg-message.in
new file mode 100644
index 000000000000..f31a1930a57f
--- /dev/null
+++ b/biology/blat/files/pkg-message.in
@@ -0,0 +1,8 @@
+===============================================================================
+
+ A CGI script (webBlat) and instructions on how to set up a BLAT web server
+ have been installed in
+
+ %%DATADIR%%
+
+===============================================================================
diff --git a/biology/blat/pkg-descr b/biology/blat/pkg-descr
new file mode 100644
index 000000000000..e6d996a232e2
--- /dev/null
+++ b/biology/blat/pkg-descr
@@ -0,0 +1,14 @@
+BLAT is a bioinformatics software tool which performs rapid mRNA/DNA
+and cross-species protein alignments. BLAT is more accurate and 500
+times faster than popular existing tools for mRNA/DNA alignments and 50
+times faster for protein alignments at sensitivity settings typically
+used when comparing vertebrate sequences. (Source: Kent, W.J. 2002. BLAT
+-- The BLAST-Like Alignment Tool. Genome Research 4: 656-664.
+http://dx.doi.org/10.1101/gr.229202)
+
+BLAT is not BLAST. DNA BLAT works by keeping an index of the entire
+genome (but not the genome itself) in memory. Since the index takes up a
+bit less than a gigabyte of RAM, BLAT can deliver high performance on a
+reasonably priced Linux box.
+
+WWW: http://www.genomeblat.com
diff --git a/biology/blat/pkg-plist b/biology/blat/pkg-plist
new file mode 100644
index 000000000000..d87a4966eeb8
--- /dev/null
+++ b/biology/blat/pkg-plist
@@ -0,0 +1,17 @@
+bin/blat
+bin/faToNib
+bin/faToTwoBit
+bin/gfClient
+bin/gfServer
+bin/nibFrag
+bin/pslPretty
+bin/pslReps
+bin/pslSort
+bin/twoBitInfo
+bin/twoBitToFa
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%DATADIR%%/webBlat/webBlat
+%%DATADIR%%/webBlat/install.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%DATADIR%%/webBlat
+@dirrm %%DATADIR%%