aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorJohann Visagie <wjv@FreeBSD.org>2002-03-22 08:23:22 +0000
committerJohann Visagie <wjv@FreeBSD.org>2002-03-22 08:23:22 +0000
commit5e52a21fed46877de193d73887a7f37adb4194f6 (patch)
tree6773244dda04ef082eb3a816a708b146ebda25ed /biology
parentcbde27d2e24878fc40d9e7dbb58ab124fc895c3c (diff)
downloadports-5e52a21fed46877de193d73887a7f37adb4194f6.tar.gz
ports-5e52a21fed46877de193d73887a7f37adb4194f6.zip
- Fix certain mistakes in FreeBSD patches
- Bump PORTREVISION - Poroblem originally reported by Fernan Aguero <fernan@iib.unsam.edu.ar> on FreeBSD-bio list PR: 36169 Submitted by: David A. Bader <dbader@eece.unm.edu> (MAINTAINER)
Notes
Notes: svn path=/head/; revision=56444
Diffstat (limited to 'biology')
-rw-r--r--biology/clustalw/Makefile1
-rw-r--r--biology/clustalw/files/patch-ac63
-rw-r--r--biology/clustalw/files/patch-ae138
-rw-r--r--biology/clustalw/files/patch-af11
-rw-r--r--biology/clustalw/files/patch-ag128
-rw-r--r--biology/clustalw/files/patch-ah11
-rw-r--r--biology/clustalw/files/patch-ai11
-rw-r--r--biology/clustalw/files/patch-aj (renamed from biology/clustalw/files/patch-ad)27
8 files changed, 320 insertions, 70 deletions
diff --git a/biology/clustalw/Makefile b/biology/clustalw/Makefile
index 384f12477c37..3645df9e280f 100644
--- a/biology/clustalw/Makefile
+++ b/biology/clustalw/Makefile
@@ -7,6 +7,7 @@
PORTNAME= clustalw
PORTVERSION= 1.82
+PORTREVISION= 1
CATEGORIES= biology
MASTER_SITES= ftp://ftp-igbmc.u-strasbg.fr/pub/ClustalW/
DISTNAME= ${PORTNAME}${PORTVERSION}.UNIX
diff --git a/biology/clustalw/files/patch-ac b/biology/clustalw/files/patch-ac
index 9ac14ac11427..fc4431f3b68f 100644
--- a/biology/clustalw/files/patch-ac
+++ b/biology/clustalw/files/patch-ac
@@ -9,66 +9,3 @@
lf=(sint)strlen(fname);
deb=path1;
-@@ -2121,7 +2121,7 @@
- strcpy(local_prompt,"\n\nEnter new name to avoid overwriting ");
- strcat(local_prompt," [%s]: ");
- fprintf(stdout,local_prompt,file_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != EOS) strcpy(file_name,temp);
- }
- }
-@@ -2129,7 +2129,7 @@
- strcpy(local_prompt,prompt);
- strcat(local_prompt," [%s]: ");
- fprintf(stdout,local_prompt,file_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != EOS) strcpy(file_name,temp);
- }
-
-@@ -2335,7 +2335,7 @@
- if (usemenu)
- fprintf(stdout,"\nUse the existing GUIDE TREE file, %s (y/n) ? [y]: ",
- tree_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != 'n' && *temp != 'N') {
- strcpy(phylip_name,tree_name);
- use_tree = TRUE;
-@@ -2567,7 +2567,7 @@
-
- fprintf(stdout,"\nEnter a name for the guide tree file [%s]: ",
- phylip_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != EOS)
- strcpy(phylip_name,temp);
- }
-@@ -2676,7 +2676,7 @@
- #endif
- fprintf(stdout,"\nUse the existing GUIDE TREE file for Profile 1, %s (y/n) ? [y]: ",
- tree_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != 'n' && *temp != 'N') {
- strcpy(p1_tree_name,tree_name);
- use_tree1 = TRUE;
-@@ -2702,7 +2702,7 @@
- #endif
- fprintf(stdout,"\nUse the existing GUIDE TREE file for Profile 2, %s (y/n) ? [y]: ",
- tree_name);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != 'n' && *temp != 'N') {
- strcpy(p2_tree_name,tree_name);
- use_tree2 = TRUE;
-@@ -3730,7 +3730,7 @@
- if(usemenu) {
- fprintf(stdout,"\nEnter a name for the parameter output file [%s]: ",
- parname);
-- gets(temp);
-+ fgets(temp,sizeof(temp),stdin);
- if(*temp != EOS)
- strcpy(parname,temp);
- }
diff --git a/biology/clustalw/files/patch-ae b/biology/clustalw/files/patch-ae
new file mode 100644
index 000000000000..b9e3678ea31b
--- /dev/null
+++ b/biology/clustalw/files/patch-ae
@@ -0,0 +1,138 @@
+--- amenu.c-orig Tue Feb 6 03:15:01 2001
++++ amenu.c Thu Mar 21 10:19:02 2002
+@@ -13,7 +13,8 @@
+ static jmp_buf jmpbuf;
+ #ifndef VMS
+ #ifndef AIX
+-#define BADSIG (void (*)())-1
++/* #define BADSIG (void (*)())-1 */
++#define BADSIG SIG_ERR
+ #endif
+ #endif
+
+@@ -176,7 +177,7 @@
+ fprintf(stdout," H. HELP\n");
+ fprintf(stdout," X. EXIT (leave program)\n\n\n");
+
+- getstr("Your choice",lin1);
++ getstr("Your choice",lin1,MAXLINE);
+
+ switch(toupper(*lin1)) {
+ case '1': seq_input(FALSE);
+@@ -260,7 +261,7 @@
+ fprintf(stdout," H. HELP\n");
+ fprintf(stdout," or press [RETURN] to go back to main menu\n\n\n");
+
+- getstr("Your choice",lin1);
++ getstr("Your choice",lin1,MAXLINE);
+ if(*lin1 == EOS) return;
+
+ switch(toupper(*lin1))
+@@ -353,7 +354,7 @@
+ fprintf(stdout," H. HELP\n");
+ fprintf(stdout," or press [RETURN] to go back to main menu\n\n\n");
+
+- getstr("Your choice",lin1);
++ getstr("Your choice",lin1,MAXLINE);
+ if(*lin1 == EOS) return;
+
+ switch(toupper(*lin1))
+@@ -449,7 +450,7 @@
+ fprintf(stdout,"\n\n");
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if( *lin2 == EOS) {
+ return;
+ }
+@@ -525,7 +526,7 @@
+ fprintf(stdout,"--\n");
+
+
+- getstr("\n\nEnter number (or [RETURN] to exit)",lin2);
++ getstr("\n\nEnter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if(*lin2 == EOS) return(output_struct_penalties);
+
+ switch(toupper(*lin2))
+@@ -594,7 +595,7 @@
+ fprintf(stdout," H. HELP\n");
+ fprintf(stdout," or press [RETURN] to go back to main menu\n\n\n");
+
+- getstr("Your choice",lin1);
++ getstr("Your choice",lin1,MAXLINE);
+ if(*lin1 == EOS) return;
+
+ switch(toupper(*lin1))
+@@ -669,7 +670,7 @@
+ fprintf(stdout,"\n");
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if(*lin2 == EOS) return;
+
+ switch(toupper(*lin2)) {
+@@ -752,7 +753,7 @@
+ fprintf(stdout,"\n");
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if(*lin2 == EOS) return;
+
+ switch(toupper(*lin2)) {
+@@ -886,7 +887,7 @@
+
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if( *lin2 == EOS) {
+ if(dnaflag) {
+ dna_pw_go_penalty = pw_go_penalty;
+@@ -1008,7 +1009,7 @@
+ fprintf(stdout," 8. Protein Gap Parameters\n\n");
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+
+ if(*lin2 == EOS) {
+ if(dnaflag) {
+@@ -1101,7 +1102,7 @@
+ fprintf(stdout," 5. Toggle End Gap Separation :%s\n\n",(!use_endgaps) ? "OFF" : "ON");
+ fprintf(stdout," H. HELP\n\n\n");
+
+- getstr("Enter number (or [RETURN] to exit)",lin2);
++ getstr("Enter number (or [RETURN] to exit)",lin2,MAXLINE);
+
+ if(*lin2 == EOS) return;
+
+@@ -1115,7 +1116,7 @@
+ case '3':
+ fprintf(stdout,"Hydrophilic Residues Currently: %s\n",hyd_residues);
+
+- getstr("Enter residues (or [RETURN] to quit)",lin1);
++ getstr("Enter residues (or [RETURN] to quit)",lin1,MAXLINE);
+ if (*lin1 != EOS) {
+ for (i=0;i<strlen(hyd_residues) && i<26;i++) {
+ c = lin1[i];
+@@ -1167,7 +1168,7 @@
+ fprintf(stdout,"--\n");
+
+
+- getstr("\n\nEnter number (or [RETURN] to exit)",lin2);
++ getstr("\n\nEnter number (or [RETURN] to exit)",lin2,MAXLINE);
+ if(*lin2 == EOS) return(matn);
+
+ i=toupper(*lin2)-'0';
+@@ -1202,7 +1203,7 @@
+ fprintf(stdout,"\n%s\n",title);
+ strcpy(line,prompt);
+ strcat(line, "(y/n) ? [y]");
+- getstr(line,lin2);
++ getstr(line,lin2,80);
+ if ((*lin2 != 'n') && (*lin2 != 'N'))
+ return('y');
+ else
diff --git a/biology/clustalw/files/patch-af b/biology/clustalw/files/patch-af
new file mode 100644
index 000000000000..102413fb84c6
--- /dev/null
+++ b/biology/clustalw/files/patch-af
@@ -0,0 +1,11 @@
+--- clustalw.h-orig Thu Mar 21 10:15:28 2002
++++ clustalw.h Thu Mar 21 10:15:43 2002
+@@ -234,7 +234,7 @@
+ char *blank_to_(char *str);
+ char *upstr(char *str);
+ char *lowstr(char *str);
+-void getstr(char *instr, char *outstr);
++void getstr(char *instr, char *outstr, int len);
+ double getreal(char *instr, double minx, double maxx, double def);
+ int getint(char *instr, int minx, int maxx, int def);
+ void do_system(void);
diff --git a/biology/clustalw/files/patch-ag b/biology/clustalw/files/patch-ag
new file mode 100644
index 000000000000..9cde8d9d019d
--- /dev/null
+++ b/biology/clustalw/files/patch-ag
@@ -0,0 +1,128 @@
+--- interface.c-orig Thu Mar 21 10:19:26 2002
++++ interface.c Thu Mar 21 10:22:18 2002
+@@ -1170,7 +1170,7 @@
+ if(strstr(temp, help_marker)){
+ if(usemenu) {
+ fprintf(stdout,"\n");
+- getstr("Press [RETURN] to continue",lin2);
++ getstr("Press [RETURN] to continue",lin2,MAXLINE);
+ }
+ fclose(help_file);
+ return;
+@@ -1182,7 +1182,7 @@
+ if(usemenu) {
+ if(nlines >= PAGE_LEN) {
+ fprintf(stdout,"\n");
+- getstr("Press [RETURN] to continue or X to stop",lin2);
++ getstr("Press [RETURN] to continue or X to stop",lin2,MAXLINE);
+ if(toupper(*lin2) == 'X') {
+ fclose(help_file);
+ return;
+@@ -1194,7 +1194,7 @@
+ }
+ if(usemenu) {
+ fprintf(stdout,"\n");
+- getstr("Press [RETURN] to continue",lin2);
++ getstr("Press [RETURN] to continue",lin2,MAXLINE);
+ }
+ fclose(help_file);
+ }
+@@ -1232,7 +1232,7 @@
+ ++nlines;
+ if(nlines >= PAGE_LEN) {
+ fprintf(stdout,"\n");
+- getstr("Press [RETURN] to continue or X to stop",lin2);
++ getstr("Press [RETURN] to continue or X to stop",lin2,MAXLINE);
+ if(toupper(*lin2) == 'X') {
+ fclose(file);
+ return;
+@@ -1243,7 +1243,7 @@
+ }
+ fclose(file);
+ fprintf(stdout,"\n");
+- getstr("Press [RETURN] to continue",lin2);
++ getstr("Press [RETURN] to continue",lin2,MAXLINE);
+ }
+
+
+@@ -1692,7 +1692,7 @@
+ FILE *infile;
+
+ if(usemenu)
+- getstr("Enter name of the matrix file",lin2);
++ getstr("Enter name of the matrix file",lin2,MAXLINE);
+ else
+ strcpy(lin2,str);
+
+@@ -1718,7 +1718,7 @@
+ FILE *infile;
+
+ if(usemenu)
+- getstr("Enter name of the matrix file",lin2);
++ getstr("Enter name of the matrix file",lin2,MAXLINE);
+ else
+ strcpy(lin2,str);
+
+@@ -2121,7 +2121,7 @@
+ strcpy(local_prompt,"\n\nEnter new name to avoid overwriting ");
+ strcat(local_prompt," [%s]: ");
+ fprintf(stdout,local_prompt,file_name);
+- gets(temp);
++ fgets(temp,FILENAMELEN+1,stdin);
+ if(*temp != EOS) strcpy(file_name,temp);
+ }
+ }
+@@ -2129,7 +2129,7 @@
+ strcpy(local_prompt,prompt);
+ strcat(local_prompt," [%s]: ");
+ fprintf(stdout,local_prompt,file_name);
+- gets(temp);
++ fgets(temp,FILENAMELEN+1,stdin);
+ if(*temp != EOS) strcpy(file_name,temp);
+ }
+
+@@ -2335,7 +2335,7 @@
+ if (usemenu)
+ fprintf(stdout,"\nUse the existing GUIDE TREE file, %s (y/n) ? [y]: ",
+ tree_name);
+- gets(temp);
++ fgets(temp,MAXLINE,stdin);
+ if(*temp != 'n' && *temp != 'N') {
+ strcpy(phylip_name,tree_name);
+ use_tree = TRUE;
+@@ -2567,7 +2567,7 @@
+
+ fprintf(stdout,"\nEnter a name for the guide tree file [%s]: ",
+ phylip_name);
+- gets(temp);
++ fgets(temp,MAXLINE,stdin);
+ if(*temp != EOS)
+ strcpy(phylip_name,temp);
+ }
+@@ -2676,7 +2676,7 @@
+ #endif
+ fprintf(stdout,"\nUse the existing GUIDE TREE file for Profile 1, %s (y/n) ? [y]: ",
+ tree_name);
+- gets(temp);
++ fgets(temp,MAXLINE,stdin);
+ if(*temp != 'n' && *temp != 'N') {
+ strcpy(p1_tree_name,tree_name);
+ use_tree1 = TRUE;
+@@ -2702,7 +2702,7 @@
+ #endif
+ fprintf(stdout,"\nUse the existing GUIDE TREE file for Profile 2, %s (y/n) ? [y]: ",
+ tree_name);
+- gets(temp);
++ fgets(temp,MAXLINE,stdin);
+ if(*temp != 'n' && *temp != 'N') {
+ strcpy(p2_tree_name,tree_name);
+ use_tree2 = TRUE;
+@@ -3730,7 +3730,7 @@
+ if(usemenu) {
+ fprintf(stdout,"\nEnter a name for the parameter output file [%s]: ",
+ parname);
+- gets(temp);
++ fgets(temp,FILENAMELEN+1,stdin);
+ if(*temp != EOS)
+ strcpy(parname,temp);
+ }
diff --git a/biology/clustalw/files/patch-ah b/biology/clustalw/files/patch-ah
new file mode 100644
index 000000000000..e16d4f3b28d9
--- /dev/null
+++ b/biology/clustalw/files/patch-ah
@@ -0,0 +1,11 @@
+--- sequence.c-orig Thu Mar 21 10:22:35 2002
++++ sequence.c Thu Mar 21 10:22:53 2002
+@@ -922,7 +922,7 @@
+ static Boolean dnaflag1;
+
+ if(usemenu)
+- getstr("Enter the name of the sequence file",line);
++ getstr("Enter the name of the sequence file",line,FILENAMELEN+1);
+ else
+ strcpy(line,seqname);
+ if(*line == EOS) return -1;
diff --git a/biology/clustalw/files/patch-ai b/biology/clustalw/files/patch-ai
new file mode 100644
index 000000000000..a228ed5b1eb4
--- /dev/null
+++ b/biology/clustalw/files/patch-ai
@@ -0,0 +1,11 @@
+--- trees.c-orig Thu Mar 21 10:23:04 2002
++++ trees.c Thu Mar 21 10:23:20 2002
+@@ -845,7 +845,7 @@
+ fprintf(stdout,"\n or 3) use the PHYLIP package.");
+ fprintf(stdout,"\n\n");
+ if (usemenu)
+- getstr("Press [RETURN] to continue",dummy);
++ getstr("Press [RETURN] to continue",dummy,10);
+ }
+
+
diff --git a/biology/clustalw/files/patch-ad b/biology/clustalw/files/patch-aj
index da64accff072..d5881bdb2c03 100644
--- a/biology/clustalw/files/patch-ad
+++ b/biology/clustalw/files/patch-aj
@@ -1,11 +1,15 @@
---- util.c.orig Wed Jun 7 16:50:08 2000
-+++ util.c Tue Aug 8 02:59:43 2000
-@@ -174,7 +174,7 @@
- void getstr(char *instr,char *outstr)
+--- util.c-orig Thu Mar 21 10:15:59 2002
++++ util.c Thu Mar 21 10:17:11 2002
+@@ -171,10 +171,10 @@
+ return str;
+ }
+
+-void getstr(char *instr,char *outstr)
++void getstr(char *instr,char *outstr, int len)
{
fprintf(stdout,"%s: ",instr);
- gets(outstr);
-+ fgets(outstr,sizeof(outstr),stdin);
++ fgets(outstr, len, stdin);
}
double getreal(char *instr,double minx,double maxx,double def)
@@ -14,7 +18,7 @@
while(TRUE) {
fprintf(stdout,"%s (%.1f-%.1f) [%.1f]: ",instr,minx,maxx,def);
- gets(line);
-+ fgets(line,sizeof(line),stdin);
++ fgets(line, MAXLINE, stdin);
status=sscanf(line,"%f",&ret);
if(status == EOF) return def;
if(ret>maxx) {
@@ -23,7 +27,16 @@
fprintf(stdout,"%s (%d..%d) [%d]: ",
instr,(pint)minx,(pint)maxx,(pint)def);
- gets(line);
-+ fgets(line,sizeof(line),stdin);
++ fgets(line, MAXLINE, stdin);
status=sscanf(line,"%d",&ret);
if(status == EOF) return def;
if(ret>maxx) {
+@@ -230,7 +230,7 @@
+ {
+ char line[MAXLINE];
+
+- getstr("\n\nEnter system command",line);
++ getstr("\n\nEnter system command",line,MAXLINE);
+ if(*line != EOS)
+ system(line);
+ fprintf(stdout,"\n\n");