aboutsummaryrefslogtreecommitdiff
path: root/biology
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-06 20:04:15 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-06 20:04:15 +0000
commit2a1c4bb9937204cd60f99aaba25c55ba12c50aeb (patch)
tree4f8684f6204b9a667b4eeae3b6cb52033c90ba64 /biology
parent1844b242bb6a07032fb931d46419134e316db0c9 (diff)
downloadports-2a1c4bb9937204cd60f99aaba25c55ba12c50aeb.tar.gz
ports-2a1c4bb9937204cd60f99aaba25c55ba12c50aeb.zip
This program calculate formula weight and percent of each elements.
PR: ports/13467 Submitted by: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
Notes
Notes: svn path=/head/; revision=21329
Diffstat (limited to 'biology')
-rw-r--r--biology/xmolwt/Makefile41
-rw-r--r--biology/xmolwt/distinfo1
-rw-r--r--biology/xmolwt/files/patch-aa13
-rw-r--r--biology/xmolwt/pkg-comment1
-rw-r--r--biology/xmolwt/pkg-descr14
-rw-r--r--biology/xmolwt/pkg-plist12
6 files changed, 82 insertions, 0 deletions
diff --git a/biology/xmolwt/Makefile b/biology/xmolwt/Makefile
new file mode 100644
index 000000000000..bde060294e74
--- /dev/null
+++ b/biology/xmolwt/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: xmolwt/gmolwt
+# Version required: 0.3
+# Date created: 1999-08-30
+# Whom: Ryo MIYAMOTO <rmiya@cc.hirosaki-u.ac.jp>
+#
+# $FreeBSD$
+
+DISTNAME= xmolwt-0.3
+CATEGORIES= biology
+MASTER_SITES= http://www.st.hirosaki-u.ac.jp/~rmiya/xmolwt/
+
+MAINTAINER= rmiya@cc.hirosaki-u.ac.jp
+
+LIB_DEPENDS= gdk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ glib12.2:${PORTSDIR}/devel/glib12 \
+ gmodule12.2:${PORTSDIR}/devel/glib12 \
+ gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
+ intl.1:${PORTSDIR}/devel/gettext
+
+USE_GMAKE= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}
+
+post-configure:
+ (cd ${WRKSRC}; ${CP} Makefile.gtk Makefile)
+
+pre-install:
+ (cd ${WRKSRC}; strip gmolwt)
+ ${RM} -rf ${PREFIX}/share/doc/xmolwt
+ ${MKDIR} ${PREFIX}/share/doc/xmolwt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/gmolwt ${PREFIX}/bin
+ (cd ${PREFIX}/bin; ln -s gmolwt molwt)
+ ${INSTALL_DATA} ${WRKSRC}/Howtouse.* ${PREFIX}/share/doc/xmolwt
+ ${INSTALL_DATA} ${WRKSRC}/Readme ${PREFIX}/share/doc/xmolwt
+ ${INSTALL_DATA} ${WRKSRC}/Xmolwt ${PREFIX}/share/doc/xmolwt
+ ${INSTALL_DATA} ${WRKSRC}/dot.gtkrc ${PREFIX}/share/doc/xmolwt
+ ${INSTALL_DATA} ${WRKSRC}/*.html ${PREFIX}/share/doc/xmolwt
+ ${INSTALL_DATA} ${WRKSRC}/*.gif ${PREFIX}/share/doc/xmolwt
+
+.include <bsd.port.mk>
diff --git a/biology/xmolwt/distinfo b/biology/xmolwt/distinfo
new file mode 100644
index 000000000000..950ea9355902
--- /dev/null
+++ b/biology/xmolwt/distinfo
@@ -0,0 +1 @@
+MD5 (xmolwt-0.3.tar.gz) = aa5c15b96a0868af3d3984c83ea6fc9d
diff --git a/biology/xmolwt/files/patch-aa b/biology/xmolwt/files/patch-aa
new file mode 100644
index 000000000000..283e381c93b4
--- /dev/null
+++ b/biology/xmolwt/files/patch-aa
@@ -0,0 +1,13 @@
+*** Makefile.gtk Sat Aug 28 19:46:47 1999
+--- Makefile Mon Aug 30 19:49:21 1999
+***************
+*** 3,8 ****
+--- 3,10 ----
+ GTKCONFIG = gtk12-config
+ OBJS = molwt.o usage.o element.o reduce.o count.o calculate.o initwidget.o allowcase.o inputformula.o addtolist.o
+
++ all: gmolwt
++
+ molwt: gmolwt
+ ln -s gmolwt molwt
+
diff --git a/biology/xmolwt/pkg-comment b/biology/xmolwt/pkg-comment
new file mode 100644
index 000000000000..058beeb062f2
--- /dev/null
+++ b/biology/xmolwt/pkg-comment
@@ -0,0 +1 @@
+This program calculate formula weight and percent of each elements.
diff --git a/biology/xmolwt/pkg-descr b/biology/xmolwt/pkg-descr
new file mode 100644
index 000000000000..e9dc5181eb3d
--- /dev/null
+++ b/biology/xmolwt/pkg-descr
@@ -0,0 +1,14 @@
+Xmolwt (Motif version)/Gmolwt (GTK+ version)
+
+This program calculate formula weight and percent of each elements
+for the given chemical formula.
+
+This porting is building up a GTK+ version of the program.
+If you want to use/build a Motif version,
+then use Makefile.motif which is attached.
+
+Please see the web site,
+ http://www.st.hirosaki-u.ac.jp/~rmiya/xmolwt/xmolwt-e.html
+
+--
+rmiya
diff --git a/biology/xmolwt/pkg-plist b/biology/xmolwt/pkg-plist
new file mode 100644
index 000000000000..86a3bb347c54
--- /dev/null
+++ b/biology/xmolwt/pkg-plist
@@ -0,0 +1,12 @@
+bin/gmolwt
+bin/molwt
+share/doc/xmolwt/Howtouse.doc
+share/doc/xmolwt/Howtouse.jp
+share/doc/xmolwt/Readme
+share/doc/xmolwt/Xmolwt
+share/doc/xmolwt/dot.gtkrc
+share/doc/xmolwt/xmolwt.html
+share/doc/xmolwt/xmolwt-e.html
+share/doc/xmolwt/xmolwt.gif
+share/doc/xmolwt/gmolwt.gif
+@dirrm share/doc/xmolwt